Jump to content


Photo

web interface access denied on https://192.168.1.2:8920/


Best Answer OneCD , 25 February 2019 - 10:23 PM

However by default I still cannot open the page as  http, it still tries to open it as https, which i don't have a certificate for so the connection is rejected. I couldn't find the line in the qpkg.conf responsible for it or did I miss it?

 

Are you logged into your QTS via HTTPS? Or HTTP?

 

I'm not sure but I think if you log into QTS via HTTPS, it will then try and open QPKG app pages in HTTPS too. Maybe try commenting-out that line in qpkg.conf with a hash character:

#Web_SSL_Port = 8920

Then reload App Center. This will leave the value of 'Web_Port' as a valid UI port.

 

 

Another idea is to maybe create an exception in your web-browser for that page?

Go to the full post


  • Please log in to reply
18 replies to this topic

#1 nevolex OFFLINE  

nevolex

    Member

  • Members
  • 16 posts
  • Local time: 09:25 AM

Posted 25 February 2019 - 01:46 AM

Hi guys,

 

I got my Emby installed and it works just fine, however I cannot access it by clicking on the icon in the QTS,  it basically opens up a page with address https://192.168.1.2:8920/ and the port which is not in use. 

 

I understand there is something with a certificate. however it is rather a strange behavior, for example I am not using the port 8920 for ssl it has been changed to 9001 but still every time I click on it, emby forwards me to this page with the default port https://192.168.1.2:8920/.

 

Is there  a way to configure Emby to open up a default page http://192.168.1.2:9000 and not https://192.168.1.2:8920/ so I don't have to every time change https to http and port from 8920 to 9000

 

Kind regards


Edited by nevolex, 25 February 2019 - 01:47 AM.

  • OneCD likes this

#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136163 posts
  • Local time: 04:25 PM

Posted 25 February 2019 - 02:11 AM

Hi, outside of configuring SSL, I don't think there's a way. You may want to just setup a browser bookmark with the http url.


  • nevolex likes this

#3 nevolex OFFLINE  

nevolex

    Member

  • Members
  • 16 posts
  • Local time: 09:25 AM

Posted 25 February 2019 - 02:19 AM

Hi Luke, thank you for the quick answer, I just had another question, is there a way Emby can be opened with a different IP address, for example 192.168.1.25 and not 192.168.1.2. I have a local simple dns server running in the network to resolve a few local ip addresses, for example 192.168.1.2 can actually be opened as qnap.local however as emby runs from the same ip but the different port, there is no way i can just map a new "domain name" to it.

 

Thank you


Edited by nevolex, 25 February 2019 - 02:21 AM.


#4 OneCD ONLINE  

OneCD

    Member

  • Members
  • 27 posts
  • Local time: 06:25 AM
  • Location"... there, behind that sofa!"

Posted 25 February 2019 - 04:06 AM

Hi guys,

 

I got my Emby installed and it works just fine, however I cannot access it by clicking on the icon in the QTS,  it basically opens up a page with address https://192.168.1.2:8920/ and the port which is not in use.

You''ll need to update the App Center icon information.

 

Edit [/etc/config/qpkg.conf], find the Emby configuration block, and ensure your web UI port number is adjusted. Then reload the App Center and try the QPKG icon again.


Edited by OneCD, 25 February 2019 - 04:07 AM.

  • nevolex likes this

#5 nevolex OFFLINE  

nevolex

    Member

  • Members
  • 16 posts
  • Local time: 09:25 AM

Posted 25 February 2019 - 06:46 AM

Hi. OneCD I tried to open this file in VIM but it seems to be empty?

/etc/config/qpkg.conf

You''ll need to update the App Center icon information.

 

Edit [/etc/config/qpkg.conf], find the Emby configuration block, and ensure your web UI port number is adjusted. Then reload the App Center and try the QPKG icon again.



#6 OneCD ONLINE  

OneCD

    Member

  • Members
  • 27 posts
  • Local time: 06:25 AM
  • Location"... there, behind that sofa!"

Posted 25 February 2019 - 04:17 PM

Can you please run this command and post the result shown in your terminal session?

qfile=/etc/config/qpkg.conf; cat $qfile; ll $qfile

Edited by OneCD, 25 February 2019 - 04:19 PM.

  • nevolex likes this

#7 nevolex OFFLINE  

nevolex

    Member

  • Members
  • 16 posts
  • Local time: 09:25 AM

Posted 25 February 2019 - 09:33 PM

 

Can you please run this command and post the result shown in your terminal session?

qfile=/etc/config/qpkg.conf; cat $qfile; ll $qfile

Thank you OneCD, please find the log attached

 

Attached Files

  • Attached File  log.txt   11.53KB   7 downloads

Edited by nevolex, 25 February 2019 - 09:34 PM.


#8 OneCD ONLINE  

OneCD

    Member

  • Members
  • 27 posts
  • Local time: 06:25 AM
  • Location"... there, behind that sofa!"

Posted 25 February 2019 - 09:40 PM

Hmm... the file definitely exists then. :)

 

When you selected the filename for editing via vim, did you use the correct character-case?


  • nevolex likes this

#9 OneCD ONLINE  

OneCD

    Member

  • Members
  • 27 posts
  • Local time: 06:25 AM
  • Location"... there, behind that sofa!"

Posted 25 February 2019 - 09:43 PM

An alternative to direct file editing is to use QTS's own config file modification utility.

 

Example: to change the Emby SSL port to be 12345, use:

setcfg EmbyServer Web_SSL_Port 12345 -f /etc/config/qpkg.conf

  • nevolex likes this

#10 nevolex OFFLINE  

nevolex

    Member

  • Members
  • 16 posts
  • Local time: 09:25 AM

Posted 25 February 2019 - 10:02 PM

Thanks a lot OneCD, it did work just fine on the 2nd attempt, not sure what file I opened in VIm first time, :) , I have adjusted the port. However by default I still cannot open the page as  http, it still tries to open it as https, which i don't have a certificate for so the connection is rejected. I couldn't find the line in the qpkg.conf responsible for it or did I miss it? Thanks again



#11 OneCD ONLINE  

OneCD

    Member

  • Members
  • 27 posts
  • Local time: 06:25 AM
  • Location"... there, behind that sofa!"

Posted 25 February 2019 - 10:23 PM   Best Answer

However by default I still cannot open the page as  http, it still tries to open it as https, which i don't have a certificate for so the connection is rejected. I couldn't find the line in the qpkg.conf responsible for it or did I miss it?

 

Are you logged into your QTS via HTTPS? Or HTTP?

 

I'm not sure but I think if you log into QTS via HTTPS, it will then try and open QPKG app pages in HTTPS too. Maybe try commenting-out that line in qpkg.conf with a hash character:

#Web_SSL_Port = 8920

Then reload App Center. This will leave the value of 'Web_Port' as a valid UI port.

 

 

Another idea is to maybe create an exception in your web-browser for that page?


  • nevolex likes this

#12 nevolex OFFLINE  

nevolex

    Member

  • Members
  • 16 posts
  • Local time: 09:25 AM

Posted 25 February 2019 - 10:31 PM

OneCD, it did the trick, thanks a lot!



#13 OneCD ONLINE  

OneCD

    Member

  • Members
  • 27 posts
  • Local time: 06:25 AM
  • Location"... there, behind that sofa!"

Posted 26 February 2019 - 12:58 AM

Awesome! :)

 

Which part worked? Did you comment the Web_SSL_Port line or did you create a browser site exception?



#14 nevolex OFFLINE  

nevolex

    Member

  • Members
  • 16 posts
  • Local time: 09:25 AM

Posted 26 February 2019 - 01:06 AM

Awesome! :)

 

Which part worked? Did you comment the Web_SSL_Port line or did you create a browser site exception?

 

Commenting out #Web_SSL_Port = 8920, which is basically now forcing emby to use http over https and also connecting the right port Web_Port = 9000  (i changed it from the default one) that works too. I edited the conf directly with VIM.

 

Did not have to add any exception to browser which makes this a good unified solution, thanks again. Much appreciate your help!


  • OneCD likes this

#15 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136163 posts
  • Local time: 04:25 PM

Posted 26 February 2019 - 01:08 AM

How difficult was all of this? Is it something we can/should automate in the package? 



#16 OneCD ONLINE  

OneCD

    Member

  • Members
  • 27 posts
  • Local time: 06:25 AM
  • Location"... there, behind that sofa!"

Posted 26 February 2019 - 01:12 AM

Commenting out #Web_SSL_Port = 8920, which is basically now forcing emby to use http over https and also connecting the right port Web_Port = 9000  (i changed it from the default one) that works too. I edited the conf directly with VIM.

 

Great! Good work.

 

@Luke, I'm not sure. Changing QPKG port numbers is always a pain as QTS has no mechanism to read the new port number assigned in the app. It's like creating a Windows desktop shortcut, then moving the target. Windows has no idea where the target went.

 

A solution I use in some of my own packages is to include an automated check for that app's web UI port number, then write that into the QTS App Center config file so the user will have a valid start icon. But, it only updates when the package is started. ;)

 

This is a snippet:

        if [[ $(/sbin/getcfg misc enable_https -d 0 -f "$SETTINGS_PATHFILE") = 1 ]]; then
            ui_port=$(/sbin/getcfg misc https_port -d 0 -f "$SETTINGS_PATHFILE")
            msg+='HTTPS port: '
        else
            ui_port=$(/sbin/getcfg misc port -d 0 -f "$SETTINGS_PATHFILE")
            msg+='HTTP port: '
        fi

        if [[ $ui_port -gt 0 ]]; then
            /sbin/setcfg $QPKG_NAME Web_Port $ui_port -f "$QPKG_CONF_PATHFILE"
            msg+=$ui_port
        else
             msg='! no web service port found'
        fi

Edited by OneCD, 26 February 2019 - 01:16 AM.


#17 nevolex OFFLINE  

nevolex

    Member

  • Members
  • 16 posts
  • Local time: 09:25 AM

Posted 26 February 2019 - 01:15 AM

How difficult was all of this? Is it something we can/should automate in the package? 

 

It was really easy, basically I had to do was editing the file in /etc/config/qpkg.conf

 

I changed 2 lines:

 

Web_Port = xxxx - custom port I set up earlier in emby web interface for http connection so it reflects the changes in the web link (emby icon) in QTS

 

And commented # like that

 

#Web_SSL_Port = 8920to bypass https and now even thought I connect to qts over https, emby runs perfectly fine with http. It just says that https is not available would you like to connect any way.

 

Cheers



#18 Moogle Stiltzkin OFFLINE  

Moogle Stiltzkin

    Member

  • Members
  • 13 posts
  • Local time: 04:25 AM

Posted 18 May 2019 - 09:01 PM

i posted in the other thread before i noticed this one

https://emby.media/c...y-server/page-2

 

but essential the default emby icon link in appcenter tries to open on the https port url which doesn't work by default (at least for me anyway).

 

the only way for me to access it to NOT use the clickable link in appcenter for emby....

 

instead i have to type in browser url

 

http://192.168.0.xxx...96/mediabrowser

 

 

which does work.

 

 

yes im logged into QTS via https.

 

anyway it weirds how emby clickable url goes to a broken url. maybe you should make this a setting in emby to use https or not. cause it's just defaulting to https which doesn't work.

 

needs a solution for https to work ideally if possible.

 

right now all i'm using emby for is local access, but at some point i'd like to use emby for remote access later  :ph34r:



#19 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136163 posts
  • Local time: 04:25 PM

Posted 18 May 2019 - 10:01 PM

Hi, unfortunately it is a QNAP button and it wants to use https but in order for that to work you need to set it up in the advanced server section of emby server. So it's a little bit of a chicken and egg scenario.


  • Moogle Stiltzkin likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users