Jump to content

No compatible streams on some titles [solved]

Go to solution Solved by Luke,

Recommended Posts


Hi forum!


Emby's organization has been great. Unfortunately I've been hitting the "no compatible streams" error when trying to play some content. Length and bitrate of the content doesn't seem to affect it, I can't figure out why some files hit this error and others don't.


When I select "play" from the web interface, the system goes to the loading screen, the loading animation runs for about two minutes, then I get an error indicating there are no compatible streams. On Roku the video loads for a long time and then does not play, or sometimes plays for a few seconds then hangs for another minute.


It looks like these files are forcing transcoding. I've been using a slightly modified version of handbrake's settings for Roku with web optimization enabled. If there are better handbrake settings to avoid retranscoding, let me know.


(Looks like TranscodeReasons=SubtitleCodecNotSupported is added in the encoding file -- are my embedded subtitles causing the issue? Is it better practice to keep subs as separate files in the library?)


Thanks for your time and a great app,


(Log.txt is the server log, log2-4.txt are transcoding logs that all happened around the same time.)





Edited by brownbat
Link to comment
Share on other sites


Still learning about the issue, but there are definitely resources on this site that are helping, it's just taken me a while to find all of them: 






Sorry for asking an old question.


The only improvement I'd recommend is I think you could shorten the wait time to error message in some situations.


If Emby is repeatedly and consistently failing to transcode any videos, it might just want to fail out to an error message as soon as it discovers an incompatible stream.


I dunno, that might hit some false positives though.


Thanks again for the really interesting program, I think I'm slowly figuring it out. Appreciate any pointers or recommendations for other threads to read or keywords to search for.

Link to comment
Share on other sites

  • Solution

Hi @@brownbat, what's happening here is that transcoding is not actually failing, but rather it's  just not going fast enough to be playable. I  notice these examples are burning in subtitles, and that is a very expensive process.


Can you try turning off the subtitles prior to playback and see how that compares? thanks !

  • Like 1
Link to comment
Share on other sites


Absolutely right @@Luke. Yesterday I reencoded without any subs and replaced the file, that worked great.


I'm only now finding all the comment threads where you weighed in on subs and transcoding - you've posted lots of great info on this topic, thanks for your patience on it.


I was preserving all subs from the DVDs by embedding them in the mkv... I'll start converting the collection to srt. From what you've written, looks like that's the preferred way forward.


Thanks again.

Edited by brownbat
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...