Jump to content


Photo
- - - - -

Legacy folder view broken

legacy folder 4.0.0.2 wmc

  • Please log in to reply
61 replies to this topic

#41 One2Go OFFLINE  

One2Go

    Advanced Member

  • Members
  • 545 posts
  • Local time: 01:08 PM

Posted 26 March 2019 - 11:33 AM

Hi

 

I believe I have done this already and it did not work.  I am running Server 4.0.3.0 and EMC 3.0.317.0 and I changed my movie folder to mixed content as mentioned earlier in this thread, however the collections are still not nesting in EMC or on the web client.

 

Sharon

 

.......

 

Also, will the collections show up in nested collection folders under the Movie Folder on my EMC or will they only show up under collections?  I'd like them to just be in the movie folder where they used to be but nested correctly

Your problem may be that you are running server version 4.0.3.0 which I am NOT using. After updating my setup to that version I found out that it does not do the folder view as expected and I simply deleted the version 4.0.3.0 system folder and renamed the old system folder. That is the easy way to get back to the previous version 4.* of the Emby server. I have stayed with version 4.0.1.0 until this folder / nested / legacy view is solved.

 

If you want to have a resemblance of the folder view using collections it is a time consuming creation of collections structure as well as possible file and directory restructuring. Not what I was prepared to spend my time on.


Edited by One2Go, 26 March 2019 - 11:36 AM.


#42 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153333 posts
  • Local time: 01:08 PM

Posted 26 March 2019 - 02:22 PM

The upcoming 4.1 release will have improved folder views. Thanks.



#43 shavid0610 OFFLINE  

shavid0610

    Advanced Member

  • Members
  • 41 posts
  • Local time: 05:08 PM

Posted 30 March 2019 - 03:57 AM

HI all

 

Thanks for all your advice.  I used the emby Web Client to create collections and when I went back into EMC all my collections were nested happily together.

 

I will probably go through all my collections in my file structure at some point and flatten them out as I found it harder to locate the files I wanted to play with the meta data in the meta data manager while they were filed in this manner.  Not a huge priority though as the system is now back to looking like I want it to.

 

On a side note - How can I get the EHS to show an image for Movies by Genre?  As this is not a menu item under My Media I can't choose an artwork for it.  I have chosen art work for all the actual genres which works beautifully but can't see any way to show an image for the menu item "Movies by Genre" in the EHS.

 

Thanks again for your help



#44 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153333 posts
  • Local time: 01:08 PM

Posted 30 March 2019 - 07:54 PM

HI all

 

Thanks for all your advice.  I used the emby Web Client to create collections and when I went back into EMC all my collections were nested happily together.

 

I will probably go through all my collections in my file structure at some point and flatten them out as I found it harder to locate the files I wanted to play with the meta data in the meta data manager while they were filed in this manner.  Not a huge priority though as the system is now back to looking like I want it to.

 

On a side note - How can I get the EHS to show an image for Movies by Genre?  As this is not a menu item under My Media I can't choose an artwork for it.  I have chosen art work for all the actual genres which works beautifully but can't see any way to show an image for the menu item "Movies by Genre" in the EHS.

 

Thanks again for your help

 

There's currently no way to assign that image but i would have thought that the app would randomly pick something to put there. @ebr can elaborate on if this is true or not. It might not be given the age of the app at this point. Thanks.



#45 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 50877 posts
  • Local time: 01:08 PM

Posted 31 March 2019 - 09:35 AM

EMC would be looking for an image in the old "imagesByName" folder.  You would need to name this image "Movies by Genre.png" (or .jpg).



#46 One2Go OFFLINE  

One2Go

    Advanced Member

  • Members
  • 545 posts
  • Local time: 01:08 PM

Posted 31 March 2019 - 01:24 PM

EMC would be looking for an image in the old "imagesByName" folder.  You would need to name this image "Movies by Genre.png" (or .jpg).

I have tried also to get an image to show for Movies by Genre but to no avail. When you create a library you get to choose, primary, logo and backdrop which all display just fine in EMC. I can assign images to any of the individual genre but on the EHS I have yet to discover how to do that, the same for Weather Forecast.

 

What is the path to where the ImagesByName folder needs to be created and the image needs to be placed? In the MB 2.6 it is under C:\Program Data\MediaBrowser\ImagesByName and then the associated subfolders. This does not work under the Emby-Server folder regardless of what you name the images.

 

Any Help would be appreciated.

 

Also any chance to register with Yahoo so that we get the Weather app working again. Throgmorton suggested to sweet talk to you to get the Weather App working again :D



#47 shavid0610 OFFLINE  

shavid0610

    Advanced Member

  • Members
  • 41 posts
  • Local time: 05:08 PM

Posted 01 April 2019 - 03:10 AM

EMC would be looking for an image in the old "imagesByName" folder.  You would need to name this image "Movies by Genre.png" (or .jpg).

 

I though this folder no longer existed with the new versions.  Is there are way to create it and if so where do you put it so the EHS will look in the right spot for it.

 

Thank You



#48 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153333 posts
  • Local time: 01:08 PM

Posted 01 April 2019 - 11:02 AM

@Teddy do you have an example of this?

#49 Teddy OFFLINE  

Teddy

    Advanced Member

  • Members
  • 412 posts
  • Local time: 07:08 PM
  • LocationMadrid (SPAIN)

Posted 02 April 2019 - 02:11 PM

@Teddy do you have an example of this?

I never use the Movies by Genre folder, but if I activate it, WMC shows the folders of the first 4 movies of that genre. Although the folder exists in C: \ Users \ MediaCenter \ AppData \ Roaming \ Emby-Server \ metadata.
I do not know if with this I can help.

Attached Files



#50 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153333 posts
  • Local time: 01:08 PM

Posted 02 April 2019 - 03:01 PM

Thanks Teddy.



#51 shavid0610 OFFLINE  

shavid0610

    Advanced Member

  • Members
  • 41 posts
  • Local time: 05:08 PM

Posted 03 April 2019 - 06:58 AM

Hi

 

I wanted to pass on this information in case is assists anyone with the same issue I am having.

 

I went ahead and flattened out all of my collections in my folder structure and found that my collections that had finally started working again after installing Auto box set plug in had vanished again.  Well, all but 8 of them...

 

So, I re-created my collections in my folder structure and re-scanned the libraries and they are all back again.

 

Maybe the folder structure does have some impact on showing the collections and having them nested?



#52 shavid0610 OFFLINE  

shavid0610

    Advanced Member

  • Members
  • 41 posts
  • Local time: 05:08 PM

Posted 03 April 2019 - 07:20 AM

I never use the Movies by Genre folder, but if I activate it, WMC shows the folders of the first 4 movies of that genre. Although the folder exists in C: \ Users \ MediaCenter \ AppData \ Roaming \ Emby-Server \ metadata.
I do not know if with this I can help.

 

Hi

 

I definitely don't have a path under C:\Users called mediacenter but I found the Emby-Server folder you mentioned by searching for it.  All of the sub-folders under genre had the images in them that I selected by using the Emby Web Client and they are working fine in EMC.

 

I looked at your attached images and wheat you have shown is not where we are trying to have an image show.  It is in the EHS - small little box to the left of the screen as seen in first image.  

 

You can see in second pic the other genres have an image here that is selected in the Emby Web Client but there is no where to set the image for Movies by Genre.  Can I save an image somewhere in the Emby-Server folder that will be seen by this little square in the EHS menu?

 

5ca4951b84ae5_Capture.jpg

 

5ca4957926039_Capture2.jpg



#53 Teddy OFFLINE  

Teddy

    Advanced Member

  • Members
  • 412 posts
  • Local time: 07:08 PM
  • LocationMadrid (SPAIN)

Posted 03 April 2019 - 07:46 AM

Hi

 

I definitely don't have a path under C:\Users called mediacenter but I found the Emby-Server folder you mentioned by searching for it.  All of the sub-folders under genre had the images in them that I selected by using the Emby Web Client and they are working fine in EMC.

 

I looked at your attached images and wheat you have shown is not where we are trying to have an image show.  It is in the EHS - small little box to the left of the screen as seen in first image.  

 

You can see in second pic the other genres have an image here that is selected in the Emby Web Client but there is no where to set the image for Movies by Genre.  Can I save an image somewhere in the Emby-Server folder that will be seen by this little square in the EHS menu?

 

5ca4951b84ae5_Capture.jpg

 

5ca4957926039_Capture2.jpg

The path C: \ Users called mediacenter is my user, you will have another different user.

The behavior with genres is similar to how it shows with the theme Chocolate, small little box has not image even though the sub-folders under genre had the images in them.

Attached Files

  • Attached File  EHS.bmp   2.77MB   6 downloads


#54 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 50877 posts
  • Local time: 01:08 PM

Posted 03 April 2019 - 09:02 AM

Look on your server dashboard at the "Paths" section and find the path for "Metadata"

 

Go to that path and find the folder named "General".  If it doesn't exist, create it.  Then go into that folder.

 

Now find or create a folder called "Movies By Genre" and put an image in there named "folder.jpg/png".

 

Run a library scan.



#55 One2Go OFFLINE  

One2Go

    Advanced Member

  • Members
  • 545 posts
  • Local time: 01:08 PM

Posted 03 April 2019 - 04:55 PM

Look on your server dashboard at the "Paths" section and find the path for "Metadata"

 

Go to that path and find the folder named "General".  If it doesn't exist, create it.  Then go into that folder.

 

Now find or create a folder called "Movies By Genre" and put an image in there named "folder.jpg/png".

 

Run a library scan.

I did all of that but it does not resolve this problem for me. I have tried for all kinds of NON Library entries on the EHS like Forecast and Movies By Genre but never could get an image to display on the EHS for set EHS entry. It will only work if there is a library created using the Settings/Library page on the Emby Server web page. I have tried different images like Folder.png, Poster.png, Logo.png as well as backdrop.png and again it works for libraries that were created. If there is no entry in the Libraries page like Collections I can't get images to show up on the EHS for set EHS entry.

 

In addition I tried the ImagesByName folder in different places as well as different entries and settings but it just doesn't work for me and the @throgmorton themes. Look at the attached pictures you can see the EHS entry and then the Recently Added Movies the Logo image displays but just not for the Movies By Genre entry.

 

Forecast Entry on EHS

5ca51d6875e58_EHSForecast.jpg

 

Movie By Genre

5ca51d82ecf29_EHSGenre.jpg

 

Recently Added shows image

5ca51da9a89fc_EHSGenreAdded.jpg

 

If there is an entry for Movies By Genre on the Emby Server Libraries Web Page like Collections you could assign images.


Edited by One2Go, 03 April 2019 - 04:58 PM.


#56 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 50877 posts
  • Local time: 01:08 PM

Posted 03 April 2019 - 09:09 PM

Okay, then it is quite possible that this does not work anymore in the current server.  EMC would have been the only thing that ever used this construct.



#57 shavid0610 OFFLINE  

shavid0610

    Advanced Member

  • Members
  • 41 posts
  • Local time: 05:08 PM

Posted 08 April 2019 - 03:40 AM

Look on your server dashboard at the "Paths" section and find the path for "Metadata"

 

Go to that path and find the folder named "General".  If it doesn't exist, create it.  Then go into that folder.

 

Now find or create a folder called "Movies By Genre" and put an image in there named "folder.jpg/png".

 

Run a library scan.

 

Yep I can confirm this doesn't work



#58 One2Go OFFLINE  

One2Go

    Advanced Member

  • Members
  • 545 posts
  • Local time: 01:08 PM

Posted 08 April 2019 - 05:39 PM

Now before you delete everything put an image in there called backdrop.jpg for me it started to appease in all the movie genre categories, not what I wanted so I deleted it. Settled on the idea with no image for movies for genre.

#59 One2Go OFFLINE  

One2Go

    Advanced Member

  • Members
  • 545 posts
  • Local time: 01:08 PM

Posted 10 April 2019 - 12:01 AM

Here is what I have settled on for the Movie By Genre EHS entry. I can't get a logo or image to display on the EHS level however I can use images assigned to the individual genres.

 

For example in the following location for the Animation Genre \\NUC-PC\Users\Admin\AppData\Roaming\Emby-Server\metadata\Genre\Animation\ I have an image called Poster.png and it will display. I use banners from different movies and create a poster the size of 1020 x 1500. Here is the Animation Genre image that I use.

 

Animation Genre Image:

5cad68c5c7820_GenreAnimation.png

This will result in the following Genre display from the EHS screen to showing the many different genres each with its own fitting image created from specific movie banners. The theme is Throgsoft's Maelstrom Thumb view. Then selecting that genre it displays a list of movies from it.

 

EHS screen of Movies by Genre (can't get an image into the box just text:

5cad69f4a6f04_EHSMoviesByGenre.jpg

 

Example of the Animation Genre:

5cad6a1a0c558_MoviesByGenreAnimation.jpg

 

The Animation Genre list of movies:

5cad6a614604e_MoviesByGenreDetail.jpg

 

This is the best I can do for movies by genre in EMC using the Throgsoft themes.



#60 shavid0610 OFFLINE  

shavid0610

    Advanced Member

  • Members
  • 41 posts
  • Local time: 05:08 PM

Posted 15 April 2019 - 11:42 PM

Now before you delete everything put an image in there called backdrop.jpg for me it started to appease in all the movie genre categories, not what I wanted so I deleted it. Settled on the idea with no image for movies for genre.

 

This didn't work either.  I have put these images in every folder I can think of that it might pull from but I am sure it is only grabbing it from the server and there is nowhere to assign an image to the genre menu in the server.

 

I am using the classic theme and have no problem getting images to show for each genre in the next screen down as I have set these images in the server, just can't get one to show in the EHS.  It's just bugging me as every other menu header has one except the Movies By Genre Menu header.  Makes my OCD itchy.

 

Sharon







Also tagged with one or more of these keywords: legacy, folder 4.0.0.2 wmc

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users