Jump to content


Photo

All mylocal Metadata is gone since the v4 update

update metadata lost

  • Please log in to reply
56 replies to this topic

#1 Grabbenswe OFFLINE  

Grabbenswe

    Member

  • Members
  • 12 posts
  • Local time: 07:55 AM

Posted 16 January 2019 - 03:54 PM

I am completely devastated here.

My Emby Server upgraded to v4 last night (something I have really been looking forward to).

Now it seems like a majority of my locally created metadata (mainly for my extensive Music Video library) is completely gone!!??

The paths are pointing to the right location where the data was before and after the upgrade.

I have tried to re-assign the paths again and then run several new library scans with no change.

I have restarted the pc and the Emby Server several times.

Now I am getting a slight panic attack that the YEARS of tagging all these videos with actors, composers and directors is forever gone!

And since there is no Metadata supplier to talk of, it is not possible to quickly re-create.

 

What can I possibly do?

Help! :-(

(The logfile I want to attach is more that 90 MB so I cant attach that one)

Attached Files


Edited by Grabbenswe, 16 January 2019 - 03:59 PM.


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 127006 posts
  • Local time: 02:55 AM

Posted 16 January 2019 - 04:56 PM

Hi there, do you have local metadata files in your media folders (nfo or xml)? 



#3 Grabbenswe OFFLINE  

Grabbenswe

    Member

  • Members
  • 12 posts
  • Local time: 07:55 AM

Posted 16 January 2019 - 05:29 PM

No I don't.

Tried it before but had problems with that people with other roles (such as composer, producer etc.) was saved as Actors in the local data (XML,NFO)

So I skipped the local metadata saving.



#4 Grabbenswe OFFLINE  

Grabbenswe

    Member

  • Members
  • 12 posts
  • Local time: 07:55 AM

Posted 16 January 2019 - 05:32 PM

My metadata/cache paths

5c3fa2de78f35_paths.jpg



#5 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 44185 posts
  • Local time: 02:55 AM

Posted 16 January 2019 - 06:24 PM

Hi we're very sorry about this but, if you want to customize metadata, then you really must save that metadata with the media or a complete rebuild will lose your customization (because you selected not to save them to files).



#6 Grabbenswe OFFLINE  

Grabbenswe

    Member

  • Members
  • 12 posts
  • Local time: 07:55 AM

Posted 17 January 2019 - 02:39 AM

:o

I just can't believe what I read!

Where could I find that info?

This is 1000 of hours of work.........

 

It makes me question even why this option exists, I mean who wants their work wiped out every time there is a rebuild?


Edited by Grabbenswe, 17 January 2019 - 02:43 AM.


#7 Maximus Naxsus OFFLINE  

Maximus Naxsus

    Advanced Member

  • Members
  • 83 posts
  • Local time: 08:55 AM
  • LocationLeiden, NL

Posted 17 January 2019 - 07:55 AM

Hi we're very sorry about this but, if you want to customize metadata, then you really must save that metadata with the media or a complete rebuild will lose your customization (because you selected not to save them to files).

 

Could 'offline file sync' help? (Control Panel\All Control Panel Items\Sync Centre)



#8 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 14114 posts
  • Local time: 11:55 PM
  • LocationWashington State

Posted 17 January 2019 - 08:06 AM

I guess technically metadata still exist in old table in the library.db.  The issue is all \library\xx\itemid folder containing images have already been cleared as they became obsolete during the first library scan.


  • Grabbenswe likes this

#9 maegibbons OFFLINE  

maegibbons

    Advanced Member

  • Members
  • 2219 posts
  • Local time: 07:55 AM
  • LocationLutterworth, England, UK

Posted 17 January 2019 - 08:07 AM

So. The next question is whst backups do you have of ypur pc and/or emby server directory structure?

You really need to roll back to 3.5.3 and ensble nfo and run full scan to dump data to nfo before doing upgrade again.

Krs

Mark

Sent from my SM-N950F using Tapatalk
  • Maximus Naxsus and Grabbenswe like this

#10 Grabbenswe OFFLINE  

Grabbenswe

    Member

  • Members
  • 12 posts
  • Local time: 07:55 AM

Posted 17 January 2019 - 04:29 PM

I guess technically metadata still exist in old table in the library.db.  The issue is all \library\xx\itemid folder containing images have already been cleared as they became obsolete during the first library scan.

 

Images I could live without, but if it was possible to recover the metadata from the old tables as you suggest that would make my day. 

But how?



#11 tman OFFLINE  

tman

    Advanced Member

  • Members
  • 243 posts
  • Local time: 07:55 AM

Posted 17 January 2019 - 04:41 PM

Not too happy here either. I just noticed tonight that my Emby install had updated to 4.0.0.2, and now loads of my movie metadata is either missing or incorrect. That's over 700 movies! Most art and logo images are missing, posters are either missing or incorrect etc. I've updated Emby many, many times, and never had this much trouble. Some movies had metadata in the movie folder, but I'd changed it at some point so it was all cached on an SSD in the server for speed.

I've spent so, so long getting everything the way I wanted it. Gutted.


  • Grabbenswe likes this

#12 Grabbenswe OFFLINE  

Grabbenswe

    Member

  • Members
  • 12 posts
  • Local time: 07:55 AM

Posted 17 January 2019 - 04:46 PM

I am using the 

 

Not too happy here either. I just noticed tonight that my Emby install had updated to 4.0.0.2, and now loads of my movie metadata is either missing or incorrect. That's over 700 movies! Most art and logo images are missing, posters are either missing or incorrect etc. I've updated Emby many, many times, and never had this much trouble. Some movies had metadata in the movie folder, but I'd changed it at some point so it was all cached on an SSD in the server for speed.

I've spent so, so long getting everything the way I wanted it. Gutted.

 

Seems like we both can see all our work out the window.

Pretty disappointed by this.



#13 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 14114 posts
  • Local time: 11:55 PM
  • LocationWashington State

Posted 17 January 2019 - 04:46 PM

I

 

Images I could live without, but if it was possible to recover the metadata from the old tables as you suggest that would make my day. 

But how?

 

I am a not a database guy, I don't know if there is even a way to align or import the information into the new table but I would first insure you have a backup of the library.db.



#14 Grabbenswe OFFLINE  

Grabbenswe

    Member

  • Members
  • 12 posts
  • Local time: 07:55 AM

Posted 17 January 2019 - 04:47 PM

I am using the Plugin "Emby Backup" so I have 14 backups, 10 of them from before the update.

Anyway I can use these and recover?
 



#15 Grabbenswe OFFLINE  

Grabbenswe

    Member

  • Members
  • 12 posts
  • Local time: 07:55 AM

Posted 17 January 2019 - 04:48 PM

I

 

 

I am a not a database guy, I don't know if there is even a way to align or import the information into the new table but I would first insure you have a backup of the library.db.

 

That I have from the Emby Backup.



#16 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 14114 posts
  • Local time: 11:55 PM
  • LocationWashington State

Posted 17 January 2019 - 05:10 PM

I am using the Plugin "Emby Backup" so I have 14 backups, 10 of them from before the update.
Anyway I can use these and recover?

 
No as the plugin only "Backup and restore server and user configurations". Has nothing to do with metadata.



#17 bigverm23 OFFLINE  

bigverm23

    Advanced Member

  • Members
  • 86 posts
  • Local time: 07:55 AM

Posted 17 January 2019 - 05:16 PM

same issue here, hours of scanning libraries and most of the metadata is just gone. and yes its all saved within my folders.



#18 rs6516 OFFLINE  

rs6516

    Member

  • Members
  • 27 posts
  • Local time: 07:55 AM

Posted 17 January 2019 - 05:47 PM

Same here. I'm in the same boat all of you are in. hours and hours wasted. Even objects that were "locked" are now gone. I just can't go through this again. 

I do have a message for those who are developing Emby... your #1 priority should be to ensure that updates do not purge all your clients data. I'm now debating between disabling all updates, or moving to plex.


  • Grabbenswe likes this

#19 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 44185 posts
  • Local time: 02:55 AM

Posted 17 January 2019 - 06:00 PM

Hi.  We're very sorry this has happened but we have always recommended that, if you customize your metadata or images, you need to turn on the option to save those customizations next to your media.

 

Thanks.



#20 moviefan OFFLINE  

moviefan

    Advanced Member

  • Alpha Testers
  • 858 posts
  • Local time: 11:55 PM

Posted 17 January 2019 - 06:35 PM

we have always recommended that, if you customize your metadata or images, you need to turn on the option to save those customizations next to your media.

 

Ahh so local metadata is king.  Seems like an option we should be able to use with collections as well!


  • FrostByte and Senna like this





Also tagged with one or more of these keywords: update, metadata, lost

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users