Jump to content

Post 4.0.0.2 update different issue not found with search now always asks for password.


killerbotics
 Share

Recommended Posts

killerbotics

I know the kodi plugin is getting worked on so please add this to the list:
 

Kodi Emby plugin asks for password every time it starts after updating to 4.0.0.2
 
I can't be hand holding family every time kodi boots.
 
Environments:
Server (on windows) Version 4.0.0.2
Server Plugin Kodi Companion 2.0.9.0
Emby for Kodi plugin 3.0.34
Kodi (on windows) 17.6 "Krypton"
Also acts the same way on OpenELEC and is also new behavior post 4.0.0.2
Edited by killerbotics
  • Like 1
Link to comment
Share on other sites

benbour

I know the kodi plugin is getting worked on so please add this to the list:

 

Kodi Emby plugin asks for password every time it starts after updating to 4.0.0.2

 

I can't be hand holding family every time kodi boots.

 

Environments:

Server (on windows) Version 4.0.0.2

Server Plugin Kodi Companion 2.0.9.0

Emby for Kodi plugin 3.0.34

Kodi (on windows) 17.6 "Krypton"

Also acts the same way on OpenELEC and is also new behavior post 4.0.0.2

Same issue here. Performed database reset on both libreelec boxes, it's removes everything but won't resync. This just started happening after emby update. Where's the quality control for releases? This isn't the first time server updates have broken things...

 

Sent from my Pixel 2 XL using Tapatalk

Link to comment
Share on other sites

sualfred

@@benbour

 

And where is your ability to read the reply?

 

You have to be on the beta branch of the Emby for Kodi addon and do a complete database reset. 

 

And don't forget that the addons are provided by users and not Emby. We are doing this in our free time.

Edited by sualfred
Link to comment
Share on other sites

benbour

@@benbour

 

And where is your ability to read the reply?

 

You have to be on the beta branch of the Emby for Kodi addon and do a complete database reset. 

 

And don't forget that the addons are provided by users and not Emby. We are doing this in our free time.

 

I read the reply, but I thought it was about as lazy as the addon release. Most people would prefer to be on the "stable" repository, and not have to search forums for solutions after every update. I have a premium license and expect things to work (I know, crazy!). Maybe remove Kodi from the advertised platform support on the website?

Link to comment
Share on other sites

sualfred

Then don't use Kodi or use EmbyCon instead. 

 

Again, the Kodi addons are developed by the community in our free time (I know, crazy!) and don't require Premiere at all. but we are already working since days to get the addon done to release it to stable repo. 

 

If you face issues the next time you better provide a log instead of behaving so outrageously.

Edited by sualfred
  • Like 2
Link to comment
Share on other sites

This thread demonstrates the issue with the kodi addon.  I get both points of view.  It's frustrating for everyone.

 

Since it's developed by volunteers (thank you!) you expect some hitches but maybe you can also some expect some "workarounds" that are user friendly.  As pointed out - Emby boasts kodi support even though this is not part of the main development featureset.  In this instance the dirty workaround of putting the beta (which mostly works) into stable could have been, imo, a wise decision (albeit not a normal process for normal dev).  The mess that you're left with can be quite confusing.

 

I have others who use the system who are utterly clueless to anything behind the scenes.  I didn't even notice Emby server had updated myself until I heard the issues and I immediately advised against and killed server auto update for other people who I know use Kodi and this plugin (nearly everyone in my circles btw).  The beta would have confused for a second but allowed relatively normal usage afterwards.

 

By the way, maybe I'm getting blind in my older age, but I'm "in the field" and I didn't see a way to access the beta easily in the forum.  There are 404 links in the opening post on the main pinned thread.  You have to fish around to notice that there's now a source.  

 

Just some food for thought.  You don't want to have the attitude of "if you have a problem it's your fault because we do this for free so go elsewhere",  You might free up some spare time if you take that attitude enough. :P  You might also turn people away from Emby as well.

 

There's a middle ground.  When people sit down with the family to watch TV or movie in the evening or something and the system goes haywire and they have no idea why (other than the plugin is clearly not responding normally) then you're going to get frustrated users.  Frustrated devs trying to push out the fix need to take a deep breath.  We ALL know how users are. And, after all, they're who you're doing it for - even out of the goodness of your heart and empty pocket.

 

Again, thank you sincerely, but constructive criticism shouldn't be banned for community projects so I hope this is taken as well meaning.

  • Like 1
Link to comment
Share on other sites

sualfred

That's what I call friendly formulated.

 

Constructive criticism is welcome. But some users have to be reminded that we are working 24/7 on two construction zones. Emby 4.0 and Kodi Leia, which changed a lot. And these changes are happening day by day, because of daily nightly builds and users that are addicted to update as soon as possible. It's a race that sometimes is going to be lost. We are married, having family and a full time job. So don't get me wrong if I do not respond so kindly to inappropriately worded demands. We are still doing this for the fun and wie don't want to loose it.

 

 

And as harsh as it sounds, if you decide to use Kodi you will always have issues here and then. It's only a system for experienced users. Even more with the Emby integration. That's why I gave my families the advice to use the Emby Theater applications. 

 

But I agree that our "HowTo's" are outdated. It simply the lack of time to concentrate on them. We will take care of it as soon possible. Promised.

Edited by sualfred
Link to comment
Share on other sites

djdevon3

Was running Kodi 16 for a long time with Emby DB for a Grandma.  I prefer using Emby to admin things it's so much easier to make collections/sets for her. Took her years just to learn Confluence skin.  Well today everything went from odd to completely broken.  Kodi started asking for her Emby login, removed all of the custom sets I created for her, and seemed to divert back to pure Kodi without Emby.  Couldn't even play a movie without crashing, it was just done.  So I upgraded Kodi to 17.6 praying they had Confluence skin for her and they did, it's why I didn't upgrade initially. Anyway, after upgrading to Krypton it was the same issue.  Then I updated Emby addon within Kodi Krypton, still same thing. Getting random unresponsive program and Kodi is crashing all over the place. Since I haven't updated Kodi since 16.x yet had Emby addon set to auto update pretty sure that's what borked the pooch.  Someone mentioned it will work with the beta kodi addon.  Where can I find that or how to install that? Obviously I don't update often because Grandma barely knows how to use the back button on the remote and change isn't something she's good with. :/  Any help is appreciated.

Link to comment
Share on other sites

djdevon3

Thank you. I'm now running Kodi 17.6, Emby for Kodi 3.1.44a, Emby Server 4.0.  Reset the local db. As far as I can tell everything seems to be working again yey! Only one small issue, "Sets" (Emby Collections) is no longer showing up in Confluence under movies main menu like it did in Kodi 16. Unsure if this is a kodi skin issue or emby for kodi thing. I did find Sets in the file manager under movies>sets and created a favorite link to it. It works but less than ideal compared to how easy it used to be.

  • Like 1
Link to comment
Share on other sites

838Joel

Hi,

 

I'm running Kodi 18RC, Emby for Kodi 3.1.45a, Emby Server 4.0.0.2  Reset the local db. But This is still not working! Got this message "@The database version detected is unsupported. Syncing may not work, proceed anyway?".

If I proceed I got "Something went wrong during the sync....".

 

I tried to find the database.py file like mentionned in this thread https://forum.kodi.tv/showthread.php?tid=334305&pid=2762570#pid2762570 but it does not exist!

 

My Emby server is a VM on Ubuntu (Just upgraded to 4.0.0.2, My Kody is running on my AndroidTV Sony X900F, using beta apps of Kodi (Which is 18RC, instead of 17.6), I tried many Emby plugin: plugin.video.emby-3.0.30-leia-109.zip, plugin.video.emby-3.0.35.zip and last plugin.video.emby-3.1.45a.zip.

All doing the same problem.

 

Any idea what I should do?

 

And, how do I get my kodi.log file from my TV?

 

Thanks in advance for all the help!

 

Joel

Edited by 838Joel
Link to comment
Share on other sites

Yea have to agree. The info is all over. and have to keep trying other things. hard to tell whats current.  And that is with some  experience..  I completely get the vent.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...