Jump to content

Library shows correctly in Emby but not in Kodi


Loondawg
 Share

Recommended Posts

Loondawg

I'll be honest and say I struggle figuring some of this stuff out. So this may be something simple and stupid I am missing. But what I am finding is my library appears almost perfectly in Emby but doesn't show up correctly in Kodi.

 

For example, I have a six season TV series that shows up perfectly when I view it from the Emby web interface. All the seasons and episodes are there and show in the correct order. But when I open the same series in Kodi, I only see two seasons and even they do not show all the correct episodes. When I look at the files stored on disk, I am seeing all the episodes and they all seem to have all the correct nfo files with the correct information about the series and episode information in them.

 

Any ideas on how to solve this? I don't even know where to start. I've tried re-scanning the library in Kodi but that does not help.

Link to comment
Share on other sites

Loondawg

The episodes are all in one folder for the given series. So the directories are structured as follows..

 

--TV Shows [Dir]

------Series One Name [Dir]

---------S1E01 Series One Episode Name [File]

---------S1E02 Series One Episode Name [File]

---------S1E03 Series One Episode Name [File]

---------etc.

------Series Two Name [Dir]

---------S2E01 Series Two Episode Name [File]

---------S2E02 Series Two Episode Name [File]

---------S2E03 Series Two Episode Name [File]

---------etc.

 

[Fixed typos in season two episodes.]

Edited by Loondawg
Link to comment
Share on other sites

Loondawg

What version of Emby Server?

Was 3.x but was upgraded to 4 last night. I use automatic updates so it is generally on the latest available version.

 

The more I look into this, the more I am convinced this is likely a Kodi issue. After the upgrade last night, I noticed that the episodes show correctly when accessed via the Embycon add-on but not when accessed directly through the top level TV Shows Kodi menu.

 

Still looking for suggestions on why that might be and how to fix it though.

Edited by Loondawg
Link to comment
Share on other sites

Loondawg

your above example has S1Exx for both season 1 and season 2, is that a type?

 

That was a typo. I will correct it above.

 

It should have been S2E01, etc... under the season two folder. The files are named correctly on disk.

Edited by Loondawg
Link to comment
Share on other sites

Angelblue05

Ok, so to confirm here, you don't have season folders, correct? I will have to test that scenario to ensure we aren't ignoring virtual season folders.

Link to comment
Share on other sites

Angelblue05

It looks like he does have season folders in the above example.

 

Perhaps an actual screen shot of his paths would be more helpful.

I see TV shows > Series Name > Epx 

 

He has the season value in the episode name, but not an actual season folder and that could be why this is happening imo.

Edited by Angelblue05
Link to comment
Share on other sites

Loondawg

Ok, so to confirm here, you don't have season folders, correct? I will have to test that scenario to ensure we aren't ignoring virtual season folders.

 

Correct. I do not have season folders.

 

However the more I look into this, the more I am convinced the problem is between Kodi and Emby and not Emby itself. I say that because if I access the files via the Embycon add-on, they seem correct. All episodes appear and they are correctly separated by seasons. They only seem to be really messed up when I access them via the top level TV Shows menu in Kodi. Still open to suggestions to fix this though.

Edited by Loondawg
  • Like 1
Link to comment
Share on other sites

Loondawg

It looks like he does have season folders in the above example.

 

Perhaps an actual screen shot of his paths would be more helpful.

 

I'm sorry. It was actually correct the first time and I was a bit thrown by the question. I do not use season folders. I use one folder for each series. And all the files for any given series are in that folder labeled with S#E# for the season and season episode. Here is a partial directory output which should clear it up.

 

E:\TV Shows\Letterkenny>dir /b

Letterkenny S1E01 - Ain't No Reason To Get Excited.mp4

Letterkenny S1E02 - Daryl's Super Soft Birthday.mp4

Letterkenny S1E03 - Fartbook.mp4

Letterkenny S1E04 - Wing Man Wayne.mp4

Letterkenny S1E05 - Rave.mp4

Letterkenny S1E06 - A Fuss In The Back Bush.mp4

Letterkenny S2E01 - A Fuss At The Ag Hall.mp4

Letterkenny S2E02 - The Election.mp4

Letterkenny S2E03 - Relationships.mp4

Letterkenny S2E04 - The Native Flu.mp4

Letterkenny S2E05 - Uncle Eddie's Trust.mp4

Letterkenny S2E06 - Finding Stormy A Stud.mp4

Letterkenny S3E01 - Sled Shack.mp4

Letterkenny S3E02 - Puck Bunny.mp4

Letterkenny S3E03 - Modeans 2.mp4

Letterkenny S3E04 - Les Hiques.mp4

Letterkenny S3E05 - The Battle For Bonnie Mcmurray.mp4

Letterkenny S3E06 - Bradley Is A Killer.mp4

Letterkenny S3E07 - Bonus - Haunting Of Modeans II.mp4

etc...

  • Like 1
Link to comment
Share on other sites

Loondawg

Oh, sorry I confused series with season, you are correct. So what he had before was correct, why did he change it.

--TV Shows [Dir]
------Series One Name [Dir]
---------S1E01 Series One Episode Name [File]

To be honest it would still be better to get an actual screen shot of his library structure, then there is no confusion, typos or misunderstandings.

 

You are correct. I was correct the first time and then thought I wrong making it very confusing. To clear things up, an example of a directly listing was provided in the post right above this one.

  • Like 1
Link to comment
Share on other sites

Angelblue05

@@Loondawg

 

Just a small update, I can see what you are seeing with my animes which don't have season folders. I will work on a fix and let you know when it's ready to be tested. Thanks for your patience.

 

Edit: For some reason, I can't see it now.

Edited by Angelblue05
Link to comment
Share on other sites

Angelblue05

@@Loondawg

 

I've got nothing to go on after all. I thought I saw the issue, but I was mistaken. I've added multiple shows with no season folders, but they all show up correctly here.

 

Are you on 3.1.44? If so, can you try to repair the library, then provide your Kodi log and let me know the series that are missing content? Thank you.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...