Jump to content

offline sync not working on amazon device


revengineer
 Share

Recommended Posts

Weird issue, I just lost the ability to scroll the emby app on my phone. It's an old version 2.9.76 but it's the last version that works properly on my devices and scrolling worked flawlessly a few days ago. I tried deleting the app data and even deleted cache+dalvik to no avail. Any clue what might be going on? The same app side loaded on my kindle fire hd still scrolls just fine. I am stumped...

Link to comment
Share on other sites

I've had that happen to me, too.  I believe it was 2.9.92, using it because it worked with my Bluetooth device.  The only way I could fix scrolling was to update.

Link to comment
Share on other sites

Thank you for the responses, that is what I was afraid of. I tried the latest version 3.0.21 and while the scrolling now works, the app is otherwise junk just like any other 3.x version I have tried. Direct play no longer works on my Fire HD 7 and downloads to external storage show as "ready to transfer" forever. So as it stands now, emby is unusable for me again. Is there really no way to revive the scrolling in the 2.9.x versions?

 

EDIT: I should elaborate on what I mean with "direct play no longer works": The playback stutters terribly, it plays 3 seconds then stops 3 seconds. Wifi is a brand new AC2600 router, so this should not be the issue. I have limited success with transcoding to 1 Mbps stream. I wonder if this is a CPU issue. whatever it is, the 2.9.76 version worked flawlessly.

Edited by revengineer
Link to comment
Share on other sites

So, I was able to downgrade and use version 2.9.92 without issue after encountering the scroll problem by doing the following on my phone:

 

1. Uninstalled Chrome updates

 

The "Android System WebView" app on my phone was disabled.  Apparently, it is no longer used and Chrome itself is used as the rendering engine.  It must have been updated and caused the problem with the Emby Android app.

 

I'm not sure this will work for everyone but it is something to look into if you need to use an older version of the app.

Link to comment
Share on other sites

Let's work together to resolve your problem.

 

Luke, ok, happy to work with you as my time allows. Of the two issues, the issue with the failed downloads is the bigger problem, so I would like to tackle that first. I noticed that the download tries to start when I select the internal storage as the download location. However, the internal storage is small and emby reports that I have to make space for the download first. It seems to be the external storage where the download is "ready to transfer" forever. Not sure if this helps in any way.

 

So, I was able to downgrade and use version 2.9.92 without issue after encountering the scroll problem by doing the following on my phone:

 

1. Uninstalled Chrome updates

 

The "Android System WebView" app on my phone was disabled.  Apparently, it is no longer used and Chrome itself is used as the rendering engine.  It must have been updated and caused the problem with the Emby Android app.

 

I'm not sure this will work for everyone but it is something to look into if you need to use an older version of the app.

 

Thank you, I will keep that solution in mind. For now, I have left the latest version on my phone where I had the scroll issue but where downloads and playback seemed to work although I have not extensively tested it. If I find any issues, I will follow your path. I have downgraded my kindle fire to the 2.9.x version and scrolling still works there. I will try to provide Luke with the information needed to fix the issue.

Edited by revengineer
Link to comment
Share on other sites

Please try this version in regards to both issues:

https://www.dropbox.com/s/9am2hgfcj403j8d/MediaBrowser.Mobile-googlearmv7-release.apk?dl=0

 

Then provide a log from the app if there is trouble downloading. thanks.

 

Thanks for working this so quickly. Log is attached.

 

EDIT: I also checked that the request made it to the server. The request in Download & Sync  is there, also reporting "Ready to transfer".

f5dbf2b8-f837-4703-ab75-6c2c6c2d279a.log

Edited by revengineer
Link to comment
Share on other sites

And about video playback?

 

Oops, I forgot to test that for the log. I am now playing the episode that was stuttering yesterday. It is direct playing smoothly now! So maybe that one is solved. I will retry 3.0.21 for good measure to see whether the device or the app is behaving differently. Will post back in a few.

Link to comment
Share on other sites

What version of android is this on?

 

Fire OS 5.6.2.0. Installed Google Playstore on my Fire HD and then installed emby from Google appstore.

Link to comment
Share on other sites

Can you cancel all pending downloads, then restart the app, try to download something from inside the app, and then provide the app log?

 

Also, what version of emby server?

Link to comment
Share on other sites

What did you try to download? because it's acting like there's nothing to download.

 

Ok, I screwed up. I did not follow instructions and sent a log of playing video. I will try to download something from inside the app again. I am a little confused because that is what I did for the first log.

Link to comment
Share on other sites

Ok here a new log. The file I am trying to download is "Notruf_Hafenkante_S07E24_H_henfl_ge.mkv". Inerestingly, the file on the server is called "Notruf Hafenkante S07E24 Höhenflüge.mkv" and German umlauts. Log shows "Sat Nov 03 18:55:37 EDT 2018 ServerSync failed to server: 4b9b9dd38eb9409781f1498c0f5dfbf2. Error: Java exception was raised during method invocation"

 

Let me try a filename without special characters next.

c68a1843-feaa-4797-9133-46760107c37e.log

Link to comment
Share on other sites

Can you cancel that and do a test without umlauts just so that we can rule that out as a possible cause? thanks.

Link to comment
Share on other sites

Tried another movie "RELIGULOUS.m4v", log attached. Same Java error, so it's not the special characters, not sure if that is a separate issue or just a logging bug.

 

Ok, thanks.

Link to comment
Share on other sites

This is the relevant snippet from the server log

2018-11-03 19:06:06.191 Info HttpServer: HTTP Response 200 to 192.168.1.76. Time: 1ms. http://192.168.1.50:8096/emby/system/info/public 
2018-11-03 19:06:06.402 Info HttpServer: HTTP GET http://192.168.1.50:8096/emby/System/Info. UserAgent: Mozilla/5.0 (Linux; Android 5.1.1; KFAUWI Build/LVY48F; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/59.0.3071.125 Safari/537.36
2018-11-03 19:06:06.403 Info HttpServer: HTTP Response 200 to 192.168.1.76. Time: 1ms. http://192.168.1.50:8096/emby/System/Info 
2018-11-03 19:06:06.447 Info HttpServer: HTTP GET http://192.168.1.50:8096/emby/DisplayPreferences/usersettings?userId=e0997acd42d1404c9e5337164159811c&client=emby. UserAgent: Mozilla/5.0 (Linux; Android 5.1.1; KFAUWI Build/LVY48F; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/59.0.3071.125 Safari/537.36
2018-11-03 19:06:06.448 Info HttpServer: HTTP Response 200 to 192.168.1.76. Time: 1ms. http://192.168.1.50:8096/emby/DisplayPreferences/usersettings?userId=e0997acd42d1404c9e5337164159811c&client=emby 
2018-11-03 19:06:06.592 Info HttpServer: HTTP GET http://192.168.1.50:8096/emby/Sync/Items/Ready?TargetId=76dce0426f7e7b75. UserAgent: Mozilla/5.0 (Linux; Android 5.1.1; KFAUWI Build/LVY48F; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/59.0.3071.125 Safari/537.36
2018-11-03 19:06:06.602 Info HttpServer: HTTP Response 200 to 192.168.1.76. Time: 9ms. http://192.168.1.50:8096/emby/Sync/Items/Ready?TargetId=76dce0426f7e7b75 
2018-11-03 19:06:43.085 Error HttpServer: WebSocket ConnectionClosedPrematurely
2018-11-03 19:06:43.085 Error HttpServer: Error closing web socket response
	*** Error Report ***
	Version: 3.5.3.0
	Command line: C:\Users\admin\AppData\Roaming\Emby-Server\system\EmbyServer.dll -service
	Operating system: Microsoft Windows NT 6.2.9200.0
	64-Bit OS: True
	64-Bit Process: True
	User Interactive: True
	Processor count: 4
	Program data path: C:\Users\admin\AppData\Roaming\Emby-Server
	Application directory: C:\Users\admin\AppData\Roaming\Emby-Server\system
	System.Net.Sockets.SocketException (10054): An existing connection was forcibly closed by the remote host
	   at SocketHttpListener.SocketStream.Write(Byte[] buffer, Int32 offset, Int32 count)
	   at SocketHttpListener.Net.HttpResponseStream.DisposeCore()
	   at SocketHttpListener.Net.HttpResponseStream.Dispose(Boolean disposing)
	   at SocketHttpListener.Net.HttpConnection.Close(Boolean force)
	   at EmbyServer.SocketSharp.WebSocketSharpListener.TryClose(HttpListenerContext ctx, Int32 statusCode)
	System.Net.Sockets.SocketException
	   at SocketHttpListener.SocketStream.Write(Byte[] buffer, Int32 offset, Int32 count)
	   at SocketHttpListener.Net.HttpResponseStream.DisposeCore()
	   at SocketHttpListener.Net.HttpResponseStream.Dispose(Boolean disposing)
	   at SocketHttpListener.Net.HttpConnection.Close(Boolean force)
	   at EmbyServer.SocketSharp.WebSocketSharpListener.TryClose(HttpListenerContext ctx, Int32 statusCode)
	
Link to comment
Share on other sites

Tried another movie "RELIGULOUS.m4v", log attached. Same Java error, so it's not the special characters, not sure if that is a separate issue or just a logging bug.

 

@softworkz 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...