Jump to content


Photo

How to safely and efficiently upgrade to v4.x Stable?


  • Please log in to reply
55 replies to this topic

#21 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 2486 posts
  • Local time: 01:52 AM

Posted 16 January 2019 - 02:47 PM

So no issues with watched status?

Sent from my SM-G960U1 using Tapatalk

#22 CBers OFFLINE  

CBers

    Advanced Member

  • Moderators
  • 15168 posts
  • Local time: 09:52 AM
  • LocationKent, England.

Posted 16 January 2019 - 02:49 PM

So no issues with watched status?


No. I didn't delete the library.db files in the end, as I wanted to see how long the first one took, then I just let the others upgrade themselves.

#23 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 2486 posts
  • Local time: 01:52 AM

Posted 16 January 2019 - 03:50 PM

No. I didn't delete the library.db files in the end, as I wanted to see how long the first one took, then I just let the others upgrade themselves.

I have 700 or so movies and several thousand episodes. How long do you think that will take on an i5 4690k if I shut down MCEBuddy to keep it from hogging resources?

Sent from my SM-G960U1 using Tapatalk

#24 CBers OFFLINE  

CBers

    Advanced Member

  • Moderators
  • 15168 posts
  • Local time: 09:52 AM
  • LocationKent, England.

Posted 16 January 2019 - 03:53 PM

The initial library scan may take a good while if you have the "Extract chapter images during the library scan" option enabled.

You could stop the scan, disable that option on each library and rerun.

Once completed, re-enable the option.

#25 neik ONLINE  

neik

    Advanced Member

  • Members
  • 610 posts
  • Local time: 10:52 AM

Posted 16 January 2019 - 04:47 PM

So, what is the best practice to upgrade from 3.5.3 stable to 4.x stable? The process described in post #1?

 

I don't mind start over with the library but I would like to save the watch status and restore it after rebuilding the database.

Is this possible?



#26 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 128711 posts
  • Local time: 04:52 AM

Posted 16 January 2019 - 04:49 PM

I would suggest checking out the announcement:

 

https://emby.media/c...emby-server-40/

 

Thanks !


  • Sammy likes this

#27 CBers OFFLINE  

CBers

    Advanced Member

  • Moderators
  • 15168 posts
  • Local time: 09:52 AM
  • LocationKent, England.

Posted 16 January 2019 - 05:36 PM

So, what is the best practice to upgrade from 3.5.3 stable to 4.x stable? The process described in post #1?


Just let your server auto-update.

#28 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 128711 posts
  • Local time: 04:52 AM

Posted 16 January 2019 - 05:37 PM

Auto update if supported on your platform, otherwise install the latest version manually on top of your existing version.



#29 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 14319 posts
  • Local time: 01:52 AM
  • LocationWashington State

Posted 16 January 2019 - 06:03 PM

What about upgrading from 4.0.0.1 beta to 4.0.0.2 stable? Do I get the installer from the Emby site and perform a clean install? Or over the top? There are no update messages on my server.

 

Just run the installer, this will change your beta to stable branch.



#30 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 2486 posts
  • Local time: 01:52 AM

Posted 18 January 2019 - 09:49 AM

I have some Library mapping that I'm not happy with in my production server so I want to take the time to fix that before doing the update.

Basically what I want to do is use consistent UNC paths for all of my library. Right now it is just a mishmash that needs correcting.

Sent from my SM-G960U1 using Tapatalk
  • cayars likes this

#31 cayars OFFLINE  

cayars

    Advanced Member

  • Alpha Testers
  • 2889 posts
  • Local time: 04:52 AM

Posted 18 January 2019 - 10:06 AM

If you're going to be redoing your layout anyway, this would be a great time to install Stablebit Drivepool.

 

It makes library managment so much easier!



#32 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 2486 posts
  • Local time: 01:52 AM

Posted 18 January 2019 - 10:59 AM

If you're going to be redoing your layout anyway, this would be a great time to install Stablebit Drivepool.

It makes library managment so much easier!

I merely have JBOD because none of my content is not necessarily precious.

Does Stablebit Drivepool work in such an environment? Do you have a link to setting it up?

TIA

Sent from my SM-G960U1 using Tapatalk

Edited by Sammy, 18 January 2019 - 11:08 AM.


#33 cayars OFFLINE  

cayars

    Advanced Member

  • Alpha Testers
  • 2889 posts
  • Local time: 04:52 AM

Posted 18 January 2019 - 12:22 PM

It's super simple.  Get the trial and PM me and we can do a teamview session.

 

If you have two or more drives used for storage it's worth it in my opinion.  Besides if you are anything like the rest of us you'll keep adding drives and the more drives you have the more you'll appreciate how it pools the drives together and keeps you from having to modify Emby or any other app using the data.



#34 CBers OFFLINE  

CBers

    Advanced Member

  • Moderators
  • 15168 posts
  • Local time: 09:52 AM
  • LocationKent, England.

Posted 18 January 2019 - 12:33 PM

If you're going to be redoing your layout anyway, this would be a great time to install Stablebit Drivepool.

It makes library managment so much easier!


Or DriveBender ;)

#35 hoppel118 OFFLINE  

hoppel118

    Advanced Member

  • Members
  • 164 posts
  • Local time: 10:52 AM

Posted 18 January 2019 - 12:55 PM

Yesterday I updated my Emby docker container from 3.4.1 to 4.0.0.2. It works as expected. No problems until now.

Thanks and regards Hoppel
  • CBers likes this

#36 WilhelmStroker OFFLINE  

WilhelmStroker

    Advanced Member

  • Members
  • 180 posts
  • Local time: 09:52 AM

Posted 18 January 2019 - 01:12 PM

Upgraded to 4.0.0.1 beta and then to 4.0.0.2 stable without issues although I did notice the real time monitoring option for 1 of my libraries got deselected.
  • CBers likes this

#37 blade005 OFFLINE  

blade005

    Advanced Member

  • Alpha Testers
  • 681 posts
  • Local time: 03:52 AM

Posted 18 January 2019 - 04:56 PM

Unless something has changed \metadata\people will not be used on a new\delete database upgrade.  This resource is only used in the migrartion.  Still awaiting more information on this.

@Happy2Play

 

Did you confirm if PEOPLE images are now in a different folder location? Reason I ask is that i did an upgrade from 3.5.3 to 4.0 and have not been able to run a PEOPLE REFRESH scan since then. I am seeing the same display issues others have noted of some Actors being displayed on detail screens, but others are not until you drill down into the detail page and then they will show up. Below is the error message I get repeatedly attempting a PEOPLE REFRESH scan. NOTE: Left it running for 2+ hours and it never moved off of 0%. Attempted to STOP the scan, but it never successfully stop and I had to RESTART the server to clear it out.

 

PEOPLE REFRESH SCAN ERROR:

Cannot access a disposed object.
Object name: 'SqliteItemRepository has been disposed and cannot be accessed.'.

 



#38 cayars OFFLINE  

cayars

    Advanced Member

  • Alpha Testers
  • 2889 posts
  • Local time: 04:52 AM

Posted 18 January 2019 - 05:11 PM

That's an option but I personally don't like the way they did the pooling using user mode drivers.  I find to many utils don't work with it properly.  Drivepool has never let me down and just works so that's what I recommend.

 

If a person needed to add NAS or network storage to a pool then I'd consider DriveBender however.  But besides that it's just not a flexible or easy to use IMHO.



#39 CBers OFFLINE  

CBers

    Advanced Member

  • Moderators
  • 15168 posts
  • Local time: 09:52 AM
  • LocationKent, England.

Posted 18 January 2019 - 05:12 PM

That's an option but I personally don't like the way they did the pooling using user mode drivers. I find to many utils don't work with it properly. Drivepool has never let me down and just works so that's what I recommend.

If a person needed to add NAS or network storage to a pool then I'd consider DriveBender however. But besides that it's just not a flexible or easy to use IMHO.


Not sure what you're talking about, but each to their own :)
  • cayars likes this

#40 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 14319 posts
  • Local time: 01:52 AM
  • LocationWashington State

Posted 18 January 2019 - 05:12 PM

@Happy2Play

 

Did you confirm if PEOPLE images are now in a different folder location? Reason I ask is that i did an upgrade from 3.5.3 to 4.0 and have not been able to run a PEOPLE REFRESH scan since then. I am seeing the same display issues others have noted of some Actors being displayed on detail screens, but others are not until you drill down into the detail page and then they will show up. Below is the error message I get repeatedly attempting a PEOPLE REFRESH scan. NOTE: Left it running for 2+ hours and it never moved off of 0%. Attempted to STOP the scan, but it never successfully stop and I had to RESTART the server to clear it out.

 

PEOPLE REFRESH SCAN ERROR:

Cannot access a disposed object.
Object name: 'SqliteItemRepository has been disposed and cannot be accessed.'.

 

 

Can you post the server log.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users