Jump to content

Problem accessing a network drive on DietPi


thalysguimaraes
 Share

Recommended Posts

thalysguimaraes

Hey, I'm trying to configure an Emby server on a RPI3 running DietPi.

 

My media is on a Seagate Personal Cloud NAS, and I was able to mount it using the DietPi disk manager on /mnt/segate, but somehow when I try to configure the library on Emby it doesn't recognize any media. It recognizes the path, but doesn't load anything.

 

I think it's not a misconfiguration on the NAS mount because all other instances installed on DietPi can access the folder.

 

Any thoughts?

Link to comment
Share on other sites

thalysguimaraes

Hi, I've tried using the mount path (/mnt/seagate) and also tried to address the network path (\\192.x.x.x).

 

Hi, what path are you entering into Emby?

Link to comment
Share on other sites

thalysguimaraes

When I try the mount path, Emby let me create it but can't find my media. I tried scanning it several times and accessed the mount in other applications (it worked).

When I try the IP it doesn't recognize the path at all.

 

And what happened when you tried?

Edited by thalysguimaraes
Link to comment
Share on other sites

  • 2 weeks later...
JaScoMa

  • "dietpi-config"

     

  • Select "Option 8: Network Options: Misc"

     

  • Select "network drives" - Then select "OK"

     

  • Select "Add network drive" and follow the prompts to configure your network share.

     

    NOTE: I never had any luck getting the connection working properly going this route, so just exit out of this after it tries to configure the share, etc.  It's good to do since it'll installed the needed packages, etc.

     

  • Exit back to the command prompt.

     

  • At the command prompt type (without quotes): "nano /etc/fstab"

     

  • At the top of the file, under the "#Please use DietPi-Drive_Manager to setup network mounts" enter the following (edit to match your settings):

     

    "//111.222.333.444/%mediafolder% /mnt/seagate cifs rw,username=%username%,password=%password%,uid=emby,gid=emby 0 0"

     

  • CTRL-O to save the file, followed by CTRL-X to exit.

     

  • Next at the command prompt, enter: "mount -a" to mount your network share.

     

  • If you entered everyone correctly in your fstab file, you shouldn't see any errors when you mount the drive.

     

  • Next change to your mounted folder ("/mnt/seagate") and do a directory listing "ls -l" and it should list the things in your media folder.

     

  • And, this location is read/write to the emby user/group so things like your NFO and JPGs can be stored in this location.
 
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...