Jump to content
LeonP

New feature request: Management of server wake / sleep state

Recommended Posts

LeonP

We have a couple of Samsung TVs in the house, which are not very "smart" out of the box.  To solve that problem we have installed nVidia Shield devices for each of these TVs.

 

This solved the problems with the built in functionality.  Streaming apps are working perfectly now ... with the exception of Emby.

 

The problem is that the Emby client for Android TV cannot manage a server that is in the Sleep State.

 

I'm respectfully requesting for a feature that can manage the sleep/wake state of the Emby Server (in my case the host is Windows 10).  This can be done by:

 

- Sending a WOL magic packet to the server when a client requests a video to be streamed (and the server is in the sleep state).

- Keeping the server awake during streaming.

 

Really love the Emby server, as it provides many benefits over its competitors, like Plex, but the absence of this feature really limits its usability in the Android TV space.

 

Share this post


Link to post
Share on other sites
ebr

Hi.  We already have this so please describe exactly the problem you are encountering so we can figure out what it is.  Thanks.

 

How to Report a Problem

Share this post


Link to post
Share on other sites
LeonP

I'm talking about the client for Media Centres / TV (Android TV).  There is no evidence of this function in this version of Emby -- nor does it succeed in waking my PC.  All other methods to wake the Win10 server work, but not the Emby Android TV client.

 

If indeed this function does exist, please elaborate how this function is accessed / invoked.

Share this post


Link to post
Share on other sites
ebr

Hi.  Can you please tell me exactly what you are doing and what is happening?  What versions of everything, etc. (as outlined in the doc I linked)

 

Thanks.

Share this post


Link to post
Share on other sites
LeonP

Client:  nVidia Shield, Android TV, version 1.6.56g (tv.emby.embyatv)

 

Server:  Windows 10 PC, Emby Server 3.5.3.0

 

Client and Server on same network subnet (home).

 

 

Problem description:

 

1.  Server is asleep (state S3).  Network interface power management is set to only wake up on receiving a WOL "magic packet".

 

2.  Try to connect to server.  Client just hangs, cannot wake server, and times out.  Client is obviously not sending a WOL "magic packet".  After the timeout period the server dialogue is displayed.  The only possible change for the Server is to "forget" it ... no "wake up" function.

 

3.  Workaround is to use "Wake on LAN" Android app from my smart phone, to send a WOL "magic packet" to server, which succeeds in waking it.

 

4.  Repeat:  this is the client for Android TV, not Android.

 

 

Have looked at all other Emby and related forums.  There is no evidence that the Emby client for Android TV sends a WOL "magic packet" to server.

Edited by LeonP

Share this post


Link to post
Share on other sites
ebr

Hi.  You said it "times out".  What, exactly, happens then?

 

What should be happening is that you should get a dialog up that asks you if you would like to try and wake the server.

 

Also, if you have a remote with a "menu" button on it, you can use that to produce a menu with the wake option.  Or, you should be able to long-press select and get the same menu.

Share this post


Link to post
Share on other sites
LeonP

Many thanks for quick response.  After connection attempt, no response is received for say 60 seconds.  Then the server selection dialogue appears, but without any option to wake the server.

 

NB:  When I try to connect to the server from my smartphone, I get an option to wake the server, which works ok.

 

Please note that the Emby Client for Android and the Emby Client for Android TV behaves differently in this respect.

Share this post


Link to post
Share on other sites
ebr

Hi.  On that screen, there should be a "send logs" button. Can you create the issue and then use that and come tell me exactly what time you did it?

 

Thanks.

Share this post


Link to post
Share on other sites
Kodi_Newcomer

I have the Same Problem. I have an Nvidia shield Android TV Box. In this there is the latest emby App, my emby Server on win 10 is running the latest beta. When my server is at Standby mode s3 the Android App in the Nvidia shield did Not start the emby server when i Start the emby App in the Android TV Box. Is there no wol Feature ?

Share this post


Link to post
Share on other sites
Luke

I have the Same Problem. I have an Nvidia shield Android TV Box. In this there is the latest emby App, my emby Server on win 10 is running the latest beta. When my server is at Standby mode s3 the Android App in the Nvidia shield did Not start the emby server when i Start the emby App in the Android TV Box. Is there no wol Feature ?

 

Hi, yes there is WOL. Did you try selecting the Wake Server option from the menu?

Share this post


Link to post
Share on other sites
Kodi_Newcomer

In the emby Server or the emby Android App ? In the App i cant found anything.

Share this post


Link to post
Share on other sites
ebr

In the emby Server or the emby Android App ? In the App i cant found anything.

 

Did you click on the server in the server list?

Share this post


Link to post
Share on other sites
Kodi_Newcomer

Here is what i have on options at the app, there is no wol settings or similar to it !

 

When the server is not running, and i click on the server to choose for some time the app hangs and after this nothing happens, no server is waked up or anything happens.

When i start the app it tooks a long time until he reacts, i think he is trying to connect to the known server but when he is off nothing happens.

 

When i start kodi for example he starts my server. but i will change to emby app so i did not need kodi anymore.

post-190077-0-69386300-1567620460_thumb.png

post-190077-0-73931000-1567620467_thumb.png

post-190077-0-96693300-1567620475_thumb.png

Share this post


Link to post
Share on other sites
Luke

Did you try selecting the Wake Server option?

Share this post


Link to post
Share on other sites
ebr

Please be sure you wait at least 45 seconds after selecting the server from the server list screen.

Share this post


Link to post
Share on other sites
Kodi_Newcomer

Did you try selecting the Wake Server option?

Where should this Option be ? I looked though all Options unter settings in the App nothing found.

Share this post


Link to post
Share on other sites
ebr

Where should this Option be ? I looked though all Options unter settings in the App nothing found.

 

 

It will be on the dialog that comes up after the server connection times out so please be sure you are waiting at least 45 seconds.

  • Like 1

Share this post


Link to post
Share on other sites
Kodi_Newcomer

Hm i Start the App and in the Screen there stand loading. I was i think the 46 Seconds. After that there comes a Message unable to connect ... And after this i See the Server to choose. I click on IT again but IT will Not Work. Nothing Happens nothing to choose wol Option .

 

Is there no way i can Set wol permanently ? So when i Start the App He sends directly an wol package ?

Share this post


Link to post
Share on other sites
ebr

We removed the automatic attempt to wake the server because it potentially slowed things down and made it manual.  Perhaps it makes sense to try to wake automatically IF you have the app configured to auto login...

Share this post


Link to post
Share on other sites
Kodi_Newcomer

We removed the automatic attempt to wake the server because it potentially slowed things down and made it manual.  Perhaps it makes sense to try to wake automatically IF you have the app configured to auto login...

Did you mean login with MediaBrowserConnect ? Or did you mean to implement this maybe as an option for auto login ?

 

But when i start the app he try's to connect to the server, is this not auto connect ?

Share this post


Link to post
Share on other sites
Kodi_Newcomer

It will be on the dialog that comes up after the server connection times out so please be sure you are waiting at least 45 seconds.

There is No Message or Dialog for wol Option. Maybe you can bring Automatic wol Back as an Option. I dont think im the only one with this Problem .

Share this post


Link to post
Share on other sites
Luke

do you have a mobile device to compare with the WOL function in the mobile android app?

Share this post


Link to post
Share on other sites
ebr

Hi.  I found one logic path where the dialog didn't show.  This should be fixed in the next release.

 

Thanks.

Share this post


Link to post
Share on other sites
Kodi_Newcomer

With the Mobile App on mY Phone it works. After a View Seconds He Shows me the Server to choose there i can click wakeup Server and IT has worked.

 

But the time ist very long, normaly my server is in standby, so i have to wait many seconds every day.

Edited by Kodi_Newcomer

Share this post


Link to post
Share on other sites
DaSilva

Was this problem fixed?

I also have a Shield 2019 and when I’m trying to connect to my sleeping Emby Server (Windows) I get the spinning circle for about 40 seconds and then I get the screen with the following:

-Select a server with my server listed.

-Other options / Enter Manually / Login with connect.

Is there an option to configure the Emby client app to automatic send a magic packet to the server?

Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...