Jump to content

Emby for KODI - Local Trailers Don't Play


ulrick65
 Share

Go to solution Solved by Angelblue05,

Recommended Posts

First off...as I have said before I believe...I LOVE this add on!

 

I have Kodi Krypton and the newest release of Emby as well as current version of the Emby for Kodi add-on.

 

Local trailers are in the movie folder alongside the movie with the -trailer added like so:

 

Movie Name (2018).mkv

Movie Name (2018)-trailer.mov

 

Trailers play fine from the web app

 

In Kodi (running the Titan Skin), when I go to "Information" for a movie and click on "Trailer".  I get a pop up that says "Add-on required - To use this feature you must download an add-on:  YouTube" and asks if I want to download it.  If I don't (which I don't want to use YouTube trailers) then it just takes me back to the Information screen.  If I do download it, then it runs the trailer from YouTube (which I don't want).

 

To be honest, I don't watch trailers on this box, so I can't tell you if it ever worked...but it works perfectly from the Emby Web App (and I have trailers for all my movies).

 

Any idea how to fix this?

 

Thanks.

Link to comment
Share on other sites

  • Solution

If you are not on server 3.6, then it’s normal. There’s been changes in the api and local trailers was one of them.

Edited by Angelblue05
  • Like 1
Link to comment
Share on other sites

Ok, thanks for the quick response.  I will wait for it to release then and try again.

 

Does that mean that it never worked or something broke along the way?  I don't recall the last time I tried to watch a trailer is why I am asking.

 

Thanks.

Link to comment
Share on other sites

Sorta. It was working, yes. But the indicator to know if there was a local trailer didn’t. Previously, then add-on tried to get a local trailer regardless. Now, it looks at the indicator first, since it’s been fixed with server 3.6.

  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...