Jump to content


Photo

Cannot Play Episode on Roku 3


  • Please log in to reply
4 replies to this topic

#1 snodrog742 OFFLINE  

snodrog742

    Advanced Member

  • Members
  • 153 posts
  • Local time: 06:17 PM

Posted 07 December 2018 - 02:13 AM

American Horror Story S08E01 just sits at Loading bar (completely green bar) but never plays on Roku 3.  Roku 2 and Web Player play the file fine.  Sent Logs @ 12:04 username snodrog742 through Roku app.  Server & transcode logs attached.

 

This also happened on NCIS: New Orleans S05E09 but not shown in logs.  I'm tired but grabbed these for AHS at least.

Attached Files



#2 speechles ONLINE  

speechles

    Advanced Member

  • App Developer
  • 3111 posts
  • Local time: 04:17 PM

Posted 07 December 2018 - 02:49 AM

Are you using the Emby Beta app?

 

It looks like the issue is the refframes. We don't allow a roku3 to direct play/direct stream if the reffframes are 1 within an mp4. Yours is the same thing inside an mkv. We need to update our profile to include this change and it will fix your issue on the Roku3. I will submit a fix for this shortly.

 

Edit: Fix submitted. Like all submissions these will appear in the beta once they pass through higher ups. Thank you for bringing it to our attention. :)


Edited by speechles, 07 December 2018 - 02:54 AM.


#3 snodrog742 OFFLINE  

snodrog742

    Advanced Member

  • Members
  • 153 posts
  • Local time: 06:17 PM

Posted 07 December 2018 - 12:28 PM

Are you using the Emby Beta app?

 

It looks like the issue is the refframes. We don't allow a roku3 to direct play/direct stream if the reffframes are 1 within an mp4. Yours is the same thing inside an mkv. We need to update our profile to include this change and it will fix your issue on the Roku3. I will submit a fix for this shortly.

 

Edit: Fix submitted. Like all submissions these will appear in the beta once they pass through higher ups. Thank you for bringing it to our attention. :)

 

Not using Beta.  Where's that leave me? Lol



#4 speechles ONLINE  

speechles

    Advanced Member

  • App Developer
  • 3111 posts
  • Local time: 04:17 PM

Posted 07 December 2018 - 03:30 PM

Not using Beta.  Where's that leave me? Lol

 

Exactly where you are is where you are left. The private/beta and public/store apps can share the homescreen. There is no reason to not be using the beta. Unless you want to lag behind and wait for Roku to push the "publish" button when a new version of the app is submitted. That is the difference between the two versions. We can self-publish the beta and have it available to you immediately. The store version must be vouched for by Roku and must be reviewed by them before they allow it to be published. They can also come back at you with issues you must correct before they will publish. Getting onto the store requires time.

 

Right now we are in a "feature freeze" for the beta to stabilize it for promotion to store/public. That freeze should end tomorrow or the next day. Then the beta can receive the updates I have submitted for it and the beta can be published. The fix I submitted for your bug has not yet been merged into the beta nor has a new beta been published because of this freeze. It will be very shortly though.

 

2018 Channel Store publishing blackout dates
  • FridayNovember 16 — SundayNovember 25, 2018Thanksgiving week (USA)
  • FridayDecember 14, 2018 — WednesdayJanuary 2, 2019Winter holidays

 

During this December blackout the beta app can continue to be updated regularly. It is only the public/store app that must wait out the winter holiday. We will update the beta once the promotion to stable happens. Stay tuned.

 

 

 


Edited by speechles, 07 December 2018 - 03:37 PM.


#5 snodrog742 OFFLINE  

snodrog742

    Advanced Member

  • Members
  • 153 posts
  • Local time: 06:17 PM

Posted 07 December 2018 - 03:36 PM

Thanks for the details.  I'll switch to Beta so get the fix ASAP.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users