Jump to content


Photo

3.6.0.74 - DLNA "Play On" not working on FreeBSD (FreeNAS)

DLNA freebsd freenas

  • Please log in to reply
7 replies to this topic

#1 oper82 OFFLINE  

oper82

    Newbie

  • Members
  • 4 posts
  • Local time: 02:40 AM

Posted 05 December 2018 - 09:14 AM

So i have a problem with DLNA "Play On" feature. It's not working anymore in 3.6.x.x beta releases. I have over past months tried many different beta versions and nothing has changed.
Everything works fine with 3.5.x.x versions. My TV will not even appear in the "Play On" list in the 3.6.x.x versions.
 
Overview of my setup:
emby runs in a FreeNAS 11.2 RC2 iocage jail.
TV is a LG webos 3.5 smart tv.
 
For testing i even created a new plugin jail according to this guide: https://emby.media/c...e-7#entry619899
Still no change.
 
Only error i see is this:

2018-12-05 14:24:47.318 Info App: Starting entry point Emby.Dlna.Main.DlnaEntryPoint
2018-12-05 14:24:47.387 Error Dlna: Error receiving udp message
        *** Error Report ***
        Version: 3.6.0.74
        Command line: /usr/local/lib/emby-server/system/EmbyServer.exe -os freebsd -ffdetect /usr/local/lib/emby-server/bin/ffdetect -ffmpeg /usr/local/lib/emby-server/bin/ffmpeg -ffprobe /usr/local/lib/emby-server/bin/ffprobe -programdata /var/db/emby-server -updatepackage emby-server-freebsd_{version}_amd64.txz
        Operating system: Unix 11.2.0.0
        64-Bit OS: True
        64-Bit Process: True
        User Interactive: False
        Mono: 5.10.1.57 (5.10.1.57 Sun Dec  2 02:23:04 UTC 2018)
        Processor count: 4
        Program data path: /var/db/emby-server
        Application directory: /usr/local/lib/emby-server/system
        System.NotImplementedException: System.NotImplementedException: The method or operation is not implemented.
          at System.Net.Sockets.Socket.ReceiveMessageFromAsync (System.Net.Sockets.SocketAsyncEventArgs e) [0x00006] in <b3922b7d60404fa9ae645f1fb97f5b6b>:0
          at Rssdp.Infrastructure.SsdpCommunicationsServer.BeginReceive (System.Net.Sockets.Socket socket, System.Net.Sockets.SocketAsyncEventArgs args) [0x0000a] in <7b1e368f86f945b8bfaedf0803c9dbc0>:0
        Source: System
        TargetSite: Boolean ReceiveMessageFromAsync(System.Net.Sockets.SocketAsyncEventArgs)
          at System.Net.Sockets.Socket.ReceiveMessageFromAsync (System.Net.Sockets.SocketAsyncEventArgs e) [0x00006] in <b3922b7d60404fa9ae645f1fb97f5b6b>:0
          at Rssdp.Infrastructure.SsdpCommunicationsServer.BeginReceive (System.Net.Sockets.Socket socket, System.Net.Sockets.SocketAsyncEventArgs args) [0x0000a] in <7b1e368f86f945b8bfaedf0803c9dbc0>:0

2018-12-05 14:24:47.419 Info App: Entry point completed: Emby.Dlna.Main.DlnaEntryPoint. Duration: 0.100731 seconds



#2 makarai OFFLINE  

makarai

    Advanced Member

  • Members
  • 452 posts
  • Local time: 02:40 AM

Posted 05 December 2018 - 11:21 AM

 

So i have a problem with DLNA "Play On" feature. It's not working anymore in 3.6.x.x beta releases. I have over past months tried many different beta versions and nothing has changed.
Everything works fine with 3.5.x.x versions. My TV will not even appear in the "Play On" list in the 3.6.x.x versions.
 
Overview of my setup:
emby runs in a FreeNAS 11.2 RC2 iocage jail.
TV is a LG webos 3.5 smart tv.
 
For testing i even created a new plugin jail according to this guide: https://emby.media/c...e-7#entry619899
Still no change.
 
Only error i see is this:

2018-12-05 14:24:47.318 Info App: Starting entry point Emby.Dlna.Main.DlnaEntryPoint
2018-12-05 14:24:47.387 Error Dlna: Error receiving udp message
        *** Error Report ***
        Version: 3.6.0.74
        Command line: /usr/local/lib/emby-server/system/EmbyServer.exe -os freebsd -ffdetect /usr/local/lib/emby-server/bin/ffdetect -ffmpeg /usr/local/lib/emby-server/bin/ffmpeg -ffprobe /usr/local/lib/emby-server/bin/ffprobe -programdata /var/db/emby-server -updatepackage emby-server-freebsd_{version}_amd64.txz
        Operating system: Unix 11.2.0.0
        64-Bit OS: True
        64-Bit Process: True
        User Interactive: False
        Mono: 5.10.1.57 (5.10.1.57 Sun Dec  2 02:23:04 UTC 2018)
        Processor count: 4
        Program data path: /var/db/emby-server
        Application directory: /usr/local/lib/emby-server/system
        System.NotImplementedException: System.NotImplementedException: The method or operation is not implemented.
          at System.Net.Sockets.Socket.ReceiveMessageFromAsync (System.Net.Sockets.SocketAsyncEventArgs e) [0x00006] in <b3922b7d60404fa9ae645f1fb97f5b6b>:0
          at Rssdp.Infrastructure.SsdpCommunicationsServer.BeginReceive (System.Net.Sockets.Socket socket, System.Net.Sockets.SocketAsyncEventArgs args) [0x0000a] in <7b1e368f86f945b8bfaedf0803c9dbc0>:0
        Source: System
        TargetSite: Boolean ReceiveMessageFromAsync(System.Net.Sockets.SocketAsyncEventArgs)
          at System.Net.Sockets.Socket.ReceiveMessageFromAsync (System.Net.Sockets.SocketAsyncEventArgs e) [0x00006] in <b3922b7d60404fa9ae645f1fb97f5b6b>:0
          at Rssdp.Infrastructure.SsdpCommunicationsServer.BeginReceive (System.Net.Sockets.Socket socket, System.Net.Sockets.SocketAsyncEventArgs args) [0x0000a] in <7b1e368f86f945b8bfaedf0803c9dbc0>:0

2018-12-05 14:24:47.419 Info App: Entry point completed: Emby.Dlna.Main.DlnaEntryPoint. Duration: 0.100731 seconds

 

 

Hi, would you mind telling me your exact iocage start command and a little bit about your network infrastructure?



#3 oper82 OFFLINE  

oper82

    Newbie

  • Members
  • 4 posts
  • Local time: 02:40 AM

Posted 05 December 2018 - 01:50 PM

Starting the jail is as simple as:

iocage start emby-server-beta74

The network is very simple. Everything is in one /24 subnet.

No restriction between the tv and emby server.

 

I have my main emby jail also on the same freenas box which is currently on version 3.5.2.0 and on that DLNA "Play On" works as expected

5c080e7c97414_Screenshotfrom201812051942

 

But on the beta emby:

5c080ff61c078_Screenshotfrom201812051949



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124437 posts
  • Local time: 08:40 PM

Posted 05 December 2018 - 06:22 PM

We're looking into this, thanks.



#5 oper82 OFFLINE  

oper82

    Newbie

  • Members
  • 4 posts
  • Local time: 02:40 AM

Posted 12 December 2018 - 09:49 AM

I don't know if you changed anything regading my issue in 3.6.0.76 but i just installed a new jail with the latest beta and the tv now properly appears in the "Play On" list.

I did the preliminary test remotely. will do some more testing when i get home.



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124437 posts
  • Local time: 08:40 PM

Posted 12 December 2018 - 03:20 PM

Thanks for the feedback.



#7 oper82 OFFLINE  

oper82

    Newbie

  • Members
  • 4 posts
  • Local time: 02:40 AM

Posted 13 December 2018 - 07:24 AM

So i did some more testing last night and everything works as expected again.

Topic closed.



#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124437 posts
  • Local time: 08:40 PM

Posted 13 December 2018 - 10:44 AM

Great, thanks !





Also tagged with one or more of these keywords: DLNA, freebsd, freenas

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users