Jump to content

Live TV Seek Mode Expected Behavior


drchandler
 Share

Go to solution Solved by ebr,

Recommended Posts

drchandler

Fairly new user of Emby here and need some clarification if what I'm seeing is expected behavior. I'm running server version 3.5.3.0 and the client is a pendant Fire TV 4K. Live TV tuner is the Homerun Connect. I have direct streaming for Live TV enabled on my client. There is a difference in how Emby handles viewing a show that is being recorded and viewed at the same time versus just having a channel being viewed in the Seek Mode of Live TV. If I start a recording and then subsequently start viewing the in-process recording, the program is re-muxed to HLS but the video/audio is being direct-played. If I start viewing a channel in Live TV and then press Pause to enter into Seek Mode, once I start viewing again the program is re-muxed to HLS (as it was in the previous scenario) but now the video is also being transcoded with the reason stated as "the bitrate is too high". These two scenarios should be roughly the same... If you can watch an in process recording without transcoding, you should be able to watch in Seek Mode without transcoding. I understand there is a need to re-mux  for FF and RW and am ok with that... I'd just like to have Seek Mode without the video being transcoded. It's as if Seek Mode doesn't properly look at the bitrate and just gives up on direct playing the video.

 

Also note that I tried maxing out the allowed bitrate of the client but that didn't help.

Edited by drchandler
Link to comment
Share on other sites

  • Solution

Okay, the answer is that, with the live stream we don't know the bitrate so we cannot assume it is within the limits that are set.  But, with the recording, we do know the bitrate so we know it is within the limit.

Input #0, mpegts, from 'http://127.0.0.1:8096/LiveTv/LiveStreamFiles/bc257851282340a3ba494033804cc23d/stream.ts':
  Duration: N/A, start: 33893.918422, bitrate: N/A
  • Like 1
Link to comment
Share on other sites

Yea for some reason our probe of the live stream could not determine the bitrate. I've seen this in a couple user logs but it's been difficult to reproduce. Please try again with the next release. Thanks.

Link to comment
Share on other sites

drchandler

Thanks for the feedback! I will try the next release and I can work around the issue for now by just starting a recording and then watching. I don't currently watch a lot of live TV (mostly recordings), but this workaround would be cumbersome for just wanting to pause the video for a bit. A possible suggestion based on my understanding of the client settings... If the client has the direct streaming for live TV option enabled, would it be reasonable to assume that you could just do the remux in Seek Mode and not the full transcode when the bitrate isn't available? Just a thought.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...