Jump to content


Photo

Emby keeps asking me to connect every single time


  • Please log in to reply
20 replies to this topic

#1 joekrill OFFLINE  

joekrill

    Member

  • Members
  • 27 posts
  • Local time: 03:12 PM

Posted 26 November 2018 - 07:54 PM

Every time I launch the Emby app it shows me the "Emby Connect" screen, prompting me to "Sign in with Emby Connect". I've set the "Remember User" option "ON", but it still continues to prompt me whenever I launch the channel. It's completely useless if it's going to keep asking me every time because I have to manually enter my server address every single time.

 

I'm running emby in a docker container on my server. I've got it assigned a local IP address which I can use, but I also have a hostname forwarded via nginx so I can access it remotely. I can connect either way (entering the local IP address directly and connecting via 8096, or entering my hostname and connecting via 443). But either way it's not remembering and always prompts me. How can I even troubleshoot this?



#2 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 42823 posts
  • Local time: 04:12 PM

Posted 26 November 2018 - 09:06 PM

Hi.  Exactly how do you exit the app?



#3 joekrill OFFLINE  

joekrill

    Member

  • Members
  • 27 posts
  • Local time: 03:12 PM

Posted 26 November 2018 - 09:42 PM

I've tried just about every possible way: scrolling down to the exit option; just hitting the home button; or hitting back enough times that it asks me if I want to close the app and I've exited that way. It doesn't seem to matter. I also tried resetting the settings. I removed and re-added the channel. I toggled the "Remember User" option off and back on a handful of times. Nothing seems to work.

 

It appears, however, that if I login  Emby Connect it remembers. But I have a separate local account (a "Home" account) that I used for general areas in the house that has completely different watched statuses, etc, and I'd rather not use Emby Connect. 



#4 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 42823 posts
  • Local time: 04:12 PM

Posted 27 November 2018 - 11:09 AM

It must be related to all of the advanced network configuration you have going on.

 

If you look on your server dashboard at the local address, is that correct?



#5 joekrill OFFLINE  

joekrill

    Member

  • Members
  • 27 posts
  • Local time: 03:12 PM

Posted 27 November 2018 - 04:42 PM

It hasn't been a problem before. It worked in the past with my Roku. It works fine with my Android TV (Shield), Fire TV, Android app, iOS app, through the web app, and using app.emby.media. This seems limited to the Roku app, and has started sometime within the past 2 months or so because it was previously working on a different Roku I have (though it has since stopped there, too, but I'm not sure when because I hadn't been using it much).

 

The local address is technically correct. As I said, I'm using docker. Docker creates a bridge network, so the server shows that IP address as it's local address. Then I have an nginx-proxy container running that handles TLS and acts as a reverse proxy. I've had this setup for quite some time without issue, and I use it with a lot of other images. I don't know why it would suddenly cause a problem - and only with the Roku. 

 

I've tried enabling debugging and then sending the log files -- I'm not entirely sure where they get sent to or how they are identifiable. 



#6 speechles ONLINE  

speechles

    Advanced Member

  • App Developer
  • 3673 posts
  • Local time: 01:12 PM

Posted 27 November 2018 - 04:48 PM

Go to the devices tab of the server and remove all the Roku entries you see.

 

Then..

 

1) Remove all emby apps from your Roku: Stable & Beta

2) Reboot your Roku (don't skip this step this is important)

3) Reinstall all emby apps to your Roku: Stable & Beta

 

This should restore you to a fresh state for your Roku. Now does it let you log in and remember?


Edited by speechles, 27 November 2018 - 04:49 PM.


#7 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 42823 posts
  • Local time: 04:12 PM

Posted 27 November 2018 - 05:26 PM

I've tried enabling debugging and then sending the log files -- I'm not entirely sure where they get sent to or how they are identifiable. 

 

Like this:

 

 

... use this button to send the log.  Then add the following information to your report in the forum:

 
  • Exactly what you were doing and what happened.  Include the name of whatever you played if it is a playback problem
  • The time you sent the log
  • The name of the Emby user on the local server that was logged in at the time


#8 joekrill OFFLINE  

joekrill

    Member

  • Members
  • 27 posts
  • Local time: 03:12 PM

Posted 28 November 2018 - 07:24 PM

I followed speechles instructions and the problem persists. Which isn't really surprising because this whole thing started with a brand-spankin' new Roku, so it should have been in a pretty fresh state to begin with.

 

I also enabled debugging and uploaded the logs. Here were the steps I took and approximate times (UTC times, November 28, 2018):

 

  • 23:08 - Launch Emby, connect manually changing the IP address to 192.168.1.163. Select user "Home", turn on debug logging in the settings, press back and exit Emby.
  • 23:09 - Launch Emby, forced to connect again so repeat the same as above, entering the IP address and using user Home. Resume "The Good Place" S03E01 at 3:39 and watch for 4 seconds. Exit Emby by pressing the Home button on the remote.
  • 23:11 - Launch Emby. Again forced to connect, repeat as above and Login again as user "Home". Go to settings and "Send Logs"


#9 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 42823 posts
  • Local time: 04:12 PM

Posted 29 November 2018 - 11:53 AM

The local address your server is reporting is not correct.  If you can get the server dashboard to show the proper local address (192.168.1.163), this should work. 



#10 joekrill OFFLINE  

joekrill

    Member

  • Members
  • 27 posts
  • Local time: 03:12 PM

Posted 29 November 2018 - 09:31 PM

Technically it _is_ correct... it has 2 IP addresses. I guess Emby just picks the first one it sees? I need it to bind to all addresses. Is there a way to specify which address it should consider "local" but still ensure it binds to all addresses?

 

Also, that would explain why it "forgets" when I use the local IP address (192.168.1.163) - but it also forgets when I use my external domain name (https://emby.example.com), and all my other devices work perfectly fine connecting that way.



#11 SquishyZa OFFLINE  

SquishyZa

    Newbie

  • Members
  • 4 posts
  • Local time: 03:12 PM

Posted 30 November 2018 - 12:47 AM

I have been struggling with the same thing. If I expose the UDP ports from the docker instance then the Roku displays the docker IP adress instead of the exposed IP adress. So I changed how I run docker and did not expose the UDP ports. Emby on the Roku then does not seem to find the server. So I wrote a little program to emulate the UDP broadcasting protocol and it works for iOS. But on the Roku it initially shows the correct IP until you try to connect, it fails, then it shows the docker IP adress. I tried finding the Roku source code, but the github repo I could find was updated 2 years ago and I hope the client is a bit more current than that? Next step may be to dump the http traffic to try and figure this out the hard way. So any pointers to the source or some way to configure the IP adress that the server advertises would be appreciated.

#12 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 121602 posts
  • Local time: 04:12 PM

Posted 30 November 2018 - 01:03 AM

I have been struggling with the same thing. If I expose the UDP ports from the docker instance then the Roku displays the docker IP adress instead of the exposed IP adress. So I changed how I run docker and did not expose the UDP ports. Emby on the Roku then does not seem to find the server. So I wrote a little program to emulate the UDP broadcasting protocol and it works for iOS. But on the Roku it initially shows the correct IP until you try to connect, it fails, then it shows the docker IP adress. I tried finding the Roku source code, but the github repo I could find was updated 2 years ago and I hope the client is a bit more current than that? Next step may be to dump the http traffic to try and figure this out the hard way. So any pointers to the source or some way to configure the IP adress that the server advertises would be appreciated.

 

Hi, does your Emby Server dashboard display the correct local address?



#13 SquishyZa OFFLINE  

SquishyZa

    Newbie

  • Members
  • 4 posts
  • Local time: 03:12 PM

Posted 30 November 2018 - 01:15 AM

No, it shows a 172.x.x.x adress which is the local IP of the docker container. The ports are forwarded to a 192.168.x.x adress that is reachable by the Roku.

#14 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 121602 posts
  • Local time: 04:12 PM

Posted 30 November 2018 - 01:31 AM

Ok so that is the issue. do you have docker in bridge or host networking mode?



#15 SquishyZa OFFLINE  

SquishyZa

    Newbie

  • Members
  • 4 posts
  • Local time: 03:12 PM

Posted 30 November 2018 - 02:07 AM

The default is bridge and that is what I used. I switched to host and it seems to work now. As a reference here is my docker-compose.yml file:

version: "3.2"
services:
emby:
environment:
- UID=500
- GID=100
image: emby/embyserver:latest
restart: unless-stopped
ports:
- 8096:8096
- 8920:8920
- 7359:7359/udp
network_mode: host
volumes:
- "./srv/emby/:/config"
- type: "volume"
source: "video"
target: "/mnt/Video"
volume:
nocopy: true
volumes:
video:
driver_opts:
type: "nfs"
o: "addr=192.168.1.16,soft,intr,noexec,ro"
device: ":/Video"

#16 Napsterbater OFFLINE  

Napsterbater

    Member

  • Members
  • 23 posts
  • Local time: 04:12 PM

Posted 03 December 2018 - 05:32 PM

I'm having this issue as well. I run emby on Windows server behind and nginx reverse proxy. All other emby clients seem to have no issue connecting to the server. Except Roku. They keep asking to sign in with the pin number. Though if I use the emby app on Android and remote control and tell it to play an episode it logs in fine plays the episode fine and it will stay logged in until I go back to the home screen.

I'll set up debugging and all that once I get home tonight and see what I can find and post that here but this was more of a you're not the only one type post.

#17 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 121602 posts
  • Local time: 04:12 PM

Posted 03 December 2018 - 05:41 PM

I would give host networking mode a shot and see how that compares.



#18 Napsterbater OFFLINE  

Napsterbater

    Member

  • Members
  • 23 posts
  • Local time: 04:12 PM

Posted 08 December 2018 - 01:37 PM

Ok, so I found my issues causing this.

 

I setup Emby Server (Windows) to Bind to a loopback IP ::1, as I normally do with everything I run behind nginx.

 

This was fine for remote clients, and any other local clients, Android, Windows, etc. But local Roku clients apparently did not like this for whatever reason.

 

Whether using Pin or connecting manually (Host/Port) always resulted in the Connect/Pin screen coming up again after closing Emby on the Roku and reopening it. Not sure why this is the case since they obviously can talk to Emby with the settings provided.

 

Anyways, in my case I simply let Emby bind to any/all IPs (leaving the field blank).

 

Maybe this will help anyone else seeing this. Though My casuse is a tad bit different then Ops same symptom though.



#19 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 121602 posts
  • Local time: 04:12 PM

Posted 08 December 2018 - 03:05 PM

Ok, so I found my issues causing this.

 

I setup Emby Server (Windows) to Bind to a loopback IP ::1, as I normally do with everything I run behind nginx.

 

This was fine for remote clients, and any other local clients, Android, Windows, etc. But local Roku clients apparently did not like this for whatever reason.

 

Whether using Pin or connecting manually (Host/Port) always resulted in the Connect/Pin screen coming up again after closing Emby on the Roku and reopening it. Not sure why this is the case since they obviously can talk to Emby with the settings provided.

 

Anyways, in my case I simply let Emby bind to any/all IPs (leaving the field blank).

 

Maybe this will help anyone else seeing this. Though My casuse is a tad bit different then Ops same symptom though.

 

What values had you entered into the Advanced screen exactly?



#20 Napsterbater OFFLINE  

Napsterbater

    Member

  • Members
  • 23 posts
  • Local time: 04:12 PM

Posted 08 December 2018 - 03:14 PM

What values had you entered into the Advanced screen exactly?

 

LAN networks: (Blank)

Bind to local network address: ::1    ***** Now Blank, only setting changed

Local http port number: 10974

Local https port number: 10975

Allow remote connections to this Emby Server. (Checked)

Remote IP address filter: (Blank)

Remote IP address filter mode: Whitelist

Public http port number: 80

Public https port number: 443

External domain: emby.(mydomain).net

Custom ssl certificate path: (Path to Cert)

Certificate password: (Blank, there is no PW on it)

Secure connection mode: Handled by reverse proxy

Enable automatic port mapping: (Unchecked)

Internet streaming bitrate limit (Mbps): (Blank)

 

 

 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users