Jump to content

Emby (DS918+) missing VAAPI encoder

Go to solution Solved by solabc16,

Recommended Posts

Previously in .65 it was there, along with Intel QuickSync and Samsung Exynos.

Now it's missing in .67

In .67 only Samsung Exynos is the available option.



Edited by kyrios
  • Like 1
Link to comment
Share on other sites


Hello @@kyrios, @@FrostByte


I've just published for your platforms ('apollolake'), let us know how you get on once you've installed it.


Appreciate if you can run the Diagnostics followed by the Send Logs utilities, once you're up and running.







- James

Edited by solabc16
Link to comment
Share on other sites




Mine after upgrading to .68-2-beta.



Edit: Still no VA-API, but everything else seems to be running great so far.

Edited by FrostByte
Link to comment
Share on other sites

Thanks for the logs @@kyrios and @@FrostByte, the installation itself looks good and the updated GPU 'plumbing' appears to be working correctly.
libva info: VA-API version 1.3.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /var/packages/EmbyServer/target/ffmpeg/lib/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_1_3
libva info: va_openDriver() returns 0
vainfo: VA-API version: 1.3 (libva 2.3.0)
vainfo: Driver version: Intel i965 driver for Intel(R) Broxton - 2.2.0
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointVLD
      VAProfileH264ConstrainedBaseline: VAEntrypointVLD
      VAProfileH264ConstrainedBaseline: VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline: VAEntrypointEncSliceLP
      VAProfileH264Main               : VAEntrypointVLD
      VAProfileH264Main               : VAEntrypointEncSlice
      VAProfileH264Main               : VAEntrypointEncSliceLP
      VAProfileH264High               : VAEntrypointVLD
      VAProfileH264High               : VAEntrypointEncSlice
      VAProfileH264High               : VAEntrypointEncSliceLP
      VAProfileH264MultiviewHigh      : VAEntrypointVLD
      VAProfileH264MultiviewHigh      : VAEntrypointEncSlice
      VAProfileH264StereoHigh         : VAEntrypointVLD
      VAProfileH264StereoHigh         : VAEntrypointEncSlice
      VAProfileVC1Simple              : VAEntrypointVLD
      VAProfileVC1Main                : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD
      VAProfileNone                   : VAEntrypointVideoProc
      VAProfileJPEGBaseline           : VAEntrypointVLD
      VAProfileJPEGBaseline           : VAEntrypointEncPicture
      VAProfileVP8Version0_3          : VAEntrypointVLD
      VAProfileVP8Version0_3          : VAEntrypointEncSlice
      VAProfileHEVCMain               : VAEntrypointVLD
      VAProfileHEVCMain               : VAEntrypointEncSlice
      VAProfileHEVCMain10             : VAEntrypointVLD
      VAProfileVP9Profile0            : VAEntrypointVLD

@@Luke, logs attached FYI.

- James



  • Like 1
Link to comment
Share on other sites


Just updated to .69-1 and I'm still seeing the same thing seen in the pic kyrios uploaded in post #1 and no VA-API option to check

Link to comment
Share on other sites


Hello @@FrostByte


If you don't have debug logging enabled (Dashboard -> Expert -> Logs) can you enable it, and then restart Emby Server (which you can do from the dashboard).


Then attach the most recent (embyserver.txt) log here so we can see what's going on.



- James

Link to comment
Share on other sites


Is decoder now implemented properly?



So this is not valid anymore?



Seems true

>>>>>>  FindVideoDecoder - MediaType: h264, Mode: 2
Info    FindVideoDecoder - Checking: 'VAAPI Device 32902:23173 - H.264 (AVC)' (Priority: 100)
Info    FindVideoDecoder - Check successful - selecting 'VAAPI Device 32902:23173 - H.264 (AVC)'

>>>>>>  FindVideoEncoder - Media: h264, UseHardwareCodecs: True, Mode: 2
Info    FindVideoEncoder - Checking: 'VAAPI Device 32902:23173 - H.264 (AVC)' (Priority: 100)
Info    Encoder supports input stream
Info    FindVideoEncoder - Check successful - selecting 'VAAPI Device 32902:23173 - H.264 (AVC)'
Edited by kyrios
Link to comment
Share on other sites

Those are the device names being reported by vaapi. If you think they're a joke then maybe we just shouldn't even have this feature.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...