Jump to content


Photo

Refresh Rate Switching Occurs Only Once


  • Please log in to reply
4 replies to this topic

#1 lisag OFFLINE  

lisag

    Advanced Member

  • Members
  • 236 posts
  • Local time: 04:15 PM

Posted 14 November 2018 - 04:41 AM

On a Windows 10 HTPC connected via HDMI to an AVR and then HDMI to a TV, graphics card is a Nvidia 1050. There is a second display connected to the onboard Intel graphics card via VGA which runs Frontview.

 

When I open ET and playback a file, refresh rate switches as it should. Once that video file stops if I re-start it or play a different video file, refresh rate switching does not occur.

 

If I close ET and re-open it, the same pattern occurs.

 

Reproducible 100% of the time.

 

 



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124107 posts
  • Local time: 12:15 PM

Posted 17 November 2018 - 05:13 PM

I wonder if this is isolated to dual gpu setups. @Doofus, are you able to reproduce this? Thanks.



#3 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 10955 posts
  • Local time: 09:15 AM

Posted 17 November 2018 - 06:17 PM

OK, so I wheeled out an old 1080 TV and hooked it up to the motherboard, leaving my main display and my receiver connected to two different ports on my GTX 1060, for a total of three displays with two GPUs. So it's a little different to @lisag. With refresh rate switching enabled, I tested playback of several types of video, 4k, 1080i etc. Each time, my refresh rate switched, successfully, and switched back after stopping playback. My main display was listed as display 2, and the 1080 was display 1, in the Windows settings, if that makes a difference. 

 

Lisa, I did discover one thing. With this kind of setup, if you use the deinterlacing profile, you want to use vf=lavfi=yadif not deinterlace=yes. The latter causes dropped frames, but for me, yadif didn't.



#4 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 10955 posts
  • Local time: 09:15 AM

Posted 17 November 2018 - 06:33 PM

Things to remember. I'm using the latest mpv Git build, and electron 2.0.11



#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124107 posts
  • Local time: 12:15 PM

Posted 17 November 2018 - 10:36 PM

Interesting, thanks for the info.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users