Jump to content


Photo

Emby Server Beta for MacOS


  • Please log in to reply
94 replies to this topic

#61 nerdwork OFFLINE  

nerdwork

    Newbie

  • Members
  • 9 posts
  • Local time: 10:41 AM
  • LocationSydney, Australia

Posted 18 October 2019 - 08:37 PM

Just a note for anyone that goes looking. 

 

I'm running Emby Server on a headless MacMini that I've recently upgraded to macOS 10.15 Catalina. After remotely installing the beta Server, I could no longer get Kodi or Emby Apps to play media.

 

Being headless, I didn't see that the OS was asking to give Emby permissions to access the respective Volumes and folders it requires, and the operating system was blocking access.

 

So, before anyone else pulls their hair out encountering this, if you upgrade Emby server on macOS Catalina, after starting it up be sure to look out for the folder access dialogs and give Emby the access it requires.

 

Also, on Catalina, after updating/installing Emby Server, you will need to right click and select "open" on the app. The OS will tell you it can't open it due to security reasons. Select cancel, then right click and select "open" again. This time you will be allowed to open the Emby Server app and all will be right with the world again.



#62 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152913 posts
  • Local time: 07:41 PM

Posted 18 October 2019 - 08:50 PM

That's interesting thanks for the info.

#63 mrfragger OFFLINE  

mrfragger

    Advanced Member

  • Members
  • 103 posts
  • Local time: 07:41 AM

Posted 22 October 2019 - 06:57 PM

I finished letting it convert h264 to hevc from a folder with 24 videos. It worked quite well. Yea it takes like 4 or 5 times longer cuz it won’t use all CPU cores like handbrake does but I think it’s great as to not tax the system.

I don’t have any other suggestions other than perhaps let one choose opus instead of mp3 and let us specifically choose the nitrate 96kbps for instance. But I think that would be sometime in the future. For now it’s quite good and works fantastic.

#64 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152913 posts
  • Local time: 07:41 PM

Posted 27 October 2019 - 08:25 PM

I've updated the build in the first post with the latest beta release. Thanks guys.



#65 mrfragger OFFLINE  

mrfragger

    Advanced Member

  • Members
  • 103 posts
  • Local time: 07:41 AM

Posted 02 November 2019 - 08:19 PM

4.3.0.15 beta was the last build I could use the convert hevc feature. 4.3.0.16 was the lastest Mac build and pressing the convert button does nothing. Anyone else on Mac notice the same thing?

#66 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152913 posts
  • Local time: 07:41 PM

Posted 03 November 2019 - 05:55 PM

I've updated the build in the first post with the latest beta release. Thanks everyone.



#67 mrfragger OFFLINE  

mrfragger

    Advanced Member

  • Members
  • 103 posts
  • Local time: 07:41 AM

Posted 03 November 2019 - 11:48 PM

4.3.0.19 beta the convert to hevc works again. Thanks for the fix. Yea really need someday to be able to select opus audio and bitrate. Don’t wanna keep aac 640kps for not all that important video.

Another suggestion would be since Emby now supports sub folders for subtitles perhaps put them automatically into one sub folder. Some videos have 20 subtitles and say there are 10 episodes that is 200 vtt subtitle files. Just saying it’s look easier for file management.

#68 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152913 posts
  • Local time: 07:41 PM

Posted 21 December 2019 - 07:05 PM

I've updated the build in the first post with the latest beta release. Thanks everyone.



#69 patje57 OFFLINE  

patje57

    Advanced Member

  • Members
  • 58 posts
  • Local time: 01:41 AM
  • LocationBelgium

Posted 15 January 2020 - 01:49 PM

Link to Mac OS beta points to the latest stable release, not any of the 4.4 betas, will you ever make 4.4 betas available?

The lack of beta's on MacOS as well as on Synology, is getting me frustrated now that there is so much fuss about changes made to the interface. Changes i only can read about, but which seems to go the wrong direction, at least for how i use and what i liked about Emby and let me make the switch > 1 year ago.

Hope to see re-appear beta's on at least on 1 of those platforms.    



#70 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152913 posts
  • Local time: 07:41 PM

Posted 15 January 2020 - 01:55 PM

I'll try to get one up soon.

#71 patje57 OFFLINE  

patje57

    Advanced Member

  • Members
  • 58 posts
  • Local time: 01:41 AM
  • LocationBelgium

Posted 15 January 2020 - 02:42 PM

Ok, thanks, Luke



#72 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152913 posts
  • Local time: 07:41 PM

Posted 20 January 2020 - 05:02 PM

I've updated the build in the first post with the latest beta release. Thanks everyone.



#73 patje57 OFFLINE  

patje57

    Advanced Member

  • Members
  • 58 posts
  • Local time: 01:41 AM
  • LocationBelgium

Posted 21 January 2020 - 12:46 PM

Good to see that after restart of the server there are no longer inactive instances left. Good it's solved



#74 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152913 posts
  • Local time: 07:41 PM

Posted 21 January 2020 - 12:49 PM

Thanks for the feedback.

#75 Sudopian OFFLINE  

Sudopian

    Newbie

  • Members
  • 4 posts
  • Local time: 01:41 AM
  • LocationMunich

Posted 28 January 2020 - 04:43 AM

Hi,

 

I just set up a new Emby server on a Mac mini (former server was a Synology DS2413+) with Emby macOS server beta 4.4.0.8 and I must say that the web player now plays videos much smoother (no micro stuttering on pans) ... Great work! I will continue to feed the server my entire library of round about 2600 movies and will continue testing on Apple TV and Fire TV 4K ..

 

Keep up the good work (because Plex is going Bye-Bye) :-)



#76 Sudopian OFFLINE  

Sudopian

    Newbie

  • Members
  • 4 posts
  • Local time: 01:41 AM
  • LocationMunich

Posted 28 January 2020 - 08:31 AM

So I came across a problem:

On the Server Web Page with Safari on macOS Catalina if I click on a "Quick.-Jump-Letter" in the movie section, I don't get the corresponding result (to clarify: I group all movies in collections). For example: I have organized most of my movies in applicable collections ... so "First Blood" is in the collection "Rambo" ... but if I click on the letter "R" I don't get the result for the collection "Rambo" ... same if I click on "F", I don't get "First Blood" (which actually is correct, because First Blood is a collection item of "Rambo").

 

Same thing happens on the latest iOS beta.

 

I hope I could make myself clear :-)

 

Is this a bug or a feature?



#77 johoja12 OFFLINE  

johoja12

    Member

  • Members
  • 29 posts
  • Local time: 06:41 PM

Posted 28 January 2020 - 12:05 PM

Hey, 

 

I don't see the osx link for the 4.4.0.10 beta downlod - is it possible to get a link to that ?



#78 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 558 posts
  • Local time: 01:41 AM

Posted 31 January 2020 - 02:40 PM

What happened to Mac betas? Not one since latest release. I am ready to test some. 



#79 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152913 posts
  • Local time: 07:41 PM

Posted 31 January 2020 - 02:50 PM

What happened to Mac betas? Not one since latest release. I am ready to test some. 

 

That's not true. As you can see I posted one on Jan 20.



#80 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 558 posts
  • Local time: 01:41 AM

Posted 31 January 2020 - 03:21 PM

That's not true. As you can see I posted one on Jan 20.

 

Ok, I missed that post, sorry! But still, there is nowhere to download any beta for Mac (?) The beta link in the first post of this thread is downloading latest release and not beta. Also on github there are no betas for Mac to be seen...

 

 Anyway, I would like to test the latest now. 


Edited by levander, 31 January 2020 - 03:22 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users