Jump to content


Photo
- - - - -

Subtitle doesn't appears


  • Please log in to reply
28 replies to this topic

#21 a_cow OFFLINE  

a_cow

    Newbie

  • Members
  • 4 posts
  • Local time: 04:44 PM

Posted 11 February 2019 - 02:50 PM

I want to chime in on this topic.

I to have a problem with subtitles dissapearing but only in special cases with ass subtitles when they display more than just simple text.

This is how it should look(Ignoring the red box arround revealing):

5c61c0ef2e0be_normal.jpg

With firefox and chrome I don't get any subtitles at all during this scene.

 

Edge meanwhile tries it's best to make something out of it:

5c61c1403f572_edge.jpg

As far as I can see it only happens with ass subtitles during scenes where there is more than a simple text and only with the web player.

If some log files or anything else can help please let me know.



#22 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 129329 posts
  • Local time: 11:44 AM

Posted 13 February 2019 - 02:57 AM

@a_cow it looks like that is file is a potentially more difficult example than usual. Can i get a copy of that file? thanks.



#23 a_cow OFFLINE  

a_cow

    Newbie

  • Members
  • 4 posts
  • Local time: 04:44 PM

Posted 13 February 2019 - 02:51 PM

@a_cow it looks like that is file is a potentially more difficult example than usual. Can i get a copy of that file? thanks.

Send you a PM with some snippets.



#24 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 129329 posts
  • Local time: 11:44 AM

Posted 13 February 2019 - 03:15 PM

Thanks !



#25 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 129329 posts
  • Local time: 11:44 AM

Posted 20 February 2019 - 03:16 AM

Please try beta server 4.1.0.9+, once available for your platform. Thanks.


  • a_cow likes this

#26 a_cow OFFLINE  

a_cow

    Newbie

  • Members
  • 4 posts
  • Local time: 04:44 PM

Posted 22 February 2019 - 04:30 PM

Works like a charm now :D. More stylised subtitle fonts also have correct spacing now and no longer overlap.

Really looking forward to when the next version is leaving beta.

I'm curios was it a problem with the large amount of fonts inside that mkv?

I've looked inside the mkv and 36 font files seems like quite a lot.



#27 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 129329 posts
  • Local time: 11:44 AM

Posted 22 February 2019 - 04:39 PM

No, this isn't really a bug fix, this is just going above and far beyond. web browsers do not support these subtitles. It is a lot of new development required to make this happen. Thanks.



#28 a_cow OFFLINE  

a_cow

    Newbie

  • Members
  • 4 posts
  • Local time: 04:44 PM

Posted 22 February 2019 - 04:59 PM

I see.

Than thank you and everyone behind emby for all that awesome work.

Makes sense that browser don't support ass/ssa since i don't think it is used that much outside the context of anime.



#29 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 129329 posts
  • Local time: 11:44 AM

Posted 22 February 2019 - 05:06 PM

Thanks for the feedback.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users