Jump to content

Emby behind FORWARD http proxy


MK.Persia
 Share

Recommended Posts

MK.Persia

Hi,

I have a native installation of Emby on Ubuntu 18.04 server

My problem is that the machine has no direct access to the Internet. Usually this problem can be solved by "export http_proxy=..." either in console or "/etc/environment". Unfortunately Emby doesn't use this environment variable and therefore I can't download any metadata or subtitles... I haven't found any setting nighter in GUI Dashboard or "/var/lib/emby/config/system.xml" (I thinkĀ <IsBehindProxy>true</IsBehindProxy> means is behind reverse proxy) but I think the trick is changing "MONO_ENV" in "/etc/emby-server.conf". Can anybody help me with this please?

Edited by MK.Persia
Link to comment
Share on other sites

Hi, it will be using .net core now instead of mono, so we'll have to look into how this will work with .net core (if it can). This is something we haven't tested before. Thanks.

Link to comment
Share on other sites

  • 3 years later...
5 hours ago, whytea said:

Hi, I have the same situation. Are there any new findings in the meantime?

Hi there, can you please describe your issue in more detail? Thanks.

Link to comment
Share on other sites

Styromaniac

Emby doesn't fully work with localxpose (doesn't get past the logo centered over the black background), and that's unfortunate, because my ISP is definitely blocking other reverse proxies like ngrok.

https://localxpose.io/

Localxpose works
for my static site if I use TOR Browser or a VPN client-side, so that's how I've proven that Localxpose works with my ISP.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...