Jump to content

Headegg
 Share

Recommended Posts

Hi there guys!

 

I have emby installed on my tinkerboard. Since I always make sure to have my files encoded in the right format it works splendidly for streaming movies and shows to me and my partner.

Weirdly, though, when my partner is streaming on her MacBook the video files always get remuxed. This proves to be too much to handle comfortably and the videostream buffers heavily every once in a while.

In the dashboard I get this notification:

The media is compatible with the device regarding resolution and media type (H.264, AC3, etc.), but is in an incompatible file container (.mkv, .avi, .wmv, etc.). The video will be re-packaged on the fly before streaming it to the device.

 

The file container I use for all of my files is mkv. Which would be the right container for MacOS Mojave?

 

From the ffmpeg log I could deduce that it is remuxing to a .ts file container. I already remuxed a file by hand to this container format, to see if it would be helping but the problem persists.

Here is an excerpt from the ffmpeg log:

 

/opt/emby-server/bin/ffmpeg -ss 00:13:00.000 -noaccurate_seek -f matroska -i file:"/sharedfolders/Serien/Suburgatory/S02/Suburgatory S02E15.mkv" -threads 0 -map 0:0 -map 0:1 -map -0:s -codec:v:0 copy -bsf:v h264_mp4toannexb -copyts -vsync -1 -codec:a:0 aac -strict experimental -ac 2 -ab 384000 -af "volume=2" -f segment -max_delay 5000000 -avoid_negative_ts disabled -map_metadata -1 -map_chapters -1 -start_at_zero -segment_time 6 -segment_time_delta -780 -individual_header_trailer 0 -break_non_keyframes 1 -segment_format mpegts -segment_list_type m3u8 -segment_start_number 130 -segment_list "/var/lib/emby/transcoding-temp/727ace9c2bb6a5a30bd4606c14e7d1c2.m3u8" -y "/var/lib/emby/transcoding-temp/727ace9c2bb6a5a30bd4606c14e7d1c2%d.ts"

 

 

Does anyone have any experience with streaming to MacOS in the Web App and could help me out?

Link to comment
Share on other sites

Hi Luke, so I remuxed the video files to mp4 and tried again, but the issue persists.

Could it be the audio format?

 

This is what the ffmpeg log shows:

 

 

{"Protocol":"File","Id":"dbe94e32252233cb79f1cafb2b829b03","Path":"/sharedfolders/Serien/Suburgatory/S02/S02E16.mp4","Type":"Default","Container":"mp4","Size":718751963,"Name":"S02E16","IsRemote":false,"ETag":"b6c510d456058a966889734f00744d19","RunTimeTicks":12930240512,"ReadAtNativeFramerate":false,"DiscardCorruptPts":false,"FillWallClockDts":false,"IgnoreDts":false,"IgnoreIndex":false,"SupportsTranscoding":true,"SupportsDirectStream":true,"SupportsDirectPlay":true,"IsInfiniteStream":false,"RequiresOpening":false,"RequiresClosing":false,"RequiresLooping":false,"SupportsProbing":true,"MediaStreams":[{"Codec":"h264","CodecTag":"avc1","Language":"und","ColorTransfer":"bt709","ColorPrimaries":"bt709","ColorSpace":"bt709","TimeBase":"1/90000","CodecTimeBase":"16162/775025","VideoRange":"SDR","DisplayTitle":"720P H264","NalLengthSize":"4","IsInterlaced":false,"IsAVC":true,"BitRate":4057199,"BitDepth":8,"RefFrames":1,"IsDefault":true,"IsForced":false,"Height":720,"Width":1280,"AverageFrameRate":23.9767666,"RealFrameRate":23.9760246,"Profile":"High","Type":"Video","AspectRatio":"16:9","Index":0,"IsExternal":false,"IsTextSubtitleStream":false,"SupportsExternalStream":false,"PixelFormat":"yuv420p","Level":31,"IsAnamorphic":false},{"Codec":"mp3","CodecTag":"mp4a","Language":"eng","TimeBase":"1/48000","CodecTimeBase":"1/48000","DisplayTitle":"Eng MP3 stereo Default","IsInterlaced":false,"ChannelLayout":"stereo","BitRate":384000,"Channels":2,"SampleRate":48000,"IsDefault":true,"IsForced":false,"Type":"Audio","Index":1,"IsExternal":false,"IsTextSubtitleStream":false,"SupportsExternalStream":false,"Level":0}],"Formats":[],"Bitrate":4446952,"RequiredHttpHeaders":{}}

User policy for Cassandra: EnablePlaybackRemuxing: True EnableVideoPlaybackTranscoding: True EnableAudioPlaybackTranscoding: True

/opt/emby-server/bin/ffmpeg -noaccurate_seek -f mp4 -i file:"/sharedfolders/Serien/Suburgatory/S02/S02E16.mp4" -threads 0 -map 0:0 -map 0:1 -map -0:s -codec:v:0 copy -bsf:v h264_mp4toannexb -copyts -vsync -1 -codec:a:0 aac -strict experimental -ac 2 -ab 384000 -f segment -max_delay 5000000 -avoid_negative_ts disabled -map_metadata -1 -map_chapters -1 -start_at_zero -segment_time 6 -individual_header_trailer 0 -break_non_keyframes 1 -segment_format mpegts -segment_list_type m3u8 -segment_start_number 0 -segment_list "/var/lib/emby/transcoding-temp/ea357fe801dd6e4afc47f4a782319c3e.m3u8" -y "/var/lib/emby/transcoding-temp/ea357fe801dd6e4afc47f4a782319c3e%d.ts"
Link to comment
Share on other sites

I attached the full log file to this message.

 

Sorry did you forget to hit attach.

Link to comment
Share on other sites

Not sure why "VideoCodecNotSupported" as it is copying the stream.  The file is being remuxed do to the audio track.  Seems rather odd for mp3 to be converted.

TranscodeReasons=VideoCodecNotSupported,AudioCodecNotSupported

Stream mapping:
  Stream #0:0 -> #0:0 (copy)
  Stream #0:1 -> #0:1 (mp3 (mp3float) -> aac (native))
Link to comment
Share on other sites

So it seems like the Mac Firefox/Safari doesn't like the mp3 format of those files, that's why it needs transcoding. Have remuxed them to aac it is direct streaming again. Weird situation.

Link to comment
Share on other sites

I would have expected that to direct play. It probably tried to direct play, then automatically switched to transcoding after the video player reported an error.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...