Jump to content
Saviq

Can't remote-control Kodi any more

Recommended Posts

Saviq

Hello,

 

For a while now (I believe with the beta addon - currently 3.1.31a) I can't control Kodi remotely from the Android app. It just never shows in the "play on" dropdown.

 

I can see the devices in Emby dashboard, but not in the Android app.

 

Anything more I can add?

Share this post


Link to post
Share on other sites
Angelblue05

Someone else reported this issue, I am still trying to figure out how why this would be happening. Was it working in .30a?

Share this post


Link to post
Share on other sites
Saviq

No, I don't think this ever worked for me in any 3.1.* version. I'd gladly help to debug if you suggest where to look.

  • Like 1

Share this post


Link to post
Share on other sites
Angelblue05

Can you do me a favor, with 3.1.32 I've added additional logging just to make sure the right things are happening. Can you start Kodi, wait until you see the welcome user message. Then post your Kodi log. Thank you.

Share this post


Link to post
Share on other sites
Saviq

Here's a `grep -i emby` from my kodi.log:

 

15:33:15.296 T:4090093584  NOTICE: ADDON: plugin.video.emby.tvshows v0.13 installed
15:33:15.296 T:4090093584  NOTICE: ADDON: repository.emby.kodi v1.0.3 installed
15:33:15.297 T:4090093584  NOTICE: ADDON: repository.beta.emby.kodi v1.0.5 installed
15:33:15.297 T:4090093584  NOTICE: ADDON: plugin.video.emby.musicvideos v0.13 installed
15:33:15.297 T:4090093584  NOTICE: ADDON: plugin.video.emby.movies v0.13 installed
15:33:15.298 T:4090093584  NOTICE: ADDON: plugin.video.emby v3.1.32a installed
15:33:16.474 T:4090093584 WARNING: Repository Kodi Emby Addons uses plain HTTP for add-on downloads - this is insecure and will make your Kodi installation vulnerable to attacks if enabled!
15:33:16.478 T:4090093584 WARNING: Repository Kodi Emby Beta Addons uses plain HTTP for add-on downloads - this is insecure and will make your Kodi installation vulnerable to attacks if enabled!
15:33:19.941 T:4021285744 WARNING: Repository Kodi Emby Addons uses plain HTTP for add-on downloads - this is insecure and will make your Kodi installation vulnerable to attacks if enabled!
15:33:19.946 T:4021285744 WARNING: Repository Kodi Emby Beta Addons uses plain HTTP for add-on downloads - this is insecure and will make your Kodi installation vulnerable to attacks if enabled!
15:33:22.008 T:4090093584 WARNING: Repository Kodi Emby Addons uses plain HTTP for add-on downloads - this is insecure and will make your Kodi installation vulnerable to attacks if enabled!
15:33:22.010 T:4090093584 WARNING: Repository Kodi Emby Beta Addons uses plain HTTP for add-on downloads - this is insecure and will make your Kodi installation vulnerable to attacks if enabled!
15:33:22.019 T:4090093584 WARNING: Repository Kodi Emby Addons uses plain HTTP for add-on downloads - this is insecure and will make your Kodi installation vulnerable to attacks if enabled!
15:33:22.020 T:4090093584 WARNING: Repository Kodi Emby Beta Addons uses plain HTTP for add-on downloads - this is insecure and will make your Kodi installation vulnerable to attacks if enabled!
15:33:24.634 T:3835679600 WARNING: Repository Kodi Emby Addons uses plain HTTP for add-on downloads - this is insecure and will make your Kodi installation vulnerable to attacks if enabled!
15:33:24.641 T:3835679600 WARNING: Repository Kodi Emby Beta Addons uses plain HTTP for add-on downloads - this is insecure and will make your Kodi installation vulnerable to attacks if enabled!
15:33:24.852 T:3835679600 WARNING: Repository Kodi Emby Addons uses plain HTTP for add-on downloads - this is insecure and will make your Kodi installation vulnerable to attacks if enabled!
15:33:24.857 T:3835679600 WARNING: Repository Kodi Emby Beta Addons uses plain HTTP for add-on downloads - this is insecure and will make your Kodi installation vulnerable to attacks if enabled!
15:33:24.889 T:3835679600 WARNING: Repository Kodi Emby Addons uses plain HTTP for add-on downloads - this is insecure and will make your Kodi installation vulnerable to attacks if enabled!
15:33:24.890 T:3835679600 WARNING: Repository Kodi Emby Beta Addons uses plain HTTP for add-on downloads - this is insecure and will make your Kodi installation vulnerable to attacks if enabled!
15:33:28.618 T:3776557936  NOTICE: EMBY.service -> -->[ service ]
15:33:28.633 T:3776557936  NOTICE: EMBY.service -> Delay startup by 0 seconds.
15:33:28.705 T:3776557936  NOTICE: EMBY.entrypoint.service -> --->>>[ EMBY ]
15:33:28.706 T:3776557936  NOTICE: EMBY.entrypoint.service -> Version: 3.1.32a
15:33:28.712 T:3776557936  NOTICE: EMBY.entrypoint.service -> KODI Version: 18.0-BETA3 Git:18.0b3-Leia
15:33:28.740 T:3776557936  NOTICE: EMBY.entrypoint.service -> Platform: Linux
15:33:28.741 T:3776557936  NOTICE: EMBY.entrypoint.service -> Python Version: 2.7.15 (default, Oct  4 2018, 02:41:36) 
15:33:28.755 T:3776557936  NOTICE: EMBY.entrypoint.service -> Using dynamic paths: True
15:33:28.756 T:3776557936  NOTICE: EMBY.entrypoint.service -> Log Level: 1
15:33:29.841 T:3776557936  NOTICE: EMBY.entrypoint.service -> ---[ db/None ]
15:33:30.008 T:3776557936  NOTICE: Emby.emby.core.configuration -> Begin http constructor.
15:33:30.042 T:3776557936  NOTICE: Emby -> ---[ START EMBYCLIENT ]---
15:33:31.344 T:3776557936  NOTICE: EMBY.entrypoint.service -> --[ check updates/181127230 ]
15:33:31.628 T:3776557936  NOTICE: EMBY.entrypoint.service -> --[ objects/181127230 ]
15:33:31.655 T:3776557936  NOTICE: EMBY.client -> DeviceId loaded: 4B3385B2FB80407ABFDA23AE90EBCF45
15:33:31.674 T:3799929712  NOTICE: EMBY.monitor -> --->[ listener ]
15:33:31.674 T:3776557936  NOTICE: EMBY.connect -> --[ server/default ]
15:33:31.687 T:3776557936  NOTICE: Emby.emby.core.configuration -> Begin app constructor.
15:33:31.699 T:3776557936  NOTICE: Emby.emby.core.connection_manager -> Begin connect
15:33:31.700 T:3776557936  NOTICE: Emby.emby.core.connection_manager -> Begin getAvailableServers
15:33:31.701 T:3776557936  NOTICE: Emby.emby.core.connection_manager -> Begin getConnectServers
15:33:33.372 T:3776557936  NOTICE: Emby.emby.core.connection_manager -> Found Servers: []
15:33:33.391 T:3776557936  NOTICE: Emby.emby.core.connection_manager -> Begin connectToServers, with 2 servers
15:33:33.404 T:3776557936  NOTICE: Emby.emby.core.connection_manager -> begin connectToServer
15:33:33.405 T:3776557936  NOTICE: Emby.emby.core.connection_manager -> beginning connection tests
15:33:33.407 T:3776557936  NOTICE: Emby.emby.core.connection_manager -> testing connection mode 2 with server emby.server
15:33:33.411 T:3776557936  NOTICE: Emby.emby.core.connection_manager -> tryConnect url: http://{emby-server}/emby/system/info/public
15:33:41.462 T:3776557936  NOTICE: Emby.emby.core.http -> ERROR:: HTTPConnectionPool(host='10.0.5.143', port=8096): Max retries exceeded with url: /emby/system/info/public (Caused by ConnectTimeoutError(<libraries.requests.packages.urllib3.connection.HTTPConnection object at 0xe927b9b0>, 'Connection to 10.0.5.143 timed out. (connect timeout=8)'))
15:33:41.464 T:3776557936  NOTICE: Emby.emby.core.connection_manager -> ERROR::
15:33:41.466 T:3776557936  NOTICE: Emby.emby.core.connection_manager -> ERROR:: test failed for connection mode 2 with server emby.server
15:33:41.468 T:3776557936  NOTICE: Emby.emby.core.connection_manager -> testing connection mode 0 with server emby.server
15:33:41.470 T:3776557936  NOTICE: Emby.emby.core.connection_manager -> tryConnect url: http://{emby-server}/emby/system/info/public
15:33:49.531 T:3776557936  NOTICE: Emby.emby.core.http -> ERROR:: HTTPConnectionPool(host='10.0.5.143', port=8096): Max retries exceeded with url: /emby/system/info/public (Caused by ConnectTimeoutError(<libraries.requests.packages.urllib3.connection.HTTPConnection object at 0xe2a3e6f0>, 'Connection to 10.0.5.143 timed out. (connect timeout=8)'))
15:33:49.533 T:3776557936  NOTICE: Emby.emby.core.connection_manager -> ERROR::
15:33:49.535 T:3776557936  NOTICE: Emby.emby.core.connection_manager -> ERROR:: test failed for connection mode 0 with server emby.server
15:33:49.536 T:3776557936  NOTICE: Emby.emby.core.connection_manager -> testing connection mode 1 with server emby.server
15:33:49.538 T:3776557936  NOTICE: Emby.emby.core.connection_manager -> tryConnect url: https://{emby-server}/emby/system/info/public
15:33:49.786 T:3776557936  NOTICE: Emby.emby.core.connection_manager -> calling onSuccessfulConnection with connection mode 1 with server emby.server
15:33:50.492 T:3776557936  NOTICE: Emby.emby.core.connection_manager -> connectusersignedin {u'DisplayName': u'Saviq', u'Name': u'user@[member="emby.server"]', u'ImageUrl': u'', u'ExpDate': None, u'Id': u'', u'IsSupporter': None, u'Email': u'user@[member="emby.server"]', u'IsActive': u'true'}
15:33:51.021 T:3776557936  NOTICE: Emby.emby.client -> User is authenticated.
15:33:51.397 T:3553616752  NOTICE: Emby.emby.core.ws_client -> Websocket url: wss://{emby-server}/embywebsocket?api_key={emby-token}&device_id=4B3385B2FB80407ABFDA23AE90EBCF45
15:33:51.498 T:3553616752  NOTICE: Emby.emby.core.ws_client -> --->[ websocket ]
15:33:51.520 T:3776557936  NOTICE: EMBY.setup -> ---<[ setup ]
15:33:51.990 T:3536831344  NOTICE: EMBY.library -> --->[ library ]
15:33:51.995 T:3776557936  NOTICE: EMBY.monitor -> --[ post capabilities/875071b85df9418c80663ed89411203c ]
15:33:52.638 T:3536831344  NOTICE: EMBY.database -> [emby] 1 rows updated.
15:33:53.905 T:3536831344  NOTICE: EMBY.library -> --[ retrieve changes ] 2018-10-18T12:55:29z
15:33:54.970 T:3536831344  NOTICE: EMBY.library -> --<[ retrieve changes ]
The failures are, IIUC, expected (it's the internal IP of the container emby's running on, it's then reverse-proxied onto a public IP).

 

EDIT: The previous log was from 3.1.31a, sorry - had some trouble installing the new version.

Edited by Saviq

Share this post


Link to post
Share on other sites
Angelblue05

Looks absolutely normal to me. You say you are using a reverse proxy? Do you see any other apps under Play To other than dlna?

Share this post


Link to post
Share on other sites
Saviq

Yeah, Firefox shows up if I have the tab open there, and I can control the Android app from Firefox.

There's also one other related issue:

5bc992821503e_Zrzutekranuz20181019101415
 
I have the second user added as permanent on one of the profiles, and it looks like it just adds it on top of the one's already there. May very well be an Emby bug where it should deduplicate this?

Share this post


Link to post
Share on other sites
Angelblue05

Ok so first, the device shows up under the dashboard > active devices, but not in the list Play To?

 

As for your issue, are you using permanent users in the session? Addon settings > Interface?

Edited by Angelblue05

Share this post


Link to post
Share on other sites
Saviq

Yes, the device shows up in the dashboard, just not in Play To.

 

And yes, the second, multiplicated user is "permanent" in this Kodi profile. Other profiles just have a single user and they all show up in the Emby dashboard, but none of them do show in Play To.

Share this post


Link to post
Share on other sites
Charlie117

I'd like to report the same issue as Saviq. Basically the same details, the client does show up in the dashboard but not in the Play To list.

Edited by charliehd

Share this post


Link to post
Share on other sites
Angelblue05

What server version/platform are you using? Using the same emby user in both Kodi and webclient?

 

I still don't know what the issue could be on that one because I haven't managed to replicate this.

Edited by Angelblue05

Share this post


Link to post
Share on other sites
Saviq

For me it's Ubuntu 18.04, Emby 3.6.0.69, latest Emby for Kodi addon. Same user in both Kodi and the web client / android app.

  • Like 1

Share this post


Link to post
Share on other sites
Angelblue05

Other apps show up under Play to, correct?

Share this post


Link to post
Share on other sites
Angelblue05

Ok can you do me a favor? In the add-on settings > advanced > disable mask sensitive info. Under advanced still > Set your log level to debug. Restart Kodi, wait about 30 seconds after seeing the welcome message from the add-on. PM your Kodi log, can you also provide your server log from that time. Thanks. I just want to ensure the actual call for posting capabilities is made correctly.

Edited by Angelblue05

Share this post


Link to post
Share on other sites
Charlie117

What server version/platform are you using? Using the same emby user in both Kodi and webclient?

 

I still don't know what the issue could be on that one because I haven't managed to replicate this.

 

Sorry for the delay.

 

I'm running Emby Server 3.6.0.68 beta on Ubuntu 18.04.

Using the same Emby user for both Kodi and the webclient (and also iOS mobile client).

 

Please let me know if you'd like a log from me as well.

Share this post


Link to post
Share on other sites
Angelblue05

@@Charlie117

 

If you can do what's in the post above, that would be super helpful, thank you.

Share this post


Link to post
Share on other sites
Saviq

Ok can you do me a favor? In the add-on settings > advanced > disable mask sensitive info. Under advanced still > Set your log level to debug. Restart Kodi, wait about 30 seconds after seeing the welcome message from the add-on. PM your Kodi log, can you also provide your server log from that time. Thanks. I just want to ensure the actual call for posting capabilities is made correctly.

 

Hey, sorry for the late reply, but PM sent.

Share this post


Link to post
Share on other sites
Angelblue05

Should be resolved with 3.1.36a

Share this post


Link to post
Share on other sites
Saviq

Indeed! Thanks a lot, glad I could help.

 

There's still the issue with multiplied session users (see reply #7).

 

Shall I add a separate thread for that? It's only listed once in Emby for Kodi settings, or maybe you think it's an Emby issue?

Edited by Saviq
  • Like 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...