Jump to content

GIT version behaves differently from 0.8.5


tube82
 Share

Go to solution Solved by xnappo,

Recommended Posts

Hi,

 

thanks for this great plugin! I am using the modded Arctic skin with the 0.8.5 version of XBMB3C and it works quite well.

 

I just tried the current GIT version and noticed problems with TV shows since then.

 

Using version 0.8.5, the home looks perfect. Cover, thumb and clearlogo are shown correctly. In the GIT version the thumb is shown instead of the cover and there is no clearlogo.

The display of art doesn't work correctly in other windows either. As can be seen in the other screenshots of TV show and season view, no TV show/season art is shown.

Using the 0.8.5 version those images are shown as expected.

 

Did the handling of art change so I have to update something the skin oder is this a bug?

For movies I didn't notice any problems. Cover and clearlogo are shown in the homescreen and in the lists everything works as well.

Edited by tube82
  • Like 1
Link to comment
Share on other sites

First - did you restart XBMC after installing the Git version?  The image service we use will only refresh when XBMC restarts.

 

Now - there have been a lot of changes with how images are handled.  First was a re-write to ensure that images were refreshed when they changed on the server, and second was a re-write to clean up the code now that Gotham supports all images.

 

I am looking at it, but can you please do me a favor and try this version:

https://github.com/MediaBrowser/MediaBrowser.XBMC/archive/ff5404e8fd987a8ddff53873705bed3b8a2950ff.zip

 

That has the first change but not the second and will help narrow things down.

 

xnappo

Link to comment
Share on other sites

That version behaves a little differently:

 

The homescreen looks like in the other GIT version: No clearlogo and thumb instead of cover.

The TV show and season views both show the TV Show cover.

 

Anthing else I could test or provide you with?

  • Like 1
Link to comment
Share on other sites

I just checked in a change - give it a shot.

 

Thanks for testing!

xnappo

 

[EDIT] Also - what is that on your home screen?  Next Up or Recently Added?

 

[EDIT2] Disregard - I see the problem.  Fixing..

Edited by xnappo
  • Like 1
Link to comment
Share on other sites

Not seeing a new commit yet, but as soon as I do i'll give it a go.

 

I use NextUpEpisode on home screen. Just switched to RecentlyAdded, but the result is the same.

 

[EDIT] Alright, I'll test your fix once it's ready

Edited by tube82
  • Like 1
Link to comment
Share on other sites

It gets interesting, haha.

 

TV Shows widget is perfect. Series art, clearlogo and thumb display as they should.

 

However, recent movies doesn't fill at all now.

 

No changes in the TV show and season lists, but I guess thats not where you changed stuff.

 

[EDIT]

Last commit fixed it. Movie and TV Show shelfs work perfectly again!

Edited by tube82
  • Like 1
Link to comment
Share on other sites

Okay - but the damn poster in series is still borked right?

 

I am going blind looking for it - the weird thing is it works fine in Aeon Nox.

 

Can you give me more details on that?  Does it work right in movies, boxsets, top-level tv and broken in seasons and epsiodes?

 

Thanks again for your patience.

 

xnappo

Link to comment
Share on other sites

Just checked and as a matter of fact, it doesn't work for movies either. Had not checked before because there didn't seem to be problems with movies and I use the wall view for movies where the covers actually show.

 

So this might be a problem with the modded skin!? It works with 0.8.5, though.

Edited by tube82
  • Like 1
Link to comment
Share on other sites

Yeah.. I wish I knew if that skin was trying to use the Thumb there or the Poster.  They are both the same from the MB3 side.

 

May not get to this today.

 

xnappo

Link to comment
Share on other sites

If I looked at the correct part, the view wants to display $VAR[ListInfoPosterVar], which is defined as:

 

<variable name="ListInfoPosterVar">
        <value condition="Container.Content(episodes) + !IsEmpty(ListItem.Art(tvshow.poster))">$INFO[ListItem.Art(tvshow.poster)]</value>
        <value condition="!IsEmpty(ListItem.Art(poster))">$INFO[ListItem.Art(poster)]</value>
        <value condition="IsEmpty(ListItem.Art(poster)) + !IsEmpty(ListItem.Thumb) + !Container.Content(movies) + !Container.Content(tvshows) + !Container.Content(episodes) + !Container.Content(Seasons)">$INFO[ListItem.Thumb]</value>
<value>$INFO[ListItem.ActualIcon,views/fallbacks/,/large.png]</value>
    </variable>
 
Does that look like something that should work?
 
[edit] After changing poster to thumb in all cases shown above it seems to work.
 
Quick question: Thumb of an episode is the screenshot from the episode, correct? As thumb and poster are the same, does that mean it is impossible to display the series/season poster of a listitem that is an episode or is there a workaround? I know there is a setting to replace the thumb by the series art, but that is not what i mean. I'd like to display series/season poster in addition, not instead of the thumb.
 
Oh, and thanks for the quick bugfix!
Edited by tube82
  • Like 1
Link to comment
Share on other sites

im looking into this on the arctic-xbmb3c skin side. 

after getting the newest git, all my images refreshed and it seemed like everything is working, but i have missing covers for some views too.  i will see if i can just switch those over to whatever is being called in the views that are working.

 

on a side note, the ccd60ed0f606203c16a4761a97cc0c34277f56ca  commit has broken the music widget for me, and the way my sub menu items were set on the home screen, is this what your seeing tube82? 

 

@@xnappo  did you change the following variables in the recent commits?:

 

xbmb3c.XX.title

xbmb3c.XX.path

xbmb3c.XX.type

Edited by elcabong
  • Like 1
Link to comment
Share on other sites

I didn't change them, but someone else may have.

 

Ugh - my head is spinning looking at it.

 

@@im85288 @ - help?

 

xnappo

Edited by xnappo
Link to comment
Share on other sites

@@elcabong

 

Can't test music because my mb3 music library is empty.

 

Changing "poster" to "thumb" in the views with missing covers fixed the problem for me. Movie, series, season and episode thumb are shown in e.g. PanelList now.

 

Submenues that link to XBMB3C sections don't work for me anymore either, just checked.

  • Like 1
Link to comment
Share on other sites

Also broken is background art (fanart_image).

 

I will look more tomorrow.

 

xnappo

Link to comment
Share on other sites

tested with xperience1080plusplus and music widget is not working as well as the submenu items, so i dont think im85288 changed anything there.  i have updated the arctic-xbmb3c git to reflect the new poster fix.  i have rolled back to using 0.8.5 for consistency, and everything is working as it should.

Edited by elcabong
  • Like 1
Link to comment
Share on other sites

@@xnappo

 

I don't know what exactly you mean by "all", but using poster instead of thumb works again, well done!

 

The sub menu items still don't, but that is the only thing left as far as I can tell.

Edited by tube82
  • Like 1
Link to comment
Share on other sites

What do you mean by sub menu items?

 

xnappo

 

I mean sub menu items in the home screen. E.g. shortcuts to recently added, fav movies, box sets or trailers in a sub menu of movies.

 

In the skin they are accessed via

 

xbmb3c.XX.title

xbmb3c.XX.path

xbmb3c.XX.type

 

but those don't seem to work.

 

[edit]

Another small bug I noticed: The XBMB3C sections don't show icons in front of them anymore. They used to show a folder icon in 0.8.5.

post-3425-0-78215600-1397397502_thumb.png

post-3425-0-08036200-1397397506_thumb.png

Edited by tube82
  • Like 1
Link to comment
Share on other sites

LOL, this is something @@im85288 - I don't know what you are talking about.  I use Aeon Nox - this must be some Arctic/xpereience1080++ thing?

 

You are talking about something other than the widget right?

 

Like the recent Widget data comes from this:

            WINDOW.setProperty("LatestMovieMB3." + str(item_count) + ".Title", title)
            WINDOW.setProperty("LatestMovieMB3." + str(item_count) + ".Thumb", thumbnail)
            WINDOW.setProperty("LatestMovieMB3." + str(item_count) + ".Path", playUrl)

That works fine tho - so you are talking about something else?

 

xnappo

Edited by xnappo
Link to comment
Share on other sites

I'll try to explain it with two screenshots.

 

This is my home screen in 0.8.5:

post-3425-0-60342000-1397399973_thumb.png

 

and this is my home screen in the git version:

post-3425-0-32088700-1397399978_thumb.png

 

The code for the first of those buttons is:

<item id="0">
 <label>$INFO[Window(home).Property(xbmb3c.3.title)]</label>
 <onclick>$INFO[Window.Property(xbmb3c.3.path)])</onclick>
 <property name="Poster">$INFO[Skin.String(Home.Movies.Tile.1.Icon)]</property>
 <property name="showlabel">$INFO[Skin.String(Home.Movies.Tile.1.ShowLabel)]</property>
 <property name="path">$INFO[Skin.String(Home.Movies.Tile.1.Path)]</property>
 <property name="animate">$INFO[Skin.String(Home.Movies.Tile.1.Animate)]</property>
 <property name="custom">1</property>
 <visible>substring(Window(home).Property(xbmb3c.3.type),movies)</visible>
 <visible>Container(525).HasFocus(1)</visible>
</item>
Edited by tube82
  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...