Jump to content

Wants to sync all updates


ddurdle
 Share

Recommended Posts

ddurdle

I noticed this once yesterday and ended up zapping the KODI and restarting from scratch, and didn't have the issue after that.

 

But the first time I was trying to do a fresh install, it wanted to pull down all the updates (over 42,000) from the server as part of the full initial sync as well as still do the full initial sync.  After zapping everything and restarting from an emby KODI db, I didn't see the issue again.

 

But I have a few users trying to test on devices like an apple tv with kodi installed and zapping all files isn't an easy thing.  When they start off with a "reset db" and install the plugin fresh from the repository, right after logging into the plugin, it wants to pull down 42,000 updates before asking the user if they want to do a sync and which folders they want to sync.  That part comes after you accept the 42,000 updates that starts chugging away.

 

A few others are reporting the same behaviour.

  • Like 1
Link to comment
Share on other sites

Thanks for making aware of this. I will correct this behavior for the next build.

 

Maybe it got broken inbetween mini-versions? This behavior def. didn't happen on any of my 3 machines. But I didnt do a reset in almost 2 weeks now.

  • Like 1
Link to comment
Share on other sites

Angelblue05

Yes it got broken as I was fixing the resume sync behavior at startup.

Edited by Angelblue05
  • Like 1
Link to comment
Share on other sites

Yes it got broken as I was fixing the resume sync behavior at startup.

 

Gotcha. By the way, unrelated and just noticed, if I check "disable screen saver" (during sync? cant recall the full sentence), it prevents Shield from going to sleep in the middle of a scan or just the screensaver itself?

 

If I recall, when this option wasn't there and incase my shield kicked in its screensaver, I could "resume" (not really, it almost started from scratch) where it would stop.

 

I might reset one database and test it out myself but why not be lazy and ask  :D

Edited by djhifi
Link to comment
Share on other sites

Angelblue05

Yes it prevents both the screensaver and sleep from happening while the addon is processing content updates.

  • Like 1
Link to comment
Share on other sites

Yes it prevents both the screensaver and sleep from happening while the addon is processing content updates.

 

Nice. I did read the release notes on that particular version and must've skipped that info.

 

Amazing news and adressed one of my PMs I've sent you in the past.

 

Keep up the good work. I'm here to help squash bugs.

  • Like 1
Link to comment
Share on other sites

Angelblue05

You didn't miss it as I believe I said screensaver but it's always been disabling both. And I really appreciate that, thanks! :)

  • Like 1
Link to comment
Share on other sites

You didn't miss it as I believe I said screensaver but it's always been disabling both. And I really appreciate that, thanks! :)

 

I wasn't aware of that then. 

 

But btw, I've just checked and it doesn't say "disable screensaver during syncs" but rather "Allow the screensaver during syncs". So, to prevent sleep and screensaver during sync i must leave it unchecked, correct? You might want to double check the sentence, or I'm dumb and get confused easily  :D 

 

Ontopic: I've remembered something regarding this issue (OP). The other day when I sent you a log that showed a "huge server update" maybe it was related with this issue afterall? I ask this because on that day, all I did server-wise was a "scan all libraries" command. Because I wanted to delete old and removed entries.

And the plugin indeed showed me, out of the blue, that I had 17k+ things to process. Which is not normal since that "scan all libraries" took 9min since all is already scanned and scrapped for a month now.

 

Maybe it's not related but I've just remembered this since I've only been doing specific library updates or letting the Realtime Monitor kick in on the server when I add new content.

Edited by djhifi
Link to comment
Share on other sites

Angelblue05

As I stated in the reply, the add-on does not generate events, the server does, or when you interact with content. So your server definitely generate that many updates.

 

What the op is speaking of, is after the initial sync, it kicks in the startup sync which it shouldn't be doing.

 

Allow - Enable didn't seem right. English is not my main language, I try my best :) Suggestion? And yes, disable the setting to prevent sleep/screensaver.

Link to comment
Share on other sites

  • 2 weeks later...
Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...