Jump to content

Emby Server 3.5.3.0: failed install on Ubuntu 18.04.1 server


devbie
 Share

Go to solution Solved by devbie,

Recommended Posts

Hi All,

 

I have tried to upgrade my existing Emby server using the the new installation method for the 1st time and it failed - can someone please help? The Emby server is down and I have the whole family breathing down my neck to fix it.

 

Any help is greatly appreciated

Thanks

 

Here go all the relevant details I can think of:

 

I am running Ubuntu Server 18.04.1.

 

I had been using the old Suse repo set in etc/apt/sources.list.d/emby-server.list

# deb http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04/ / # disabled on upgrade to bionic
 

Today I have tried:

wget https://github.com/MediaBrowser/Emby.Releases/releases/download/3.5.3.0/emby-server-deb_3.5.3.0_amd64.deb

sudo service stop emby-server
sudo dpkg
-i emby*

 

I get the following errors:

 

$ sudo dpkg -i emby-server-deb_3.5.3.0_amd64.deb
(Reading database ... 93956 files and directories currently installed.)
Preparing to unpack emby-server-deb_3.5.3.0_amd64.deb ...
Stopping Emby Server!
Unpacking emby-server (3.5.3.0) over (3.3.1.0+68.1) ...
Setting up emby-server (3.5.3.0) ...
Installing new version of config file /etc/emby-server.conf ...
Installing new version of config file /etc/init/emby-server.conf ...
usermod: user emby is currently used by process 596
dpkg: error processing package emby-server (--install):
 installed emby-server package post-installation script subprocess returned error exit status 8
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Processing triggers for ureadahead (0.100.0-20) ...
ureadahead will be reprofiled on next reboot
Errors were encountered while processing:
 emby-server

 

Thanks

Link to comment
Share on other sites

Yes, that's the whole output of the dpkg command.

 

I initially ran it with the previous version (3.3.0.1) still installed. When it failed, I ran:

 

sudo apt-get remove emby-server
sudo apt-get remove emby-server --purge
sudo apt-get autoremove
sudo apt-get autoclean
 

before re-running

sudo dpkg -i emby-server-deb_3.5.3.0_amd64.deb

 

The error message was the same both times

 

Any thoughts?

Thanks

Link to comment
Share on other sites

I'm not sure. You could try purging the old apt repository. Also the name of your system user isn't emby, is it?

Link to comment
Share on other sites

It's possible yes. It's hard to say if that's the issue or not given the absence of a helpful error message in that terminal output.

Link to comment
Share on other sites

  • Solution

Problem solved. Let me just summarise it in case someone else falls into the same rabbit hole.

 

The installation was failing because I had a manually created a user called emby.

 

I must have originally created user emby to own all the media files for the emby server. Later on I installed Madsonic to serve my music - with the media pointing to the original files owned by user emby.

 

The installation failed because a process from the Madsonic server was using user emby (possibly just pointing at directories owned by user emby).

 

I was able to install the latest release of the Emby server once I uninstalled Madsonic, changed the owner of the media files, and manually deleted the account for user emby

 

Luke, thanks for your help.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...