Jump to content


Photo

AAC Audio Passthroufh


Best Answer jmccl069 , 05 February 2019 - 11:58 PM

 

  1. In the folder where you made the mpv.conf, make a folder called scripts
  2. Copy the auto-profiles.lua to the scripts folder (delete the .txt)
  3. Copy this profile to your mpv.conf, make it the last entry at the bottom
[AAC to AC3]
profile-desc=cond:p["audio-codec"]==aac
af=lavcac3enc=yes:384:2

Take it for a spin!

 

 

 

 

A little amendment for this. I just discovered that profile will enable AC3 encoding for ANY non-bitstreamed audio, not just aac. I have found a better profile. This will be codec specific. Try this @jmccl069

[AAC to AC3]
profile-desc=cond:p["audio-codec-name"]=="aac"
af=lavcac3enc=yes:384:2

 

Just tried this...

 

Works a treat!!!

 

Thanks again @Doofus

Go to the full post


  • Please log in to reply
58 replies to this topic

#41 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11341 posts
  • Local time: 02:01 PM

Posted 29 November 2018 - 09:24 PM

I followed your instructions on post #12 however can't get it to bitstream. My receiver decodes AAC natively so I thought the easiest way to get surround sound would be to bitstream.

 

Since I can't get that to work I thought I may as well go the AC3 route...

 

Do you have any stereo  AAC audio that you don't want to be AC3?



#42 jmccl069 OFFLINE  

jmccl069

    Member

  • Members
  • 29 posts
  • Local time: 09:01 PM

Posted 29 November 2018 - 10:32 PM

No... AC3 for everything is fine...

#43 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11341 posts
  • Local time: 02:01 PM

Posted 29 November 2018 - 10:36 PM

No... AC3 for everything is fine...

 

OK, so the thread directly below this, actually has all the info you need. You can start with this post, and read through. Let me know if you get stuck.

 

https://emby.media/c...eater/?p=516907



#44 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11341 posts
  • Local time: 02:01 PM

Posted 29 November 2018 - 10:39 PM

If that's TL;DR, then if you've already made an mpv.conf, just add this line

af=lavcac3enc=yes:384:2


#45 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11341 posts
  • Local time: 02:01 PM

Posted 29 November 2018 - 10:42 PM

One thing, though. Using 2 will make all stereo non-bitstreamed audio, AC3. MP3s, too, so your music will be AC3. If you don't want that, change it to 3

af=lavcac3enc=yes:384:3

Edited by Doofus, 29 November 2018 - 11:21 PM.


#46 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11341 posts
  • Local time: 02:01 PM

Posted 29 November 2018 - 11:23 PM

If you want all AAC be AC3 and everything else unchanged, then you'll need an auto-profile. Which I can help you with, if you want that.



#47 jmccl069 OFFLINE  

jmccl069

    Member

  • Members
  • 29 posts
  • Local time: 09:01 PM

Posted 30 November 2018 - 01:18 AM

If you want all AAC be AC3 and everything else unchanged, then you'll need an auto-profile. Which I can help you with, if you want that.


That’s exactly what I’m after!!! Your assistance would be very much appreciated...

Thanks

#48 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11341 posts
  • Local time: 02:01 PM

Posted 30 November 2018 - 01:21 AM

That’s exactly what I’m after!!! Your assistance would be very much appreciated...

Thanks

 

OK. gimme a minute. I'll have to collate some stuff. Did you already make an mpv.conf?



#49 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11341 posts
  • Local time: 02:01 PM

Posted 30 November 2018 - 01:39 AM

  1. In the folder where you made the mpv.conf, make a folder called scripts
  2. Copy the auto-profiles.lua to the scripts folder (delete the .txt)
  3. Copy this profile to your mpv.conf, make it the last entry at the bottom
[AAC to AC3]
profile-desc=cond:p["audio-codec"]==aac
af=lavcac3enc=yes:384:2

Take it for a spin!

Attached Files


  • jmccl069 likes this

#50 jmccl069 OFFLINE  

jmccl069

    Member

  • Members
  • 29 posts
  • Local time: 09:01 PM

Posted 30 November 2018 - 02:34 AM

 

  1. In the folder where you made the mpv.conf, make a folder called scripts
  2. Copy the auto-profiles.lua to the scripts folder (delete the .txt)
  3. Copy this profile to your mpv.conf, make it the last entry at the bottom
[AAC to AC3]
profile-desc=cond:p["audio-codec"]==aac
af=lavcac3enc=yes:384:2

Take it for a spin!

 

 

Thanks so much...

 

I'm not home at the moment but I will give it a go and let you know...

 

Very much appreciated...



#51 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11341 posts
  • Local time: 02:01 PM

Posted 30 November 2018 - 07:29 PM

One thing to keep in mind is that mpv will natively decode AAC to PCM. But of course if you're using stereo AAC then all you'll have is stereo, not surround sound. I actually use this for my music videos. I much prefer it to stereo. Feels like I'm sitting right in front of the singer, with the band spread out, as it would be if they were actually in front of you.

#52 blumamba OFFLINE  

blumamba

    Advanced Member

  • Members
  • 135 posts
  • Local time: 04:01 PM

Posted 05 December 2018 - 08:51 PM

For Giggles, check to verify that the pc is set to 2.0.  If it is not, it will not bitstream correctly.  Remove any codec packs and install and configure Shark007 codec packs to win10.

 

http://shark007.net/advanced.html

 

I have a win10 htpc running shark and emby theater and have no issue with any passthrough using hdmi to my denon h6300x.  Just make sure you configure correctly to your needs or desires and you should be good to go unless by some stretch of the imagination that you flubbed the encode?



#53 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11341 posts
  • Local time: 02:01 PM

Posted 05 December 2018 - 09:26 PM

For Giggles, check to verify that the pc is set to 2.0.  If it is not, it will not bitstream correctly.  Remove any codec packs and install and configure Shark007 codec packs to win10.

 

http://shark007.net/advanced.html

 

I have a win10 htpc running shark and emby theater and have no issue with any passthrough using hdmi to my denon h6300x.  Just make sure you configure correctly to your needs or desires and you should be good to go unless by some stretch of the imagination that you flubbed the encode?

 

Codec packs are redundant. Theater uses mpv, which is built on ffmpeg, not directshow. Bitstreaming isn't compliant to windows audio settings. That only applies when being software decoded. Not all receivers can bitstream AAC, but most can decode it. So if your receiver can't, then mpv or the receiver will just decode it to raw audio (PCM). But if you have 2 channel AAC that you want to play as surround, the audio needs to be transcoded. Which is what I provided, above. 



#54 blumamba OFFLINE  

blumamba

    Advanced Member

  • Members
  • 135 posts
  • Local time: 04:01 PM

Posted 06 December 2018 - 04:43 PM

I dont always use emby, so codec packs are needed.  I was unaware theater had it all built in.  Then as you stated it is one of the two things, the receiver or mpv.



#55 jmccl069 OFFLINE  

jmccl069

    Member

  • Members
  • 29 posts
  • Local time: 09:01 PM

Posted 14 December 2018 - 05:24 AM

  • In the folder where you made the mpv.conf, make a folder called scripts
  • Copy the auto-profiles.lua to the scripts folder (delete the .txt)
  • Copy this profile to your mpv.conf, make it the last entry at the bottom
[AAC to AC3]
profile-desc=cond:p["audio-codec"]==aac
af=lavcac3enc=yes:384:2
Take it for a spin!

Working 100%!!! Thanks so much for your help... exactly what I was after... AAC is now converted on the fly to AC3 and everything plays in surround sound that should...

Edited by jmccl069, 14 December 2018 - 05:27 AM.

  • Doofus likes this

#56 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11341 posts
  • Local time: 02:01 PM

Posted 14 December 2018 - 04:43 PM

For anyone else wanting to use this profile. Be aware that if you have music videos with AAC audio, it will affect those, too. Every AAC audio will be affected.

#57 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11341 posts
  • Local time: 02:01 PM

Posted 05 February 2019 - 11:22 PM

A little amendment for this. I just discovered that profile will enable AC3 encoding for ANY non-bitstreamed audio, not just aac. I have found a better profile. This will be codec specific. Try this @jmccl069

[AAC to AC3]
profile-desc=cond:p["audio-codec-name"]=="aac"
af=lavcac3enc=yes:384:2

  • jmccl069 likes this

#58 jmccl069 OFFLINE  

jmccl069

    Member

  • Members
  • 29 posts
  • Local time: 09:01 PM

Posted 05 February 2019 - 11:46 PM

 

 

Thanks... I'll give it a go...


Edited by jmccl069, 06 February 2019 - 12:00 AM.


#59 jmccl069 OFFLINE  

jmccl069

    Member

  • Members
  • 29 posts
  • Local time: 09:01 PM

Posted 05 February 2019 - 11:58 PM   Best Answer

 

  1. In the folder where you made the mpv.conf, make a folder called scripts
  2. Copy the auto-profiles.lua to the scripts folder (delete the .txt)
  3. Copy this profile to your mpv.conf, make it the last entry at the bottom
[AAC to AC3]
profile-desc=cond:p["audio-codec"]==aac
af=lavcac3enc=yes:384:2

Take it for a spin!

 

 

 

 

A little amendment for this. I just discovered that profile will enable AC3 encoding for ANY non-bitstreamed audio, not just aac. I have found a better profile. This will be codec specific. Try this @jmccl069

[AAC to AC3]
profile-desc=cond:p["audio-codec-name"]=="aac"
af=lavcac3enc=yes:384:2

 

Just tried this...

 

Works a treat!!!

 

Thanks again @Doofus


  • Doofus likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users