Jump to content

Emby Server Not Recognizing Subtitle 'Forced' Flag


Wilky13
 Share

Recommended Posts

I noticed Emby Server is not recognizing the 'Forced' flag for internal subtitles in a MP4 container.

 

Here is an example, you can see from Subler that Track 5 is subtitles and they are checked as 'Forced'.

 

5b9f1ad491d68_subler.jpg

 

However in Emby Server it is showing the subtitles as "No" for Forced.

 

5b9f1b2739575_embyserver.jpg

Link to comment
Share on other sites

Well that's what ffprobe is telling us. Does the mp4 container even support those flags? You may want to just extract them into an external subtitle.

Link to comment
Share on other sites

Well that's what ffprobe is telling us. Does the mp4 container even support those flags? You may want to just extract them into an external subtitle.

I assumed MP4 container supported forced subs flag, it seems to support the default audio flag.

 

I had been using external subs with the ‘eng.forced.srt’ file name. But it seemed to be hit and miss between players (AppleTV, Roku, ET, EmbyWMC, etc.). I’d thought making them internal would be more universal.

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

External subtitles is the most universal and recommended approach.I am not sure the mp4 container supports what you were trying to do.

Link to comment
Share on other sites

External subtitles is the most universal and recommended approach.I am not sure the mp4 container supports what you were trying to do.

@@Luke I'll add external subs with the "eng.forced.srt" suffix. Do you think having internal and external subs will conflict? Should I delete the internal ones?

 

 

Sent from my iPad using Tapatalk

Edited by Wilky13
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...