Jump to content


Photo

3.0.2 - no playback


Best Answer serpi , 25 August 2018 - 04:30 PM

And how are you configuring the settings in Theater?

 

I tried different settings for hardware acceleration, with and without OpenGL High Quality Mode, most settings are auto, display rate changing is out.

Also, both PCs have different settings.

 

External player works, if I enable one.

 

But now, I found the setting, that makes the problem:

If I set the 3D conversion mode to something else then auto, then it doesn't work.

 

I had it to set to mono on my HTPC and arcc on my PC.

 

This seems to be a result, that the video-stereo-mode parameter isn't supported anymore, there was already another thread of me about this.

Setting 3D conversion in MPV is now more complicated, as you also have to tell it, what is the source format.

 

@Luke

How about pushing out a new ET version which removes the 3D conversion mode setting and doesn't send this parameter anymore, until you found a way, to implement it in the new way?

 

Ciao, Alfred

Go to the full post


  • Please log in to reply
85 replies to this topic

#21 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 11371 posts
  • Local time: 02:55 AM

Posted 25 August 2018 - 04:09 PM

And how are you configuring the settings in Theater?



#22 serpi OFFLINE  

serpi

    Advanced Member

  • Members
  • 206 posts
  • Local time: 10:55 AM

Posted 25 August 2018 - 04:30 PM   Best Answer

And how are you configuring the settings in Theater?

 

I tried different settings for hardware acceleration, with and without OpenGL High Quality Mode, most settings are auto, display rate changing is out.

Also, both PCs have different settings.

 

External player works, if I enable one.

 

But now, I found the setting, that makes the problem:

If I set the 3D conversion mode to something else then auto, then it doesn't work.

 

I had it to set to mono on my HTPC and arcc on my PC.

 

This seems to be a result, that the video-stereo-mode parameter isn't supported anymore, there was already another thread of me about this.

Setting 3D conversion in MPV is now more complicated, as you also have to tell it, what is the source format.

 

@Luke

How about pushing out a new ET version which removes the 3D conversion mode setting and doesn't send this parameter anymore, until you found a way, to implement it in the new way?

 

Ciao, Alfred



#23 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 11371 posts
  • Local time: 02:55 AM

Posted 25 August 2018 - 04:38 PM

arcc is in the settings. Just use that, and don't put it in your mpv.conf

 

5b81be47bbd27_Snapshot_33.jpg



#24 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 11371 posts
  • Local time: 02:55 AM

Posted 25 August 2018 - 04:47 PM

Cancel that. They've removed it. They depreciated it a long time ago. I missed that they removed it in this build

 

https://mpv.srsfckn....ges/2018-07-22/

 

5b81c0421a9fc_Snapshot_34.jpg


Edited by Doofus, 25 August 2018 - 04:47 PM.


#25 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 11371 posts
  • Local time: 02:55 AM

Posted 25 August 2018 - 04:50 PM

You can probably still use it with the lavfi wrapper, if you really need it.



#26 serpi OFFLINE  

serpi

    Advanced Member

  • Members
  • 206 posts
  • Local time: 10:55 AM

Posted 25 August 2018 - 04:51 PM

arcc is in the settings. Just use that, and don't put it in your mpv.conf

 

5b81be47bbd27_Snapshot_33.jpg

 

I know, this is, why it is commented out in the settings file.

It's still there from a time, it wasn't available in the ET gui, just as a reminder, what's my preferred mode ;-)

 

You can try it yourself, set the mode to something else than auto and you should be unable to play anything (even 2D videos) in 3.0.2.

 

On the other hand, enabling the option in the mpv.conf file and setting the mode ET to auto still works (video plays), it simply does no 3D conversion anymore.

 

Ciao, Alfred



#27 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 11371 posts
  • Local time: 02:55 AM

Posted 25 August 2018 - 04:55 PM

Read above.



#28 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 11371 posts
  • Local time: 02:55 AM

Posted 25 August 2018 - 04:56 PM

@Luke you need to remove it from the UI.



#29 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 129329 posts
  • Local time: 05:55 AM

Posted 25 August 2018 - 04:57 PM

Remove or update? does mpv not support it anymore?



#30 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 11371 posts
  • Local time: 02:55 AM

Posted 25 August 2018 - 04:59 PM

Remove or update? does mpv not support it anymore?

 

It's been removed. It's probably still usable with the lavfi wrapper, but I can't test that. You can try

vf=lavfi=


#31 serpi OFFLINE  

serpi

    Advanced Member

  • Members
  • 206 posts
  • Local time: 10:55 AM

Posted 25 August 2018 - 05:03 PM

You can probably still use it with the lavfi wrapper, if you really need it.

 

Yes, you can (and I would like to), but there you have to tell source format and destination format.

 

I don't know any way to make this (automatically) work without help from the devs.

 

If I set one mode in the global mpv.conf, this would be used for all videos, even non 3D or 3D with different source format.

 

I don't know, if this is possible, but if I could create a mpv.conf inside the video folder and this was used, I would have the same output format for all players. And how should this work with more than one video in a folder?

 

It's a shame, the option isn't supported anymore, as mpv still recognizes the correct mode, for example like this on an HSBS file:

[   0.113][v][mkv] |   + StereoMode: sbs2l

So what is needed, was to have a setting in ET for the output format (as it has now) but then use the video filter parameter on 3D movies and somehow determinate the source format, either from the video file itself or the 3D format tag in emby.

Of course, having an auto input format in mpv would be much better...

 

Ciao, Alfred



#32 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 11371 posts
  • Local time: 02:55 AM

Posted 25 August 2018 - 05:07 PM

it should work fine if you try

vf=lavfi=video-stereo-mode=arcc

I don't have any 3D stuff to test with

 

Unless it's completely removed!


Edited by Doofus, 25 August 2018 - 05:09 PM.


#33 serpi OFFLINE  

serpi

    Advanced Member

  • Members
  • 206 posts
  • Local time: 10:55 AM

Posted 25 August 2018 - 05:11 PM

BTW: Here's the thread about the 3D conversion not working anymore in ET from march.

There was the option already removed in mpv.

 

You now have to use the --vf=stereo3d=input:output to convert the mode, where you have to know the sorce format (e.g. sbs2l for HSBS).

 

Ciao, Alfred



#34 serpi OFFLINE  

serpi

    Advanced Member

  • Members
  • 206 posts
  • Local time: 10:55 AM

Posted 25 August 2018 - 05:15 PM

it should work fine if you try

vf=lavfi=video-stereo-mode=arcc

I don't have any 3D stuff to test with

 

Unless it's completely removed!

 

I've put this into the mpv.conf and it doesn't work.

 

Ciao, Alfred



#35 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 11371 posts
  • Local time: 02:55 AM

Posted 25 August 2018 - 05:15 PM

BTW: Here's the thread about the 3D conversion not working anymore in ET from march.

There was the option already removed in mpv.

 

You now have to use the --vf=stereo3d=input:output to convert the mode, where you have to know the sorce format (e.g. sbs2l for HSBS).

 

Ciao, Alfred

 

That was when it was deprecated, but not removed

 

https://mpv.srsfckn....ges/2017-04-23/

 

This last build, is when it has actually been removed

 

https://mpv.srsfckn....ges/2018-07-22/



#36 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 11371 posts
  • Local time: 02:55 AM

Posted 25 August 2018 - 05:17 PM

I've put this into the mpv.conf and it doesn't work.

 

Ciao, Alfred

 

Then it may have been completely removed. 



#37 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 11371 posts
  • Local time: 02:55 AM

Posted 25 August 2018 - 05:20 PM

Has shinchiro removed it, too? It's gone from lachs0r's.



#38 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 11371 posts
  • Local time: 02:55 AM

Posted 25 August 2018 - 05:29 PM

This is what I see in shinchiro's latest doc

--video-stereo-mode=<no|mode>
Set the stereo 3D output mode (default: mono). This is mostly broken and thus deprecated.
The pseudo-mode no disables automatic conversion completely.
The mode mono is an alias to ml, which refers to the left frame in 2D. This is the default, which means
mpv will try to show 3D movies in 2D, instead of the mangled 3D image not intended for consumption
(such as showing the left and right frame side by side, etc.).
Use --video-stereo-mode=help to list all available modes. Check with the stereo3d filter
documentation to see what the names mean. Note that some names refer to modes not supported by
stereo3d - these modes can appear in files, but can't be handled properly by mpv.


#39 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 11371 posts
  • Local time: 02:55 AM

Posted 25 August 2018 - 05:42 PM

stereo3d isn't in any of the docs, so that maybe gone, too.

 

Yup! It is, but apparently that can be used with lavfi

 

https://mpv.srsfckn....ges/2017-12-25/

 

5b81cd2b7cc3a_Snapshot_35.jpg

 

But I would speculate that it too, will eventually be gone.


Edited by Doofus, 25 August 2018 - 05:45 PM.


#40 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 11371 posts
  • Local time: 02:55 AM

Posted 25 August 2018 - 05:57 PM

Luke, if you want to use the stereo3d option via lavfi, here is the doc that provides the configs






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users