Jump to content


Photo

Roku Selecting Audio and Subtitle Tracks


  • Please log in to reply
111 replies to this topic

#41 leebo OFFLINE  

leebo

    Advanced Member

  • Members
  • 256 posts
  • Local time: 08:00 AM

Posted 27 December 2013 - 09:11 PM

I am just getting data so I can try to find out why the subs are not rendering (i need to be able to repo it to have a chance at fixing it) the pgs subs filter is common to the dash and roku.


I see. This is interesting.

Sent from my Nexus 7

#42 leebo OFFLINE  

leebo

    Advanced Member

  • Members
  • 256 posts
  • Local time: 08:00 AM

Posted 05 January 2014 - 07:20 PM

Hey Tikuf, I have temporarily put a hold on converting anymore Blurays while I wait for more info from you. The reason is because I do not want to have to re-convert all my videos. Do you have any sense whether I will have to make some kind of change in Handbrake (if it's even possible), or whether you think it will be something fixable on your end? Sent from my Nexus 7

#43 Tikuf OFFLINE  

Tikuf

    Obsolete User

  • Members
  • 3656 posts
  • Local time: 02:00 AM

Posted 05 January 2014 - 07:52 PM

There is a fix coming for subs canvas resizing (next server build) we just need to do some testing. I am not sure if it will fix your issue or not. If you can hang tight for the fix and see. 



#44 leebo OFFLINE  

leebo

    Advanced Member

  • Members
  • 256 posts
  • Local time: 08:00 AM

Posted 06 January 2014 - 03:28 AM

Of course. It's not an emergency. I just thought if you knew it was for sure on your end I could get back to it. In fact, I just did a clean re-install of Win 7 I had been putting off for months, so I have plenty to keep me busy. I probably won't re-install MB until I hear about a new release. Probably. Maybe.:) Sent from my Nexus 7

#45 leebo OFFLINE  

leebo

    Advanced Member

  • Members
  • 256 posts
  • Local time: 08:00 AM

Posted 14 January 2014 - 10:16 PM

The networking in my motherboard died (all networking, not just he onboard NIC), so I now have a MB replacement to keep me busy! Sent from my Nexus 7

#46 FrostByte OFFLINE  

FrostByte

    Advanced Member

  • ForumMod
  • 3913 posts
  • Local time: 11:00 AM
  • LocationThe UP

Posted 15 January 2014 - 12:44 AM

Having a similar issue here though I use Dvdfab to convert my BDs to mkv and figure it's because Dvdfab also is cropping.  Crouching Tiger Hidden Dragon and others all have embedded srt, English, forced but the Roku will not display subtitles even though I can select the English subtitle the movie will just load and not display.  Hope your next server update fixes.  Thanks



#47 leebo OFFLINE  

leebo

    Advanced Member

  • Members
  • 256 posts
  • Local time: 08:00 AM

Posted 14 February 2014 - 08:12 PM

Any update on this? Estimated timeframe? I'm simply not using MB3 while I wait for this fix, as I don't want to convert my discs twice (assuming I will have to make some kind of change in my re-encoding process).

Sent from my generic not my computer device.

#48 gcw07 OFFLINE  

gcw07

    Roku Master

  • Members
  • 2505 posts
  • Local time: 10:00 AM
  • LocationOklahoma

Posted 14 February 2014 - 08:39 PM

I believe the subs changes are coming in the next server release. Still no date for that, but I'd guess soon. Whether that fixes your problem or not we will have to see.



#49 leebo OFFLINE  

leebo

    Advanced Member

  • Members
  • 256 posts
  • Local time: 08:00 AM

Posted 24 February 2014 - 08:51 PM

Does the new beta announced today include the subs changes? Is it recommended to keep waiting for the official release?



#50 Tikuf OFFLINE  

Tikuf

    Obsolete User

  • Members
  • 3656 posts
  • Local time: 02:00 AM

Posted 24 February 2014 - 08:54 PM

Please test with the new version and let me know how it goes for you


Edited by Tikuf, 24 February 2014 - 08:54 PM.


#51 leebo OFFLINE  

leebo

    Advanced Member

  • Members
  • 256 posts
  • Local time: 08:00 AM

Posted 25 February 2014 - 08:02 PM

Please test with the new version and let me know how it goes for you

I updated to the latest beta (it shows Version 3.0.5168.16132). Played a few of my BR/Handbrake conversions to mkv. Still no subtitle displaying.

I played from the web client (right click the system trey icon, select browse library). I assume if they don't display from there, there is no point to check on my Roku?



#52 Tikuf OFFLINE  

Tikuf

    Obsolete User

  • Members
  • 3656 posts
  • Local time: 02:00 AM

Posted 25 February 2014 - 09:16 PM

Can I please see an ffmpeg log thanks



#53 leebo OFFLINE  

leebo

    Advanced Member

  • Members
  • 256 posts
  • Local time: 08:00 AM

Posted 25 February 2014 - 09:51 PM

Let me know if this is good enough, or if you need me to do the clean log thing.

 

https://dl.dropboxus...65f2e28a847.txt



#54 Tikuf OFFLINE  

Tikuf

    Obsolete User

  • Members
  • 3656 posts
  • Local time: 02:00 AM

Posted 25 February 2014 - 09:40 PM

Ok for some reason the subs canvas isn't resizing. I know we fixed this. Can you link me to a clean debug server log of that same item.

Thanks



#55 leebo OFFLINE  

leebo

    Advanced Member

  • Members
  • 256 posts
  • Local time: 08:00 AM

Posted 26 February 2014 - 03:50 AM

https://dl.dropboxus...63528968399.log

 

https://dl.dropboxus...63528968473.log

 

https://dl.dropboxus...63528968477.log



#56 Tikuf OFFLINE  

Tikuf

    Obsolete User

  • Members
  • 3656 posts
  • Local time: 02:00 AM

Posted 26 February 2014 - 04:29 AM

Well that isn't from roku but I assume the result is the same on roku (ie you don't see the subs)

 

 

Lee can you make a new folder somewhere on your system and open a cmd prompt in it and run the following c/l

C:\Users\Lee\AppData\Roaming\MediaBrowser-Server\ffmpeg\20140105\ffmpeg.exe -ss 599 -fflags genpts -i file:"O:\Handbrake Conversions\Jack Reacher\Jack Reacher.mkv" -ss 1 -map 0:0 -map 0:1 -vcodec libvpx -force_key_frames expr:if(isnan(prev_forced_t),gte(t,.1),gte(t,prev_forced_t+5)) -speed 16 -quality good -profile:v 0 -slices 8 -crf 10 -b:v 1372000 -r 23.976 -vsync vfr -filter_complex "[0:4]format=yuva444p,scale=1920:816,lut=u=128:v=128:y=gammaval(.3)[sub] ; [0:0] [sub] overlay,scale=min(iw\,1280):-1" -map_metadata -1 -threads 2 -acodec libvorbis -ac 2 -ab 128000 -af "adelay=1,aresample=async=1" -t 300 "test.webm"

watch the file in vlc or something similar.

 

If you don't see subs in the file. (hopefully the section I randomly chose has some talking in it and therefore subs if not adjust the 599 value at the start of the c/l).

 

Please run.

ffmpeg.exe -ss 600 -fflags genpts -i file:"O:\Handbrake Conversions\Jack Reacher\Jack Reacher.mkv" -codec copy -t 300 "test4tikuf.mkv"

And upload the file > test4tikuf.mkv to your dropbox and pm me the link thanks.



#57 Tikuf OFFLINE  

Tikuf

    Obsolete User

  • Members
  • 3656 posts
  • Local time: 02:00 AM

Posted 26 February 2014 - 05:50 AM

Ok I am not sure what is happening with your setup but ..

 

 

530db87c1e02f_subs.jpg

 

 

All i can suggest is perhaps handbrake is doing something ffmpeg doesn't like.

 

Try running it through ffmpeg and testing the full movie.

ffmpeg.exe  -fflags genpts -i file:"O:\Handbrake Conversions\Jack Reacher\Jack Reacher.mkv" -codec copy  "O:\Handbrake Conversions\Jack Reacher\Jack Reacher-new.mkv"


#58 DigitalFool OFFLINE  

DigitalFool

    Advanced Member

  • Members
  • 41 posts
  • Local time: 04:00 PM

Posted 26 February 2014 - 06:51 PM

Since there is a thread on Roku subtitles...

 

I actually just got a Roku 3 and have been playing around with it - in my MB configuration on my HTPC I have a separate .SRT sub file. That works fine on my HTPC, however the Roku doesn't see it. Do I have to remux that sub in?



#59 leebo OFFLINE  

leebo

    Advanced Member

  • Members
  • 256 posts
  • Local time: 08:00 AM

Posted 26 February 2014 - 08:30 PM

 

Ok I am not sure what is happening with your setup but ..

 

 

530db87c1e02f_subs.jpg

 

 

All i can suggest is perhaps handbrake is doing something ffmpeg doesn't like.

 

Try running it through ffmpeg and testing the full movie.

ffmpeg.exe  -fflags genpts -i file:"O:\Handbrake Conversions\Jack Reacher\Jack Reacher.mkv" -codec copy  "O:\Handbrake Conversions\Jack Reacher\Jack Reacher-new.mkv"

OK, I'm a bit confused.

 

The frame grab suggests that the subs from the file I linked do show up when you play it? Did you use the web client?

If so, isn't your system using ffmpeg too? Why then would the subs show up on yours?

 

Also, it seems unlikely that I am the only person using Handbrake to make MKV's from Blurays, and using MB3 and a Roku. Yet I haven't seen anyone else mention this issue.

 

In any case, I'll try making a copy with your CL and playing it on my Roku later today.



#60 Tikuf OFFLINE  

Tikuf

    Obsolete User

  • Members
  • 3656 posts
  • Local time: 02:00 AM

Posted 26 February 2014 - 08:34 PM

Yes it is the web client. Yes my system is using ffmpeg. The only reason I can think of is that the copy copy c/l changed something in the file that handbrake has written.

 

Let me know how you go.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users