Jump to content


Photo

ScheduleDirect for LiveTV error looking for file /dashboard-ui/components/tvproviders/.template.html

livetv emby 3.5.2 freebsd

  • Please log in to reply
12 replies to this topic

#1 embytal OFFLINE  

embytal

    Member

  • Members
  • 29 posts
  • Local time: 07:28 PM

Posted 19 August 2018 - 10:37 PM

Hi all,

 

I have emby-server 3.5.2 running in a jail and it is working fine.

I added my HDHomerun under LiveTV but I am stuck on the following error message while trying to add the SchedulesDirect under LiveTV.

 

I get the error message: Could not find file "/dashboard-ui/components/tvproviders/.template.html"

 

Unfortunately, I am not familiar enough with the directory structure of emby and could not locate any of the folders: dashboard-ui, components or tvproviders.

 

Let me know if there is anything I should do to get this working as I could not find anything on github.



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 121604 posts
  • Local time: 07:28 PM

Posted 19 August 2018 - 10:52 PM

Hi, that's strange because we resolved this in 3.5.2. Did you install using the instructions on our website?



#3 embytal OFFLINE  

embytal

    Member

  • Members
  • 29 posts
  • Local time: 07:28 PM

Posted 19 August 2018 - 11:10 PM

Hi, that's strange because we resolved this in 3.5.2. Did you install using the instructions on our website?

 

Ok I tried with the version 3.5.2 from github and the page loads and lets me put my credentials.

So there is a difference between the version 3.5.2 from the FreeBSD package site and the 3.5.2 Emby github.

 

Side note, I can connect to ScheduleDirect with my credential through Emby but it does not list the lineup I created under ScheduleDirect. I can see the other line up entries from the postcode I submit through Emby.

 

Is there anything I missed?



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 121604 posts
  • Local time: 07:28 PM

Posted 19 August 2018 - 11:45 PM

the freebsd version must not have that hotfix. 

 

what do you mean by created a lineup? you're saying you created a custom lineup on the schedules direct website?



#5 embytal OFFLINE  

embytal

    Member

  • Members
  • 29 posts
  • Local time: 07:28 PM

Posted 20 August 2018 - 12:05 AM

the freebsd version must not have that hotfix. 

 

what do you mean by created a lineup? you're saying you created a custom lineup on the schedules direct website?

 

I did create a line up as SD-DD since this is the only option I could find.

 

The problem is that I have multiple lineups proposed in the list but they are all Satellite or Cable and not Antenna like what I need.

I reproduced the listing issue with EPG123.

I have very little experience with Schedules Direct so I also contacted them to understand how I could get an SD-JSON for Antenna or how to use the SD-DD lineup I created.

 

Unless I missed something obvious, I consider the primary issue of this thread as fixed and would like to thank you for your help.


Edited by embytal, 20 August 2018 - 12:06 AM.


#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 121604 posts
  • Local time: 07:28 PM

Posted 20 August 2018 - 12:57 AM

Thanks for the feedback.



#7 embytal OFFLINE  

embytal

    Member

  • Members
  • 29 posts
  • Local time: 07:28 PM

Posted 20 August 2018 - 09:11 PM

Ok so Schedule Direct support came back and told me they could see my line up. Strangely enough on the first query I saw the lineup listed. Not entirely sure what they did but it was not working before.

 

On a side note, it looks like 3.6.0.2 has the same issue as the FreeBSD package version as I get the following error message while trying to add SchedulesDirect: "Could not find file "/dashboard-ui/components/tvproviders/.template.html""

Any chance to have a reference to the fix that went into the the github version of 3.5.2?

 

Thanks.



#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 121604 posts
  • Local time: 07:28 PM

Posted 21 August 2018 - 11:32 PM

That fix is just not in the beta yet. I'm hoping to have a new beta up in the next few days. Thanks.



#9 embytal OFFLINE  

embytal

    Member

  • Members
  • 29 posts
  • Local time: 07:28 PM

Posted 22 August 2018 - 08:12 AM

Got it thanks.  I will keep an eye on the new beta, test and report. Thanks !



#10 gameroomsolutions OFFLINE  

gameroomsolutions

    Newbie

  • Members
  • 4 posts
  • Local time: 12:28 AM

Posted 29 September 2018 - 10:38 PM

Any update on the FreeBSD?  I just updated to 3.5.2.0 on freenas and have this issue.  Wife is going to kill me.



#11 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 121604 posts
  • Local time: 07:28 PM

Posted 29 September 2018 - 10:43 PM

If you use our official freebsd instructions it has the fix:

https://emby.media/freebsd-server.html

 

It is not in freebsd ports yet. Hopefully soon. Thanks.



#12 gameroomsolutions OFFLINE  

gameroomsolutions

    Newbie

  • Members
  • 4 posts
  • Local time: 12:28 AM

Posted 29 September 2018 - 10:56 PM

Got it by getting update from emby github and not freebsd as it is fixed there

 

1: putty(or similar) into your freenas server
2: iocage console emby
3: service emby-server stop
4: cd /tmp
5: fetch https://github.com/M...ive/3.5.2.0.zip (swap with address of latest file found here: https://github.com/M.../Emby/releases)
6: unzip -d /tmp/emby 3.5.2.0.zip
7: cp -Rfp /tmp/emby/ /usr/local/lib/emby-server
8: rm -r /tmp/emby
9: rm /tmp/3.5.2.0.zip
10: service emby-server start


Edited by gameroomsolutions, 29 September 2018 - 10:56 PM.


#13 ctmjr OFFLINE  

ctmjr

    Newbie

  • Members
  • 1 posts
  • Local time: 07:28 PM

Posted 31 October 2018 - 09:26 PM

Thank you, worked great.







Also tagged with one or more of these keywords: livetv, emby 3.5.2, freebsd

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users