Jump to content


Photo

Emby Server Connection and Restart Failure After Media Library Browsing

Connection Failure Cant Restart Server Windows Server 2016 Emby Theater Windows 7 Android app

  • Please log in to reply
43 replies to this topic

#21 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134330 posts
  • Local time: 01:20 AM

Posted 20 September 2018 - 03:57 PM

Ok thanks, it seems to be image processing related. When I said next release I really meant next major release, meaning 3.6.

 

3.5.3 is just a small patch release to address a couple things. We have updated our image processing library in 3.6. I was not comfortable throwing that into the 3.5 branch so that's why you might have to wait a bit longer. Thanks.



#22 rahul65 OFFLINE  

rahul65

    Member

  • Members
  • 12 posts
  • Local time: 10:50 AM

Posted 12 October 2018 - 12:22 AM

Hi, I am facing same problem I am on 3.5.Server and sometime even opening a item from library crashes the server and sometime it crashes during playback. Below is what i get in raspbian

 

pi@raspberrypi:~ $ systemctl status emby-server
● emby-server.service - Emby Server is a personal media server with apps on just
   Loaded: loaded (/usr/lib/systemd/system/emby-server.service; enabled; vendor
   Active: failed (Result: signal) since Fri 2018-10-12 09:09:30 IST; 1min 45s a
  Process: 642 ExecStart=/opt/emby-server/bin/emby-server (code=killed, signal=A
 Main PID: 642 (code=killed, signal=ABRT)
 
Oct 12 08:27:01 raspberrypi emby-server[642]:       _STATISTICS_TAGS: BPS DURATI
Oct 12 08:27:01 raspberrypi emby-server[642]:       _STATISTICS_TAGS-eng: BPS DU
Oct 12 08:27:01 raspberrypi emby-server[642]: Stream mapping:
Oct 12 08:27:01 raspberrypi emby-server[642]:   Stream #0:2 -> #0:0 (copy)
Oct 12 08:27:01 raspberrypi emby-server[642]: Press [q] to stop, [?] for help
Oct 12 08:27:11 raspberrypi emby-server[642]: [1.3K blob data]
Oct 12 08:27:13 raspberrypi emby-server[642]: video:0kB audio:0kB subtitle:16kB
Oct 12 09:09:30 raspberrypi systemd[1]: emby-server.service: Main process exited
Oct 12 09:09:30 raspberrypi systemd[1]: emby-server.service: Unit entered failed
Oct 12 09:09:30 raspberrypi systemd[1]: emby-server.service: Failed with result


#23 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134330 posts
  • Local time: 01:20 AM

Posted 12 October 2018 - 12:48 AM

Hi there, please attach the emby server log, thanks.



#24 larsonDigital OFFLINE  

larsonDigital

    Advanced Member

  • Members
  • 74 posts
  • Local time: 10:20 PM

Posted 22 October 2018 - 03:04 PM

Hey Luke, is there any way to flag you on another topic?  I was hoping you could take a look at this: https://emby.media/c...00/#entry638999.

 

Thanks,

James



#25 larsonDigital OFFLINE  

larsonDigital

    Advanced Member

  • Members
  • 74 posts
  • Local time: 10:20 PM

Posted 08 November 2018 - 03:17 PM

Hey Luke,

 

It seems the Emby Media Server is causing other issues in Windows Server 2016 Standard, probably when it crashes and has to restart, but I'm not positive.  What I do know is that if I DO NOT use Emby apps (Windows, Android, Samsung Blu-ray Player, PS3) to access my music on the server, Windows Server 2016 Standard runs fine.  If I do access my music, Windows has issues, like it can't complete Windows Backup.  It seems to have even caused a problem with Updates.  So I've had stop using it for now, and am looking forward to release 3.6 to hopefully resolve these issues.  Will Premiere supporters get an email or anything when this is available?

 

Thanks,

James



#26 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134330 posts
  • Local time: 01:20 AM

Posted 08 November 2018 - 03:23 PM

Hi, please stay tuned to our blog for release announcements:

https://emby.media/c...og/1-emby-blog/

 

Thanks.



#27 Crestj OFFLINE  

Crestj

    Advanced Member

  • Members
  • 589 posts
  • Local time: 06:20 AM
  • LocationColchester, England

Posted 05 January 2019 - 05:49 AM

Quick update, since uninstalling the CoverArt plugin I've had no crashes at all.

3 weeks so far.

Shame because I liked the CoverArt styling.

Edited by Crestj, 05 January 2019 - 05:50 AM.


#28 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134330 posts
  • Local time: 01:20 AM

Posted 05 January 2019 - 02:23 PM

Thanks for the info. The new release of the server will be available soon.



#29 larsonDigital OFFLINE  

larsonDigital

    Advanced Member

  • Members
  • 74 posts
  • Local time: 10:20 PM

Posted 07 January 2019 - 06:10 PM

Thanks for the update!  I may have to try that while we're waiting for the next release.   :)



#30 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134330 posts
  • Local time: 01:20 AM

Posted 07 January 2019 - 06:13 PM

It will be any day now, sorry, broken record I know :)



#31 larsonDigital OFFLINE  

larsonDigital

    Advanced Member

  • Members
  • 74 posts
  • Local time: 10:20 PM

Posted 07 January 2019 - 06:17 PM

:lol: Thanks for all you do Luke!



#32 JoeWar OFFLINE  

JoeWar

    Member

  • Members
  • 14 posts
  • Local time: 07:20 AM

Posted 19 January 2019 - 02:12 PM

Hi Luke,

after endless months of waiting for a major Emby Server release I installed 4.0.0.2 hoping it will fix the issue from my initial post. Unfortunately, I have to state that the most recent release didn’t help and I still face the Emby Server crash when I scroll down the homepage and hit some empty artworks. I was optimistic at the beginning as I do not experience the problem when accessing the Emby via the server itself. Nevertheless, the issue appears when I access it through the LAN. See the LOG attached.

 

Thx

Josef

Attached Files

  • Attached File  Log.txt   183.48KB   2 downloads

Edited by JoeWar, 19 January 2019 - 02:13 PM.


#33 Crestj OFFLINE  

Crestj

    Advanced Member

  • Members
  • 589 posts
  • Local time: 06:20 AM
  • LocationColchester, England

Posted 19 January 2019 - 02:25 PM

FYI
Updated to the same version after having the same issue with CoverArt.
Reinstalled CoverArt and have been accessing my library using the web site, emby theatre and the android emby app without a crash or missing art work.

Hopefully it will not appear again as it has for you.

#34 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134330 posts
  • Local time: 01:20 AM

Posted 19 January 2019 - 02:29 PM

Apologies that you're still having an issue. Can you scan your directories as well as the server metadata folder for any zero byte image files? Thanks.

#35 JoeWar OFFLINE  

JoeWar

    Member

  • Members
  • 14 posts
  • Local time: 07:20 AM

Posted 24 January 2019 - 02:21 PM

Hello, thx for the feedback. I searched the media drive for any zero byte images but didn’t find any. The weird thing is that when I access the Emby via the server, all the artworks are visible and all seems to be working normally. But it is not the case when I access it via a remote machine or TV despite the problematic artwork files are present. For now, I am considering uninstalling the Emby server; manually deleting all artwork and .nfo files; and installing/configuring the Emby server again. Is this worth to try or is there anything else I can try?

 

Thx

Josef


Edited by JoeWar, 24 January 2019 - 03:34 PM.


#36 Crestj OFFLINE  

Crestj

    Advanced Member

  • Members
  • 589 posts
  • Local time: 06:20 AM
  • LocationColchester, England

Posted 24 January 2019 - 02:22 PM

Have you tried uninstalling the CoverArt plugin?
Before the v4 update this solved all the connection and crashing issues I had.

#37 JoeWar OFFLINE  

JoeWar

    Member

  • Members
  • 14 posts
  • Local time: 07:20 AM

Posted 24 January 2019 - 02:34 PM

Actually, I checked list of my plugins right after reading your hint but didn’t see CoverArt listed. I haven’t installed any additional plugins. Should CoverArt be installed by default or was supposed to be before version 4?

 

Josef



#38 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134330 posts
  • Local time: 01:20 AM

Posted 25 January 2019 - 03:24 PM

No, CoverArt is an optional plugin you would have to install from the catalog.



#39 Masterz OFFLINE  

Masterz

    Advanced Member

  • Members
  • 38 posts
  • Local time: 08:20 AM

Posted 27 January 2019 - 02:12 PM

In the middle of playback.

Attached Files



#40 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134330 posts
  • Local time: 01:20 AM

Posted 28 January 2019 - 01:20 AM

Can you attach the emby server log as well? Thanks !







Also tagged with one or more of these keywords: Connection Failure, Cant Restart Server, Windows Server 2016, Emby Theater, Windows 7, Android app

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users