Jump to content

server is crashing in few minutes


Pafzedog
 Share

Go to solution Solved by Pafzedog,

Recommended Posts

Hello,

 

I'm runing emby server 3.5.2 on debian Jessie.

App is crashing quickly with this error message in Systemd status report : 

emby-server.service - Emby Server is a personal media server with apps on just about every device.
   Loaded: loaded (/usr/lib/systemd/system/emby-server.service; enabled)
   Active: failed (Result: exit-code) since lun. 2018-07-30 19:43:35 CEST; 16min ago
  Process: 16746 ExecStart=/opt/emby-server/bin/emby-server (code=exited, status=5)
 Main PID: 16746 (code=exited, status=5)

juil. 30 19:43:35 Fozzy emby-server[16746]: at System.IO.File.InternalReadAllLines(String path, Encoding encoding)
juil. 30 19:43:35 Fozzy emby-server[16746]: at System.IO.File.ReadAllLines(String path)
juil. 30 19:43:35 Fozzy emby-server[16746]: at System.Net.NetworkInformation.StringParsingHelpers.ParseGatewayAddressesFromRouteFile(String filePath, String interfaceName)
juil. 30 19:43:35 Fozzy emby-server[16746]: at System.Net.NetworkInformation.LinuxIPInterfaceProperties.GetGatewayAddresses()
juil. 30 19:43:35 Fozzy emby-server[16746]: at System.Net.NetworkInformation.LinuxIPInterfaceProperties..ctor(LinuxNetworkInterface lni)
juil. 30 19:43:35 Fozzy emby-server[16746]: at System.Net.NetworkInformation.LinuxNetworkInterface..ctor(String name)
juil. 30 19:43:35 Fozzy emby-server[16746]: at System.Net.NetworkInformation.LinuxNetworkInterface.GetOrCreate(Dictionary`2 interfaces, String name)
juil. 30 19:43:35 Fozzy emby-server[16746]: at System.Net.NetworkInformation.LinuxNetworkInterface.<>c__DisplayClass5_0.<GetLinuxNetworkInterfaces>b__1(String name, IpAddressInfo* ipAddr, UInt32* scopeId)
juil. 30 19:43:35 Fozzy emby-server[16746]: InnerException: System.IO.IOException
juil. 30 19:43:35 Fozzy emby-server[16746]: System.IO.IOException: Permission denied

I notice that it happen since emby 3.5.1, It seems that it did'nt happen with first release 3.5.0 .

thanks for your help.

 

complete server log is here because uploader on this forum failed for me

 

 

Link to comment
Share on other sites

This looks permission related. We're trying to query your system for information on your network interfaces and this is causing the crash.

	System.Net.NetworkInformation.NetworkInformationException (13): An error was encountered while querying information from the operating system. ---> System.AggregateException: One or more errors occurred. (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) ---> System.UnauthorizedAccessException: Access to the path '/proc/net/route' is denied. ---> System.IO.IOException: Permission denied

Unfortunately this crash appears to be happening in such a way that I don't think we can just trap it, log it, and continue.

 

Have you configured anything that might be causing this?

Link to comment
Share on other sites

This looks permission related. We're trying to query your system for information on your network interfaces and this is causing the crash.

	System.Net.NetworkInformation.NetworkInformationException (13): An error was encountered while querying information from the operating system. ---> System.AggregateException: One or more errors occurred. (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) (Access to the path '/proc/net/route' is denied.) ---> System.UnauthorizedAccessException: Access to the path '/proc/net/route' is denied. ---> System.IO.IOException: Permission denied

Unfortunately this crash appears to be happening in such a way that I don't think we can just trap it, log it, and continue.

 

Have you configured anything that might be causing this?

 

In fact I was wrong, it happens since 3.5.0, I just checked my command history on my server and I installed new version 3.4.x and I had to reconfigure everything but it worked.

Since I upgraded to 3.5.0 , this crash happens.

Edited by Pafzedog
Link to comment
Share on other sites

Yea we updated from the .NET Core runtime 2.0 to 2.1 in the 3.5 release so that might be playing a role as well.

Link to comment
Share on other sites

here is the content of this file:

Iface	Destination	Gateway 	Flags	RefCnt	Use	Metric	Mask		MTU	Window	IRTT                                                       
eth0	00000000	FE285097	0003	0	0	0	00000000	0	0	0                                                                               
eth0	00285097	00000000	0001	0	0	0	00FFFFFF	0	0	0                                                                               
docker0	000011AC	00000000	0001	0	0	0	0000FFFF	0	0	0
Link to comment
Share on other sites

  • 3 weeks later...

Hello,

 

do you find something useful to fix this or it will be a "wontfix" bug ?

 

No offence here, it's just to know if I have to search another way by myself ( docker, OS upgrade, etc...)

 

regards

Link to comment
Share on other sites

We are still looking into it. The problem is that the function we are calling is a critical one, so we can't just skip it, however, the exception is also being thrown in a way that we can't catch and handle. The next release will update to the newly released .NET Core runtime 2.1.3 so we can see if that has any impact. Thanks.

  • Like 1
Link to comment
Share on other sites

  • 3 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...