Jump to content
Sign in to follow this  
Crossfire0mega

Question about my local network settings

Recommended Posts

Crossfire0mega

Hello I just recently as of yesterday became unable to access the web interface of my emby installation. It was on 3.4.1.0 when it happened so I updated to see if that would fix it but it is still inaccessible. When I try to connect to the local IP via 8096 or 8920 I get a blank page that says invalid host. Tried firefox, chrome, and ie. Both chrome and FF gave the invalid host but Internet explorer said error 400. I have tried clearing cookies and cache but no luck. when logging into the server it shows that the emby service is running and nmap shows both ports open.

 

Emby Server Version: 3.5.1.0

Ubuntu 16.04.5 LTS

 

embyserver.txt

embyserver-63668073600.txt

Share this post


Link to post
Share on other sites
Luke

Have you tried rebooting your machine?

Share this post


Link to post
Share on other sites
Luke

The only way this error gets returned is if you configured a local IP filter, and you're not connecting with a local IP that matches your filter.

 

Try connecting from localhost or 127.0.0.1

Share this post


Link to post
Share on other sites
Crossfire0mega

I have tried rebooting multiple times, and the server is headless so I am connecting to it from another computer on the same subnet. I checked and ufw is disabled, I added rules for both ports and enabled it and disabled it again with no change. The machine was also set to dhcp so I set it to static but am still unable to load the web interface.

Share this post


Link to post
Share on other sites
Luke

I mean the local IP settings in Emby Server. It sounds like you have configured that in such a way that has now locked you out.

 

Can you please locate the server's programdata/config directory, and then attach the system.xml file here? thanks.

Share this post


Link to post
Share on other sites
Crossfire0mega

Ok I found the IP issue. I had changed the subnet from /16 to /24 but the emby config was still set to /16. After changing it in the system.xml file it loaded just fine, thanks!

Share this post


Link to post
Share on other sites
Luke

Thanks for the feedback.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...