Jump to content

Playstate not updated


Baldrdk
 Share

Recommended Posts

Baldrdk

After the latest update to emby, the playstate of episodes and movies are not updated in kodi.

After watching a video the sync process runs, but the state of the video are not marked as watched. As far as i figured this started happening after the latest update to emby.

 

The playstate is registred right in Emby itself, and in i run a manual sync from the kodi plugin, the state will be updated.

 

Anyone know what could be the cause of this?

Link to log: https://paste.kodi.tv/gofaqafube

Link to comment
Share on other sites

Angelblue05

Yeah looks like something was preventing the sync from running. How did you stop playback? The reason I asked is updates are set to run when playback is not happening.

Link to comment
Share on other sites

Baldrdk

It happens no matter how the playback stopps, if i let the video play out or if i stop it near the end.

Link to comment
Share on other sites

Angelblue05

Hmm ok. Then it must be the websocket connection to your server. I am not seeing any content update events from your server in your logs. Are you able to remote control players in the webclient?

Link to comment
Share on other sites

Angelblue05

Ok. For now, you can manually run the fast sync. I am in the process of reworking the sync at this time. but I don't know when I'll be done. Until then, you can assign this action to a button or a shortcut

RunPlugin(plugin://plugin.video.emby?mode=fastsync). 

 

Edit: Actually. That won't work because the incremental sync is being stopped from running. I think maybe Kodi is not sending the expected signals and it's causing the add-on to wait forever to process changes. But it's hard to tell because I don't see updates coming from Emby in your log.

Edited by Angelblue05
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...