Jump to content
Luke

New FreeNAS Package for testing

Recommended Posts

embytal

@@sluggo45 Are you building libx264 from source or using the binary package? Binary packages are still on .152 on my FreeBSD version 11.2. Once it lands our ffmpeg binary will be rebuilt against it.

 

 

"Binary packages are on .152 on my FreeBSD version 11.2 using quarterly packages"

 

FTFY

 

If you decide to go with latest package the version of libx264 is v155 are @@sluggo45 shows. Reference: https://www.freshports.org/multimedia/libx264/

Share this post


Link to post
Share on other sites
makarai

FreeNAS

 

Simple Installation

  • Requires FreeNAS 11.2 Stable
  • This Installation method will create a Jail that is fully configurable via the FreeNAS GUI

 

LATEST STABLE (4010)

cd /tmp
wget https://raw.githubusercontent.com/ma-karai/iocage-plugin-emby/master/emby-server.json
iocage fetch -P dhcp=on vnet=on bpf=yes allow_raw_sockets=1 -n emby-server.json --branch 'master' 

ADVANCED USERS:

If you know your Network setup your Installation could look like this

wget https://......./emby-server.json
iocage fetch -P --name emby-server.json ip4_addr="vnet0|192.168.0.112/24" defaultrouter="192.168.0.1" vnet="on" allow_raw_sockets="1" boot="on" host_hostname="emby-beta" host_domainname=""
  • vnet0 is of the virtualized network interface that is bridged to your NIC, if you have any plugins installed from the freeNAS repository it should already exist. If you open a shell and type ifconfig you should be able to figure out if it does.
  • Replace 192.168.122.3 and 24 with the IP and netmask you desire (make sure its outside your dhcp range and on your network).  You can edit this afterwards in the jail configuration interface, but since the plugin needs internet access to install, the initial configuration should be valid.
  • After installation you can add mount points using the jail interface to access your media files.

 

 

 

To Update 

  • Requires FreeNAS 11.2-Beta3, and at least Emby running
  • be on emby >4.1
  • There's no one click button in the freenas web interface to update an existing emby installation but you can use the shell as well
  • Go to https://github.com/MediaBrowser/Emby.Releases/releases
  • Copy the link from the emby-server-freebsd package (check for *.txz)
  • Follow the steps below
iocage console emby-server-beta
service emby-server stop
pkg add -f https://github.com/MediaBrowser/Emby.Releases/releases/download/4.2.0.13/emby-server-freebsd11_4.2.0.13_amd64.txz
service emby-server start

Optional, or more Advanced

  • Change the User and Group of emby-server to have no file ownership issues (here e.g. needs to be UID=GID=1101)
iocage console emby-server-beta
service emby-server stop
pw groupmod emby -n emby -g 1101
pw usermod emby -n emby -u 1101 -g 1101
chown -R emby:emby /var/db/emby(hit tab)
sysrc 'emby_server_user=emby'
service emby-server start

in case you like to know all the options for the starting parameter

iocage fetch -P --name emby-server-beta.json ip4_addr="vnet0|192.168.0.50/24" defaultrouter="192.168.0.1" vnet="on" allow_raw_sockets="1" boot="on" host_hostname="emby-beta" host_domainname="test.localdomain" bpf="yes"

# alternatively dhcp works also.
iocage fetch -P dhcp=on vnet=on bpf=yes -n emby-server-beta.json --branch 'master' 
# to copy config from jail to jail rsync will help and does 1g in mere seconds 

#example
rsync -vrlpogth /path_to_OLD_jail/root/var/db/emby-server/  /path_to_NEW_jail/root/var/db/emby-server/ 

rsync -vrlpogth /mnt/evo/iocage/jails/emby-server-OLD/root/var/db/emby-server/ /mnt/evo/iocage/jails/emby-server-NEW/root/var/db/emby-server/

Installation Video

 

 

 

 

Known Issues:

- Due to Freenas:  When mounting a folder to the jail via the freenas UI  folder creation fails, you have to create manually the mounting folders (will be fixed when freenas comes out of beta) (maybe fixed on the 17. OCT .2018)

 

 

Fixed :

- Due to 3rd party FreeBSD Packages:  Package for libx264 has been changed to fix follow the next steps:

  • from within the emby-server-beta jail you get there via
  • iocage console emby-server-beta
  • type
  • pkg remove libx264
    fetch https://mirrors.xtom.com/freebsd-pkg/FreeBSD%3A11%3Aamd64/quarterly/All/libx264-0.152.2854.txz
    pkg add libx264-0.152.2854.txz
  • and stop and restart your emby server
  • service emby-server stop
    service emby-server start
  • Thanks @@constrict
Edited by makarai
  • Like 3

Share this post


Link to post
Share on other sites
Luke

Thanks for this !

Share this post


Link to post
Share on other sites
Luke

What are all these extra params for?

defaultrouter="192.168.0.1" vnet="on" allow_raw_sockets="1" boot="on"

Share this post


Link to post
Share on other sites
makarai

I assume you checked https://www.freebsd.org/cgi/man.cgi?query=iocage&sektion=8

?

When you install different plugins in freeNAS these are the default network configurations that are set. So i copied this for the by hand installed jail, not sure if that's a valid reason for you. If I don't do it like this multicast won't work, or the jail stops when another plug-in is installed.

Edited by makarai

Share this post


Link to post
Share on other sites
Luke

Yes I did but i'm wondering what was the emby-specific reason? in other words, what problem do they solve?

Share this post


Link to post
Share on other sites
Luke

Our betas are now building against quarterly, and the next stable release will be as well. Thanks.

Share this post


Link to post
Share on other sites
Luke

Also i have incorporated your update and optional instructions, so i think these params are the only differences now, right?

Share this post


Link to post
Share on other sites
makarai

Well, I am not sure. Besides my anecdotal point of not being able to multicast (needed for my ip based live TV) and the emby jail network stopping as soon as I install a second plug-in using the same interface.

Share this post


Link to post
Share on other sites
Luke

do those params allow it to see other devices on the network, for upnp for example?

Share this post


Link to post
Share on other sites
Luke

ok, is it able to detect other dlna devices on the network? and are they able to detect the server?

Share this post


Link to post
Share on other sites
makarai

I have not setup dlna, I'll check asap

Share this post


Link to post
Share on other sites
youngster

I'm a little lost on the correct process here. I updated to 11.2-Release-p3 and then installed the plugin (3.5.2.0). I then started emby and I'm not sure what I ended up with. It appears emby is running at ipv4 address 192.168.0.106 but I'm unable to start the gui at 192.168.0.106:8096

 

# iocage list gives the following:

 

  3  |  emby  |  up  |   11.2-RELEASE  |  DHCP  |

 

 

I guess I expected the plugin to be more turn-key like the previous version that created the jail and the storage as well. What is my next step here?

Edited by youngster

Share this post


Link to post
Share on other sites
makarai

Well, typically it is turn-key. Try the following: start the jail/plug-in, click the Hamburger button and open the plug-in shell and type ifconfig.

 

Check if you actually have the correct ip address. Also can you tell me which freenas versions you employ

 

You can also give the instructions in this thread a try. Just adapt the ip addresses to your network. When I am back at home I can also create a video on how to deal with the installation.

Edited by makarai

Share this post


Link to post
Share on other sites
Luke

That would be great, thanks !

Share this post


Link to post
Share on other sites
youngster

Well, typically it is turn-key. Try the following: start the jail/plug-in, click the Hamburger button and open the plug-in shell and type ifconfig.

 

Check if you actually have the correct ip address. Also can you tell me which freenas versions you employ

 

You can also give the instructions in this thread a try. Just adapt the ip addresses to your network. When I am back at home I can also create a video on how to deal with the installation.

I could not figure out what you were asking me to do, so I just deleted the plugin and reinstalled it. I got a successful install message and it gave me an admin portal that I am able to connect to.

 

I'm really ignorant of how to create the jail/storage for this though. As far as I can tell, there is nothing created yet to hold the recordings. The previous version of the plugin (3.3.1) created all that for me. 

Share this post


Link to post
Share on other sites
Luke

What is that?

Share this post


Link to post
Share on other sites
makarai

What is that?

 

an installation video for emby server beta 43 on freenas.

Share this post


Link to post
Share on other sites
Luke

Ah great, thanks! 

Share this post


Link to post
Share on other sites
Barlog9511

First, tanks @makarai for the new beta package, everything works well :)

Now my problem,

after my transition from jail package to the new package, I released one thing ...

the automatic collection creation now doesn't work 

Everything is just empty ...
is here possibility ow to re-scan my library for collection? because movie have good metadata for collection but doesn't group by then or sow in the collection section

 

Thanks for a response

I have latest beta version 3.6.0.44

server logs and some pictures are in attachments 

 

 

server_log.txt

post-102570-0-68304600-1537261919_thumb.png

post-102570-0-02745500-1537261921_thumb.png

post-102570-0-11134500-1537261923_thumb.png

Share this post


Link to post
Share on other sites
makarai

First, tanks @makarai for the new beta package, everything works well :)

 

Now my problem,

after my transition from jail package to the new package, I released one thing ...

the automatic collection creation now doesn't work 

Everything is just empty ...

is here possibility ow to re-scan my library for collection? because movie have good metadata for collection but doesn't group by then or sow in the collection section

 

Thanks for a response

 

I have latest beta version 3.6.0.44

server logs and some pictures are in attachments 

 

Hi thanks for the kind words, i deflect them right towards @@Luke and crew. 

 

I suppose you installed the autoboxset plugin that takes care of the automated collection creation. If you open that plugin you can hit the button refresh the boxsets.

Share this post


Link to post
Share on other sites
Barlog9511

Hi thanks for the kind words, i deflect them right towards @@Luke and crew. 

 

I suppose you installed the autoboxset plugin that takes care of the automated collection creation. If you open that plugin you can hit the button refresh the boxsets.

 

Thanks for a quick response :)

 

the problem was after my transition from jail package to the new package auto boxset wasn't installed automatically

I must now install them now manually ...

 

So now everything works well and overall speed of emby is much faster like version 3.6.0.2 :)

 

Share this post


Link to post
Share on other sites
makarai

Thanks for a quick response :)

 

the problem was after my transition from jail package to the new package auto boxset wasn't installed automatically

I must now install them now manually ...

 

So now everything works well and overall speed of emby is much faster like version 3.6.0.2 :)

 

 

Yes, i think the idea was that emby should be compartmentalized (is that a word) and people add the things they want. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...