Jump to content


Photo

emby server crash

crash server mac unable to restart

Best Answer levander , 27 July 2018 - 07:13 PM

I just found "electron.app" in Activity Monitor and figured out that is actually emby process [UPDATE: it is emby taskbar process] (it never catched my eye before but this time I recognised the same icon that would appear with that message "unable to restart emby"). I successfully killed it from there the last time server went berserk and emby quit. After that I also successfully started emby.

 

Question:

 

Would you say it is safe to quit electron.app from Activity Monitor? I am asking that because you didn't mention it as option when I complained that I have to restart the system to be able to restart emby...

 

Thanks.

Go to the full post


  • Please log in to reply
19 replies to this topic

#1 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 575 posts
  • Local time: 11:16 PM

Posted 20 July 2018 - 10:46 AM

Hi,

 

Emby server "crashed" 2 times on Mac OS since I installed 3.5.0.0 beta. In Safari page was unreachable and also I was unable to restart emby server from menu in taskbar: "Emby Server was unable to restart".

 

This isn't the only time I had to restart Mac to be able to shut down and restart emby server. I think there should be more convenient way to shut down and restart emby if things go this way.

 

I am sending logs @Luke



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 157215 posts
  • Local time: 05:16 PM

Posted 20 July 2018 - 01:05 PM

I don't see any evidence of a crash here. the first thing i would suggest in situations like this is removing community plugins. Try removing these:

2018-07-20 15:38:48.761 Info App: Loading MediaBrowser.Plugins.Anime, Version=1.2.8.0, Culture=neutral, PublicKeyToken=null from /Users/ik/.config/emby-server/plugins/MediaBrowser.Plugins.Anime.dll
2018-07-20 15:38:48.762 Info App: Loading Emby.AutoOrganize, Version=1.2.8.0, Culture=neutral, PublicKeyToken=null from /Users/ik/.config/emby-server/plugins/Emby.AutoOrganize.dll
2018-07-20 15:38:48.762 Info App: Loading MediaBrowser.Plugins.StudioCleaner, Version=3.1.4.0, Culture=neutral, PublicKeyToken=null from /Users/ik/.config/emby-server/plugins/StudioCleaner.dll
2018-07-20 15:38:48.762 Info App: Loading statistics, Version=2.0.5.1, Culture=neutral, PublicKeyToken=null from /Users/ik/.config/emby-server/plugins/Statistics.dll
2018-07-20 15:38:48.762 Info App: Loading MediaBrowser.Plugins.TuneIn, Version=1.1.9.0, Culture=neutral, PublicKeyToken=null from /Users/ik/.config/emby-server/plugins/MediaBrowser.Plugins.TuneIn.dll
2018-07-20 15:38:48.762 Info App: Loading EmbyReports, Version=1.0.15.0, Culture=neutral, PublicKeyToken=null from /Users/ik/.config/emby-server/plugins/EmbyReports.dll
2018-07-20 15:38:48.762 Info App: Loading AutoBoxSets, Version=1.1.3.0, Culture=neutral, PublicKeyToken=null from /Users/ik/.config/emby-server/plugins/AutoBoxSets.dll
2018-07-20 15:38:48.762 Info App: Loading Trakt, Version=3.2.1.0, Culture=neutral, PublicKeyToken=null from /Users/ik/.config/emby-server/plugins/Trakt.dll

Thanks.



#3 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 575 posts
  • Local time: 11:16 PM

Posted 20 July 2018 - 01:15 PM

Ok, thanks, I will remove them for now and see how it goes.

 

I just want to add that problem of shutting down/restarting emby in this situations is maybe because of Mac OS. I haven't been able to solve this by killing the app from activity monitor. I always end up restarting the system and that is really annoying if it happens during watching movies.



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 157215 posts
  • Local time: 05:16 PM

Posted 20 July 2018 - 01:17 PM

Thanks for the info.



#5 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 575 posts
  • Local time: 11:16 PM

Posted 21 July 2018 - 08:21 AM

Now this is third time in two days, I click on an item from search query and then this:

 

5b53242575115_ScreenShot20180721at141252

 

I click refresh and then this:

 

5b53245ad9e8c_ScreenShot20180721at141444

 

I try to restart emby server and I got this:

 

5b53244c9a702_ScreenShot20180721at141437

 

Game over.

 

Now I have to restart Mac.

 

I send the logs yesterday, I removed plugins you told me to. It obviously is not crash but something else.

 

Same scenario happened more than few times with the latest stable release before I installed this one (3.5.0.0) but not so often as with this one.



#6 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 575 posts
  • Local time: 11:16 PM

Posted 21 July 2018 - 08:29 AM

Maybe answering this question ... https://emby.media/c...nd-line-script/ ...could temporary help until there would be some fix.



#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 157215 posts
  • Local time: 05:16 PM

Posted 21 July 2018 - 09:46 AM

Can you attach a new log with the plugins removed? thanks.



#8 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 575 posts
  • Local time: 11:16 PM

Posted 21 July 2018 - 10:04 AM

Can you attach a new log with the plugins removed? thanks.

 

 

Luke, now I realised I haven't restarted emby after I removed plugins yesterday and above that I missed to uninstall some of the plugins you mentioned. I deleted all the plugins now and restarted emby, if this situation repeats I will report immediately and send the logs. Thank you.



#9 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 157215 posts
  • Local time: 05:16 PM

Posted 21 July 2018 - 12:50 PM

Thanks for the feedback.


  • levander likes this

#10 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 575 posts
  • Local time: 11:16 PM

Posted 21 July 2018 - 02:54 PM

I am sending you logs again. It happened again and this time this was the case: 

 

I clicked on item that showed in search that shouldn't have been there because that location doesn't exist anymore (I moved the files and deleted it). Also, that same item was right beside the one I clicked (probably the one added from new location after I scanned the libraries). The last time this happened I also clicked on coverless "suspicious" item in search query and it immediately that circle showed; This time I could see the details page and then I clicked on edit image and clicked search. That was it - the end. 



#11 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 157215 posts
  • Local time: 05:16 PM

Posted 21 July 2018 - 02:59 PM

Thanks.



#12 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 575 posts
  • Local time: 11:16 PM

Posted 22 July 2018 - 06:13 AM

Hi,

 

just to confirm that there are definitely "non existing/dead link" items showing in search query along with those items with the same titles but from new/correct location. Those "old" titles cannot be removed after just re-scanning the library. I am not sure is this 3.5.0.0 related or it might be that it happened before. Anyway, when I try to edit or do anything with those items that circle appears, server becomes unreachable and emby refuse to restart.  



#13 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 157215 posts
  • Local time: 05:16 PM

Posted 22 July 2018 - 01:54 PM

Thanks for the info.



#14 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 575 posts
  • Local time: 11:16 PM

Posted 27 July 2018 - 03:36 AM

Hi, another update, another insight of mine: those dead duplicate movies that would cause emby to stop responding are actually “offline” media because I removed them to another location and deleted the folder containing that media but I didn’t removed it from library folders list. I like that offfline media feature but offline media behave bad when clicking on it. Also it’s been I while until I figured out that those were offline media, it would be better if there is some default icon/thumb for those.


Edited by levander, 27 July 2018 - 03:39 AM.


#15 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 157215 posts
  • Local time: 05:16 PM

Posted 27 July 2018 - 09:37 AM

Thanks for the info.

#16 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 575 posts
  • Local time: 11:16 PM

Posted 27 July 2018 - 06:53 PM

Same emby behaviour (as described throughout this thread) when I delete or rename images from media folder and then clicking on "edit images" without library scan.



#17 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 575 posts
  • Local time: 11:16 PM

Posted 27 July 2018 - 07:13 PM   Best Answer

I just found "electron.app" in Activity Monitor and figured out that is actually emby process [UPDATE: it is emby taskbar process] (it never catched my eye before but this time I recognised the same icon that would appear with that message "unable to restart emby"). I successfully killed it from there the last time server went berserk and emby quit. After that I also successfully started emby.

 

Question:

 

Would you say it is safe to quit electron.app from Activity Monitor? I am asking that because you didn't mention it as option when I complained that I have to restart the system to be able to restart emby...

 

Thanks.


Edited by levander, 28 July 2018 - 04:23 AM.


#18 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 157215 posts
  • Local time: 05:16 PM

Posted 27 July 2018 - 10:28 PM

It just means you'll lose the macos taskbar icon.



#19 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 575 posts
  • Local time: 11:16 PM

Posted 28 July 2018 - 03:49 AM

It just means you'll lose the macos taskbar icon.


No, it doesn’t mean just that. It means that that way I can kill Emby when it stops responding. And I can start Emby again then. It is faster than restarting Mac.

I tried killing Emby.app in activity monitor before without success. Instead killing electron.app process do that job.

#20 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 157215 posts
  • Local time: 05:16 PM

Posted 28 July 2018 - 12:24 PM

Thanks for the info.







Also tagged with one or more of these keywords: crash, server, mac, unable to restart

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users