Jump to content


Photo

Windows Server external url:port closes after few hours of use

Emby server bug Windows External Crash

  • Please log in to reply
6 replies to this topic

#1 delete1234567890 OFFLINE  

delete1234567890

    Newbie

  • Members
  • 2 posts
  • Local time: 05:08 AM

Posted 14 July 2018 - 11:15 AM

I have Emby running on a Windows server 2016 in a data center. I am always connecting to the external port with ssl enabled. After streaming for some time on any given day the external port within Emby closes and I cant access the server remotely. I have to RDP into the server and restart Emby to get the port to open again.

 

When I RDP in I can see Emby on the LAN port. Windows firewall has the external port open and the network firewall has the port open. I know its somewhere in Emby that has the problem. 

 

I used to use the auto restart plugin to restart Emby server every 24 hours but now that that is gone i have to do it manually. 

 

Does anyone have any recommendations to a good fix for this problem in the current version of Emby? 


Edited by sparknsh, 14 July 2018 - 11:17 AM.


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140578 posts
  • Local time: 05:08 AM

Posted 14 July 2018 - 12:44 PM

Hi there, please attach the information requested in how to report a problem:
https://emby.media/c...view=getnewpost
Thanks !

#3 delete1234567890 OFFLINE  

delete1234567890

    Newbie

  • Members
  • 2 posts
  • Local time: 05:08 AM

Posted 14 July 2018 - 12:50 PM

Due to sensitive information in the logs I am unable to post it publicly.



#4 Pankookis OFFLINE  

Pankookis

    Advanced Member

  • Members
  • 32 posts
  • Local time: 12:08 PM
  • LocationSweden

Posted 14 July 2018 - 01:51 PM

I am also experiencing this. Sometimes my server becomes unresponsive  when trying to remote access it and the only solution is to restart the Emby server.

 

It was a very long log so I've only included the last part. I hope it's alright.

 

 

Attached Files



#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140578 posts
  • Local time: 05:08 AM

Posted 14 July 2018 - 02:09 PM

I am also experiencing this. Sometimes my server becomes unresponsive  when trying to remote access it and the only solution is to restart the Emby server.

 

It was a very long log so I've only included the last part. I hope it's alright.

 

Hi there, can you please supply the complete log file? thanks.



#6 Pankookis OFFLINE  

Pankookis

    Advanced Member

  • Members
  • 32 posts
  • Local time: 12:08 PM
  • LocationSweden

Posted 14 July 2018 - 02:30 PM

Hi there, can you please supply the complete log file? thanks.

It happened again just now so here's that log, from boot to finish.

Attached Files



#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140578 posts
  • Local time: 05:08 AM

Posted 14 July 2018 - 02:40 PM

Ok, I would suggest trying again with the next release of emby server, thanks.







Also tagged with one or more of these keywords: Emby server, bug, Windows, External, Crash

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users