Jump to content
Archerofyail

Android app not playing subtitles on synced content

Recommended Posts

Archerofyail

As the title says, the android app isn't playing subtitles on synced content. Subtitles work on non-synced stuff, and I went to where the file itself is stored and the file has the embedded subtitle track in it, and it works in a different media player. It also shows up as an option in the subtitle selection menu, but they just don't show up when selected.

  • Like 1

Share this post


Link to post
Share on other sites
Bazzu85

Upp

 

Using last beta from playstore, mkv file synced to device won't load subtitles..

Using external player does..

Share this post


Link to post
Share on other sites
Luke

Can you try downloading a new file? thanks.

Share this post


Link to post
Share on other sites
Bazzu85

I've to download a new version of the beta app?

Share this post


Link to post
Share on other sites
Luke

What version of Emby Server are you running?

Share this post


Link to post
Share on other sites
Bazzu85

3.5.3.0 stable..

Android 3.0.16

 

I think is only a emby android player problem because the synced file have the subs in it (mxplayer plays the file with sub without problems).

In emby player during play the sub is selected in option but the text isn't on screen

Edited by Bazzu85

Share this post


Link to post
Share on other sites
Luke

Ok thanks. Please try again with the next release of Emby Server. Thanks.

Share this post


Link to post
Share on other sites
Bazzu85

Sorry for stressing you, but why is an emby server problem and not a android app problem?

 

The issue is during offline playback of synced content on android device..

 

Thx

Share this post


Link to post
Share on other sites
Luke

Because the two of them work together.

Share this post


Link to post
Share on other sites
Bazzu85

Ok, thx for the reply..

Share this post


Link to post
Share on other sites
saitoh183

@@Luke

Im on the latest beta server (3.6.0.60) and Emby for android 3.0.21 and i synced a single anime episode. It gives me the choice of my subs but none of them show up when i play. Subs are embedded. I choice original file as sync option

Share this post


Link to post
Share on other sites
Luke

@@softworkz is taking a look at this. Thanks.

Share this post


Link to post
Share on other sites
softworkz

@@saitoh183 - would you be able to provide one of those files for reproducing this?

Share this post


Link to post
Share on other sites
songchenwen

Any update on this issue? I'm facing the same problem now.

Share this post


Link to post
Share on other sites
songchenwen

Android TV Client won't show external subtitles. Android mobile won't show embedded subtitles for synced content. Now I have to keep both external and embedded subtitles with my videos. @@softworkz  @@Luke

Share this post


Link to post
Share on other sites
Luke

 

 

Android mobile won't show embedded subtitles for synced content. Now I have to keep both external and embedded subtitles with my videos

 

This is resolved for the next app update, which will be soon. Thanks.

 

 

 

Android TV Client won't show external subtitles

 

We're very happy to help. Please open a topic in the android tv section and attach the information requested in how to report a media playback issue. thanks !

Share this post


Link to post
Share on other sites
songchenwen

This is resolved for the next app update, which will be soon. Thanks.

 

Thank you. Looking forward to the new update.

 

 

We're very happy to help. Please open a topic in the android tv section and attach the information requested in how to report a media playback issue. thanks !

 

There is already another topic about this. Hope you also fix this soon.

Share this post


Link to post
Share on other sites
Luke

Are you sure that's the same thing? That user never said the subtitles aren't showing.

Share this post


Link to post
Share on other sites
songchenwen

Are you sure that's the same thing? That user never said the subtitles aren't showing.

 

It's the same thing. I'm sorry that I didn't recall it right yesterday. After testing again this morning, I remember that I merge subtitles with my mkv just to make my shield tv to direct play. No need to push to resolve this, because we can find an easy workaround.

 

And there is another mistake I made yesterday, which is that the Android mobile synced content bug is not related to external or embedded subtitles. It's just that one of my synced file can show external subtitles while others can't show any subtitle. I thought if I figured out the difference between the one working file and others I would be able to help you resolve the issue. But every difference I tested does not change the thing. Since you already have it resolved, I don't need to find the difference any more.

Share this post


Link to post
Share on other sites
softworkz

No no no...

 

To clarify: This thread is about displaying embedded subtitles of synced media files.

 

This issue has been resolved.

 

 

The other thread is about subtitle display on the Android TV app when playing server content.

That's a different app and a different media source and in no way related to this issue.

Share this post


Link to post
Share on other sites
songchenwen

No no no...

 

To clarify: This thread is about displaying embedded subtitles of synced media files.

 

This issue has been resolved.

 

 

The other thread is about subtitle display on the Android TV app when playing server content.

That's a different app and a different media source and in no way related to this issue.

 

No, they are not related. But together they make me have to keep both the embedded and external subtitles, which really feels like a dirty workaround. Anyhow the Android mobile issue seems not related to where I put my subtitles. A fix is good. Now I can just keep the subtitles inside my mkvs. And after the new Android mobile release, all will be good.

Share this post


Link to post
Share on other sites
softworkz

Great. Thanks for confirming!

Share this post


Link to post
Share on other sites
Luke

This is going up to beta today. Thanks.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...