Jump to content

Gamebrowser and metadata


xXSagaiaXx
 Share

Recommended Posts

xXSagaiaXx

How does gamebrowser scrape for metadata. It used to be in Gamebrowser II that it would use the directory title. Now it seems that it's looking at the contents of said directory. It doesn't work right for multi disc games.

 

S.

Link to comment
Share on other sites

Redshirt

I don't know that screenshots will help. Although GB can detect multi-disc games, none of the clients provide a way to select different discs

Link to comment
Share on other sites

oh so that's it. the server is detecting them correctly but the clients just haven't added support for them yet. that might make sense.

Link to comment
Share on other sites

Redshirt

@@ebr I'd love your input here. Without core support there are only a few options available to me. I could:

 

1. Show a multi-disc popup in the playback controller. It's an easy enough solution, but adds unforeseen situations as I have to account for the user backing out of an already running playback controller

2. Provide my own custom game details screen. Something I'm loathe to do as it seems more users whined that it didn't match their current theme.

 

With core support, it could be a popup dialog that themes could skin if they were inclined.

Link to comment
Share on other sites

Redshirt

I knew the conversation would go that route so I guess I jumped the gun. 

 

That naming convention should be valid assuming I understand you.. If hard-braces aren't being stripped before metadata lookup then that's a bug.

 

Just so I'm clear can you do what Luke originally suggested and provide a screenshot of how one of these games is laid out in explorer.

Link to comment
Share on other sites

I'm lost.  The original question was about metadata gathering but now we're talking about multi-disc games and playback...?

Link to comment
Share on other sites

xXSagaiaXx

No Redshirt. I'm kinda glad you jumped the gun, but like I said a popup to choose the multiple disc would be awesome.

 

Okay back to the issue at hand:

 

533a0c1b7758b_Untitled.png

 

So you see in the Final Fantasy VII directory I have the Images titled as Disc 1,2, & 3.

So when it tries to get the metadata it sees Disc 1 instead of Final Fantasy VII.

Here's another example:

 

533a0d1c2477b_Untitled.png

 

Here when it looks at Loaded its looking for metadata for Loaded (Track 01) instead of just Loaded. Is there anyway to change it back so it uses directory name instead of the directory contents.

 

Thanks,

S.

 

P.S. Please allow popups for multi disc or multi file games.

Link to comment
Share on other sites

xXSagaiaXx

lol...well multi disc support was on my list to ask anyway, but to answer Redshirt I wouldn't complain about a custom details screen or just a popup, if it didn't match my theme as long as we got one in the first place.

 

Now on to my issue. 

I will use playstation as my example.

 

So I have one game that I have the directory named: Hot Shots Golf. The file inside the directory is named: Hot Shots Golf [sCUS-94188]. So when the server is looking for metadata it is looking for "Hot Shots Golf [sCUS-94188]" instead of just "Hot Shots Golf". I know you could say, "well you could just rename the file", which is true but a lot of playstation games have multiple tracks in the directory and when you have multiple discs it becomes worse cause then the server looks for a game called "Disc 1" instead of "Final Fantasy VII".  (The games are just examples. This happens to all the games)

 

I hope this makes sense.

 

S.

Edited by xXSagaiaXx
Link to comment
Share on other sites

Yeah, that's a totally different issue than multi-disc playback.

 

Looks to me like we should be using the folder name for lookups just like we do with movies.

Link to comment
Share on other sites

xXSagaiaXx

Will multi disc playback be supported in the future?

 

Sent from my Nexus 4 using Tapatalk

Link to comment
Share on other sites

Will multi disc playback be supported in the future?

 

Sent from my Nexus 4 using Tapatalk

 

Probably - after we flesh out all of our alternate version logic on the server.

Link to comment
Share on other sites

xXSagaiaXx

Awesome! Thanks ebr

 

Sent from my Nexus 4 using Tapatalk

Edited by xXSagaiaXx
Link to comment
Share on other sites

  • 1 month later...
xXSagaiaXx

Now that multi disc support has been added (thanks everyone) is there anyway to get this fixed! This is a major issue keeping me from playing my games cause I cant.

 

S.

Edited by xXSagaiaXx
Link to comment
Share on other sites

Redshirt

Try this version. You may need to delete your C:\Users\[username]\AppData\Roaming\MediaBrowser-Server\data\library.db first so that the games can be re-resolved.

Link to comment
Share on other sites

xXSagaiaXx

Nope, I deleted the library.db before I copied over the new gamebrowser.dll. I let it repopulate the games and its still showing the same. Its still fetching the metadata based on the file name in the directory instead of fetching the metadata based on the directory name.

Link to comment
Share on other sites

xXSagaiaXx

Okay here's what I dont understand at the beginning of this post: http://mediabrowser.tv/community/index.php?/topic/7426-gamebrowser-classic-version-30039/ @@Redshirt showed how he had his file structure for Final Fantasy VII and media browser found all the metadata. I tried the same way and I got nothing. Also, I have parasite eve named nothing like the Final Fantasy VII and it found the metadata for that with no problem.

 

S.

Link to comment
Share on other sites

Redshirt

The only thing I can think of is that you have a bunch of game.xml files which would defeat the purpose of deleting the library db as all the same info would just get copied back into the db. I've never seen the issue you describe. I had hoped adding .cue would sort it out, but it hasn't.

Link to comment
Share on other sites

  • 2 weeks later...
xXSagaiaXx

I hate to be a pest about this, but I this issue still being looked at?

 

Thanks,

S.

Link to comment
Share on other sites

Redshirt

I don't know what to suggest right now. I can't figure out what could be happening. Over the weekend, I'll force my game library to rebuild and see if there has been an issue introduced since I put my current library together. 

Link to comment
Share on other sites

  • 1 month later...
xXSagaiaXx

@@Redshirt where would the game xml files be stored so i can delete them and see if I can get this problem fixed.

 

Thanks,

S.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...