Jump to content


Photo

Movies List constantly flashes


  • Please log in to reply
98 replies to this topic

#1 TheClaus OFFLINE  

TheClaus

    Newbie

  • Members
  • 8 posts
  • Local time: 04:43 PM

Posted 07 June 2018 - 01:03 PM

I noticed there was an update to Emby Server so I updated.  While everything plays fine on only my Roku(Roku 3 and Roku 4(older model)) when I enter Movies the posters struggle to load and the screen flashes.  The TV shows are fine just the movies.

 

Running Emby Server 3.4.1.0

Tested on Emby Client and Emby Beta for Roku.



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 118582 posts
  • Local time: 05:43 PM

Posted 07 June 2018 - 01:05 PM

Hi there, can you please attach an emby server log? you can learn how to do that here:

https://emby.media/c...port-a-problem/

 

Thanks !



#3 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 42145 posts
  • Local time: 05:43 PM

Posted 07 June 2018 - 03:07 PM

Hi.  What OS does your server run on?

 

This behavior on the client is an indication of too much image data (the images are too large for the UI) which can happen on some platforms if your image processor on the server is not functioning properly and, thus, sending full sized images to the app.

 

The log Luke requested above will show us if this is the case.

 

Thanks.



#4 speechles OFFLINE  

speechles

    Advanced Member

  • App Developer
  • 3513 posts
  • Local time: 02:43 PM

Posted 07 June 2018 - 04:32 PM

There is now a way to tell when this is going to happen, with the caveat the roku device is using firmware v8.1.x

 

https://sdkdocs.roku...DeviceInfoEvent
 

The isStatusMessage() throws true and in getInfo() will be the generalMemoryLevel string which has 3 conditions: normal, low, critical. When that image flashing problem happens it would be interesting to know what condition the roku is in. Once you know the roku is in low or critical state, you can stop dispatching for images and fallback to general purpose lower resolution placeholders (movies/tv/music/album/song/etc). This would stop the flashing, but introduce the new problem of "where did my images go"? This would be better than flashing IMO and you could even display a little popup each time the message comes in that memory is low or critical and pass this along to the user so that at least they know this isn't the apps normal behavior. On the popup rather than repeat it once they know memory is low, have it prompt the user to either dismiss or close the popup. If you choose close, the popup will repeat when each low/criticial condition event occurs, dismiss wont let the popup show again even if the condition occurs again. Food for thought.


Edited by speechles, 07 June 2018 - 04:36 PM.

  • Baenwort likes this

#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 118582 posts
  • Local time: 05:43 PM

Posted 07 June 2018 - 04:36 PM

@speechles that's great info, thanks. That would be useful to add to our logging.



#6 samuelqwe OFFLINE  

samuelqwe

    Advanced Member

  • Members
  • 211 posts
  • Local time: 04:43 PM
  • LocationEarth, Milky Way

Posted 08 June 2018 - 10:49 AM

I am experiencing the same issue where images will flicker on media selection screens. It even happens on TV Shows for me. I do believe this is due to the update to Roku OS 8.1, because everything was flawless before that.



#7 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 42145 posts
  • Local time: 05:43 PM

Posted 08 June 2018 - 11:01 AM

I am experiencing the same issue where images will flicker on media selection screens. It even happens on TV Shows for me. I do believe this is due to the update to Roku OS 8.1, because everything was flawless before that.

 

Can you please provide a server log from when this was happening and indicate at what time it was happening?

 

Thanks.



#8 TheClaus OFFLINE  

TheClaus

    Newbie

  • Members
  • 8 posts
  • Local time: 04:43 PM

Posted 08 June 2018 - 11:30 AM

I will get this stuff tonight when I get home from work.



#9 Diedrich OFFLINE  

Diedrich

    Advanced Member

  • Members
  • 630 posts
  • Local time: 05:43 PM

Posted 08 June 2018 - 05:23 PM

I noticed there was an update to Emby Server so I updated.

LOVE your avatar! Represent!

#10 rottonpeech OFFLINE  

rottonpeech

    Member

  • Members
  • 11 posts
  • Local time: 11:43 PM

Posted 13 June 2018 - 01:45 AM

Same issue since the update.
The last minute of the log is just thr roku on the menu with debug logging enbled. Hipe it helps. This is REALLLY annoyingAttached File  Log.txt   801.2KB   4 downloads

Sent from my SM-G892A using Tapatalk

#11 rottonpeech OFFLINE  

rottonpeech

    Member

  • Members
  • 11 posts
  • Local time: 11:43 PM

Posted 13 June 2018 - 01:51 AM

P.s. i have a short video of it too, but i cant attach it. PM me for the vid if you want.

Sent from my SM-G892A using Tapatalk

#12 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 42145 posts
  • Local time: 05:43 PM

Posted 13 June 2018 - 09:18 AM

Same issue since the update.
The last minute of the log is just thr roku on the menu with debug logging enbled. Hipe it helps. This is REALLLY annoyingattachicon.gifLog.txt

Sent from my SM-G892A using Tapatalk

 

It doesn't look like debug logging is actually enabled but I believe this is the root of your problem:

2018-06-12 22:42:21.357 Error ImageProcessor: Error encoding image
	*** Error Report ***
	Version: 3.4.1.0
	Command line: /system/EmbyServer.dll -programdata /config -ffmpeg /bin/ffmpeg -ffprobe /bin/ffprobe -restartexitcode 3
	Operating system: Unix 4.14.26.0
	64-Bit OS: True
	64-Bit Process: True
	User Interactive: True
	Processor count: 12
	Program data path: /config
	Application directory: /system
	System.EntryPointNotFoundException: Unable to find an entry point named 'sk_bitmap_lock_pixels' in DLL 'libSkiaSharp'.
	   at SkiaSharp.SkiaApi.sk_bitmap_lock_pixels(IntPtr b)
	   at SkiaSharp.SKBitmap.Resize(SKBitmap dst, SKBitmap src, SKBitmapResizeMethod method)
	   at Emby.Drawing.Skia.SkiaEncoder.EncodeImage(String inputPath, DateTime dateModified, String outputPath, Boolean autoOrient, Nullable`1 orientation, Int32 quality, ImageProcessingOptions options, ImageFormat selectedOutputFormat)
	   at Emby.Drawing.ImageProcessor.<ProcessImage>d__29.MoveNext()
	System.EntryPointNotFoundException
	   at SkiaSharp.SkiaApi.sk_bitmap_lock_pixels(IntPtr b)
	   at SkiaSharp.SKBitmap.Resize(SKBitmap dst, SKBitmap src, SKBitmapResizeMethod method)
	   at Emby.Drawing.Skia.SkiaEncoder.EncodeImage(String inputPath, DateTime dateModified, String outputPath, Boolean autoOrient, Nullable`1 orientation, Int32 quality, ImageProcessingOptions options, ImageFormat selectedOutputFormat)
	   at Emby.Drawing.ImageProcessor.<ProcessImage>d__29.MoveNext()

The server is unable to create proper sized images to send to the app due to what looks like an incompatible version of the image processing library.



#13 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 118582 posts
  • Local time: 05:43 PM

Posted 13 June 2018 - 04:17 PM

We're looking into this, thanks.



#14 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 118582 posts
  • Local time: 05:43 PM

Posted 13 June 2018 - 04:20 PM

@rottonpeech, you're on docker, right?



#15 rottonpeech OFFLINE  

rottonpeech

    Member

  • Members
  • 11 posts
  • Local time: 11:43 PM

Posted 18 June 2018 - 01:28 PM

@rottonpeech, you're on docker, right?

Yes. Sorry for the delay in reply.

Sent from my SM-G892A using Tapatalk

#16 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 118582 posts
  • Local time: 05:43 PM

Posted 18 June 2018 - 01:31 PM

We pushed an update to our docker container. Please update it and try again. Thanks.
  • rottonpeech likes this

#17 rottonpeech OFFLINE  

rottonpeech

    Member

  • Members
  • 11 posts
  • Local time: 11:43 PM

Posted 20 June 2018 - 05:04 AM

We pushed an update to our docker container. Please update it and try again. Thanks.

wow so much better!! thanks again!



#18 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 118582 posts
  • Local time: 05:43 PM

Posted 20 June 2018 - 09:13 AM

Thanks the the feedback.

#19 Peterw0163 OFFLINE  

Peterw0163

    Newbie

  • Members
  • 3 posts

Posted 26 June 2018 - 05:47 AM

I'm also seeing this problem on a Roku Express with the Emby App, on an older Roku 3 it works fine but on the newer EXPRESS model it flashes constantly on the Movie Info Pages.I am running Emby Server 3.4.1.0 on the QNAP box. Are you intending pushing the update out to all versions?


Edited by Peterw0163, 26 June 2018 - 09:42 AM.


#20 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 118582 posts
  • Local time: 05:43 PM

Posted 26 June 2018 - 09:55 AM

Please attach the emby server log. You can learn how to do that here:
https://emby.media/c...port-a-problem/
Thanks.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users