Jump to content
Dataman100

ANSWERED Nfo files started appearing

Recommended Posts

Dataman100

A few weeks ago, .nfo files started appearing in my main media folder.  Unfortunately, I don't know exactly when.  I'm guessing it started after one of the automatic sever upgrades.

 

I've made no changes to any of the settings in Emby, nor made any changes to any paths.  My metadata path is set to a folder under the main video folder.  Nfo files just started appearing for newly added video files in the main media folder.  I've never seen that before.  Was something changed in the handling of .nfo files?

 

Sorry I can't be more specific, but I don't really know when it started.

 

Thanks,

 

Dave

 

Share this post


Link to post
Share on other sites
Happy2Play

As all the features have moved to per library, have you checked each library?

 

Dashboard-Library-select each library-enable Show Advanced settings-scroll to Metadata Savers

  • Like 1

Share this post


Link to post
Share on other sites
Dataman100

As all the features have moved to per library, have you checked each library?

 

Dashboard-Library-select each library-enable Show Advanced settings-scroll to Metadata Savers

 

Ahhh, that was it.  The NFO box was checked.  I unchecked it and it seems like it's not creating the .nfo files anymore.  Out of curiosity, where is it storing the metadata for the file now?  Is it in the folder I have under the main folder marked for metadata?  I only see .png files in there with the artwork.

 

Thanks,

 

Dave

Share this post


Link to post
Share on other sites
Happy2Play

Ahhh, that was it.  The NFO box was checked.  I unchecked it and it seems like it's not creating the .nfo files anymore.  Out of curiosity, where is it storing the metadata for the file now?  Is it in the folder I have under the main folder marked for metadata?  I only see .png files in there with the artwork.

 

Thanks,

 

Dave

 

If nfo saver is disabled, the metadata is only written to the database.

Share this post


Link to post
Share on other sites
Dataman100

If nfo saver is disabled, the metadata is only written to the database.

 

Got it.  Thanks!

Share this post


Link to post
Share on other sites
ebr

Saving this data in nfo files will greatly reduce the time it takes to re-build your library if ever necessary (like if you were to move the items to a new location).

  • Like 1

Share this post


Link to post
Share on other sites
Devdroid

Saving this data in nfo files will greatly reduce the time it takes to re-build your library if ever necessary (like if you were to move the items to a new location).

 

Also, you can store playback information in the NFO file, which will be nice to have if an emby import fails for some reason, or if there are no emby backup. 

 

It's probably good to leave it enabled. The NFO files are small and don't do any harm :)

Edited by Devdroid

Share this post


Link to post
Share on other sites
ebr

Also, you can store playback information in the NFO file, which will be nice to have if an emby import fails for some reason, or if there are no emby backup. 

 

That feature is intended for communication with external apps (Kodi) it can only save it for a single user and it will not be re-imported into Emby.

 

Just FYI...

Share this post


Link to post
Share on other sites
Spanky

Does this feature still overwrite existing nfo files, that are supplied with scene releases?

 

If so, is there an easy way to stop this happening, while keeping both nfo files?

 

Thanks. 

Share this post


Link to post
Share on other sites
Luke

Just turn off nfo saving if you don't want that to happen. That's the only way.

  • Like 1

Share this post


Link to post
Share on other sites
samhill5215

Happy2play you mentioned turning off nfo creation was in advanced settings. It's visible in normal settings also. Has something changed? I'm running Version 3.4.1.0

Share this post


Link to post
Share on other sites
Luke

The nfo settings are immediately view-able just by clicking on a library in library setup.

Share this post


Link to post
Share on other sites
tixx

Ive just had to rebuild my library after an update which was a pain. If the nfo files help restore the data than this is great, however rather than having them inside a folder right next to the video files, is it possible to specify a directory to hold all the nfos in the one location?

 

e.g. if all the content is held at \\media\, have the ability to manually point to store the files under \\media\nfo\

 

If this is not possible, maybe look at implementing it in the future?
 

Thanks

Share this post


Link to post
Share on other sites
Luke

There currently is no setting for this. How would we know what nfo belongs to what video? That's why it's better to put them with the media

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...