Jump to content

Major problems with large music albums


FordGT90Concept
 Share

Recommended Posts

FordGT90Concept

I have an album with 405 songs (all consecutively numbered).  When I click on #1 and hit play, then go to the playing now list, it looks like this:

post-138756-0-48197600-1527347916_thumb.png

I-can-count-to-potato.jpg

 

I know about the arbitrary limit of playlist to 100 but when I click on 1, it should play through 100 no?  Not 1, 2, 3, 4, 9, etc.  I can work with 1-100, not this...ridiculousness.

Edited by FordGT90Concept
Link to comment
Share on other sites

FordGT90Concept

Isn't it obvious in the picture?  The tracks are 1-405.  In the list I clicked on, I can see 1-16.  What it actually decides to play is 1-4, 9, 12-15, 17, etc. It makes absolutely no sense.  This is also repeatable.

 

 

All I want to do is listen to all 405 tracks, preferably in order so I can stop/resume.  Emby can't handle this.

Edited by FordGT90Concept
Link to comment
Share on other sites

FordGT90Concept

Here's the album view:

post-138756-0-48765400-1527394318_thumb.png

 

I click on #1, here's the playlist view:

post-138756-0-69939600-1527394339_thumb.png

 

If I click on #5, it plays #9.  Click on #10, it plays #17.

Edited by FordGT90Concept
Link to comment
Share on other sites

Well I think based on the playlist display that would be expected, no? I guess the question that needs investigation is how did the playlist get like that, right?

Link to comment
Share on other sites

FordGT90Concept

Yes.  No matter how I get to the playlist, it ends up like it shows (in order, but sporadic indexing).  Any album with 200+ songs gets like this when a playlist is formed.  

Link to comment
Share on other sites

Can you locate the playlist.xml file and see how the track list in there compares to what you see on screen? thanks.

Link to comment
Share on other sites

FordGT90Concept

There are no files by the name of playlist.xml in emby server folder.  It's an auto-generated (unsaved) playlist.

 

This same behavior is observed with The Crew (236 songs).  Album view (alphabetical, no disks):

post-138756-0-11582900-1527396535_thumb.png

 

Click on 1999 to start playing it, here's the auto-generataed playlist:

post-138756-0-21507900-1527396562_thumb.png

 

Comparison:

post-138756-0-32772700-1527396704_thumb.png

Edited by FordGT90Concept
Link to comment
Share on other sites

Does this also happen if you click play on the album detail screen, as opposed to clicking on a song?

Link to comment
Share on other sites

FordGT90Concept

Clicking the album play button appears to have the correct order but it cuts off at 200 songs:

post-138756-0-78037200-1527397979_thumb.png

 

Edit: Same for The Crew.

Edited by FordGT90Concept
Link to comment
Share on other sites

FordGT90Concept

I just installed 3.4.1.9 and tried it and, it's fixed in part. By in part, I mean (bolded is irregular):

 

Click on 1: 1-200 shows up in playlist, playing 1
Click on 200: 1-200 shows up in playlist, playing 200 (should be 200-399 if sticking to 200 rule)

Click on 201: 1-200 shows up in playlist, playing 1

Click on 404: 1-200 shows up in playlist, playing 1

 

TL;DR: tracks beyond the first 200 are unplayable by Emby.

Edited by FordGT90Concept
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...