Jump to content

Question about hosting parameters


Bruechmann
 Share

Go to solution Solved by Luke,

Recommended Posts

Bruechmann

I did install the version 3.4.1.0 on my DS918+.

 

As the disks do not enter hibernation I wanted to disable "automatic portmapping" (as suggested somwhere in this forum).

However changing the parameters in the Advanced -> Hosting section do not have any effect.

 

This does apply to all parameters - none of them is saved after pressing "Save".

 

Only two message boxes appear.

 

Could somebody please help ?

 

 

From my point of view it look like the user requesting the cahnges does not have the permission on file system level ...

 

 

Thx a lot !

Edited by Bruechmann
Link to comment
Share on other sites

Bruechmann

Hi Luke,

 

only the "2 normal" warning boxes that tell us "...changing this parameters can lead to instability and connection problems ..." and the "Let's Crypt" message,

Link to comment
Share on other sites

Bruechmann

Yes – I try to change it from the browser (I used Chrome last time).

 

Is there another way to do this ?

 

The filesystem rights for the config.xml are 644, so only the Owner has the right to change it ...

Edited by Bruechmann
Link to comment
Share on other sites

Bruechmann

sorry fo the delay - I was some days off...

 

Here is the server-log:  Serverlog_2018-05-13.txt

 

On that day nobody has been there - the network was "unused", but the Synology did not go to sleep.

All drive are online all the time.

 

 

And this is the log of my "try" to change the automatic port mapping: Serverlog_2018-05-14.txt

 

I enabled "debug logging", before I tried to change the port mapping behaviour.

 

This are the filesystem rights in the "config" DIR:

DSadmin@DS918:/var/packages/EmbyServer/target/var/config$ ls -la
total 44
drwxr-xr-x  5 embysvr users 4096 May  9 21:13 .
drwxr-xr-x 11 embysvr users 4096 May  9 10:39 ..
drwxr-xr-x  4 embysvr users 4096 May  7 17:25 dlna
-rw-r--r--  1 embysvr users  457 May 10 11:43 dlna.xml
-rw-r--r--  1 embysvr users  213 May  7 23:37 fanart.xml
-rw-r--r--  1 embysvr users    2 May  7 17:50 mb.lic
-rw-r--r--  1 embysvr users  243 May  7 23:37 metadata.xml
drwxr-xr-x  2 embysvr users 4096 May  9 08:23 ScheduledTasks
-rw-r--r--  1 embysvr users 6546 May 14 19:49 system.xml
drwxr-xr-x  3 embysvr users 4096 May  7 17:25 users
DSadmin@DS918:/var/packages/EmbyServer/target/var/config$

Other changes (like plugin installations" have been successfully written to "system.xml" - so the general ability to save changes is there.

Only from the "advanced settings" menu this is not true.

 

 

Link to comment
Share on other sites

What exactly happened when you tried to save the automatic port mapping setting?

Link to comment
Share on other sites

Bruechmann

just a Message Box warning me to change these settings ...

then I press OK and the box disappears. That’s all. No saving successful message or something else.


Do I have to enter something into the blank fields to successfuly save the hosting parameters ?

 

...this are my values:

5afa92200e37e_20180515_094902.png

Edited by Bruechmann
Link to comment
Share on other sites

Bruechmann

Hi Luke,

 

thx a lot - that was it !

 

After switching to "disabled" I did get the "settings saved" message and the values are persistant.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...