Jump to content


Photo

Emby Theater Desktop Playback of 3D Movie Remuxes (mk3d or mkv Containers) Freezes After ~26 Minutes

3D MVC Freeze mk3d

  • Please log in to reply
182 replies to this topic

#1 shpitz461 OFFLINE  

shpitz461

    Advanced Member

  • Members
  • 173 posts
  • Local time: 02:05 PM
  • LocationAcworth, GA

Posted 06 May 2018 - 09:48 PM

Hi everyone,
 
been having a weird issue where playback stops every ~26 minutes. I'm streaming via lan (wired) an MKV bluray remux with DTS-MA audio.
 
It plays great, then after ~26 minutes the playback freezes and Emby Theatre is unresponsive, nothing happens if I press play/pause/stop. I kill Emby Theatre and then resume the movie, it plays fine for another 26 minutes.
 
If I play using an external player, the player quits and returns to Emby Theatre..
 
Nothing is in the server's log, just regular heartbeats.
 
Nothing is the Theatre log, I did set to EnableDebugLevelLogging=true but nothing extra is shown in the log.
 
Anyone else?
 

 


Edited by shpitz461, 08 October 2018 - 01:24 PM.


#2 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 15365 posts
  • Local time: 11:05 AM
  • LocationWashington State

Posted 06 May 2018 - 09:55 PM

Just a guess could your drive Emby is installed on be full?



#3 shpitz461 OFFLINE  

shpitz461

    Advanced Member

  • Members
  • 173 posts
  • Local time: 02:05 PM
  • LocationAcworth, GA

Posted 06 May 2018 - 10:39 PM

Nope. it's on the OS drive, SSD, with 295GB free.

 

I've attached my server log, bunch of exceptions but not sure if they are related.

 

I removed the library folder M:\x264

Attached Files



#4 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 15365 posts
  • Local time: 11:05 AM
  • LocationWashington State

Posted 06 May 2018 - 10:53 PM

Are all the drive letters physical/local drives or mapped drives?

 

You are having issues with M:\TV also.

Skipping realtime monitor for M:\TV because the path does not exist


#5 shpitz461 OFFLINE  

shpitz461

    Advanced Member

  • Members
  • 173 posts
  • Local time: 02:05 PM
  • LocationAcworth, GA

Posted 07 May 2018 - 10:57 AM

Yeah, M: is an external drive and is going bad, but none of the movies I played were on it. Each drive letter is a local physical disk, all internal drives varying in sizes.

 

Is there a way to bump up the logging level?

 

Thanks

 

EDIT: Enabled debug logging on the server, going to do more testing.


Edited by shpitz461, 07 May 2018 - 10:58 AM.


#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136155 posts
  • Local time: 02:05 PM

Posted 07 May 2018 - 11:23 AM

Let us know how your testing goes, thanks.



#7 shpitz461 OFFLINE  

shpitz461

    Advanced Member

  • Members
  • 173 posts
  • Local time: 02:05 PM
  • LocationAcworth, GA

Posted 11 May 2018 - 09:57 PM

This happened again just now, was watching Kung Fu Panda 3 using internal player, streaming over wire, and the playback stopped (as in movie was on but would not play). Went back to movie's info screen and tried to resume, the hourglass circle was just spinning on top of the movie's fanart image.

Had to close Emby Theatre and reopen it, movie is playing again now.

I've attached logs.

 

26 minutes. not sure what that means, but it's cyclical.

 

Playback in log is timestamped 18:12 start, 18:39 freeze.

 

2018-05-11 18:12:28.192 Info Main: Http Completed POST fileexists
2018-05-11 18:39:24.951 Info Main: Http POST fileexists
 

Attached Files



#8 shpitz461 OFFLINE  

shpitz461

    Advanced Member

  • Members
  • 173 posts
  • Local time: 02:05 PM
  • LocationAcworth, GA

Posted 11 May 2018 - 10:08 PM

And as predicted, happened again just now @ the 52-minute mark.



#9 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136155 posts
  • Local time: 02:05 PM

Posted 11 May 2018 - 11:00 PM

Do you see this if you play with the web app? Maybe there is a problem with your machine that is running Theater? What version of Windows is it?



#10 shpitz461 OFFLINE  

shpitz461

    Advanced Member

  • Members
  • 173 posts
  • Local time: 02:05 PM
  • LocationAcworth, GA

Posted 11 May 2018 - 11:34 PM

Yeah, that's what I suspect. My son was playing a 3 hour movie last night on an xbox one and it was working fine the whole time.

 

My htpc is a NUC i5 running Windows 7.



#11 shpitz461 OFFLINE  

shpitz461

    Advanced Member

  • Members
  • 173 posts
  • Local time: 02:05 PM
  • LocationAcworth, GA

Posted 14 May 2018 - 02:21 PM

Ok, so I installed a fresh copy of Windows 10 on the NUC, installed drivers and emby theatre, nothing else.

 

Playing the same Kung Fu Panda 3 3D remux (mk3d file) and it freezes just after 26 minutes, using internal player, playing in 2D mode.

 

Going to try playing with MPC-HC as external player later on and report back.



#12 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136155 posts
  • Local time: 02:05 PM

Posted 14 May 2018 - 02:43 PM

Thanks for the info.



#13 shpitz461 OFFLINE  

shpitz461

    Advanced Member

  • Members
  • 173 posts
  • Local time: 02:05 PM
  • LocationAcworth, GA

Posted 14 May 2018 - 06:10 PM

Ok, so i played another movie using internal player, a 2D mkv, and it never froze.

Tried another 3D mk3d movie using internal player and it froze after 26 minutes.

When this happens Theatre cannot play any other file anymore unless I restart the app.

I then played the 3D mk3d using MPC-HC displayed in 2D and it didn't freeze.

So it must be something with the internal player playing 3D mk3d files in 2D.

 

Is there a way to turn on internal player logging?



#14 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136155 posts
  • Local time: 02:05 PM

Posted 14 May 2018 - 06:12 PM

Yea @Doofus has a guide handy on how to setup mpv logging. Thanks.


  • shpitz461 likes this

#15 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 12103 posts
  • Local time: 11:05 AM

Posted 14 May 2018 - 06:27 PM

How set up logging for mpv

https://emby.media/c...r/?fromsearch=1

And I'm assuming you're on the latest version?

#16 shpitz461 OFFLINE  

shpitz461

    Advanced Member

  • Members
  • 173 posts
  • Local time: 02:05 PM
  • LocationAcworth, GA

Posted 14 May 2018 - 08:52 PM

Thanks Doofus, I'm on latest Theatre version as well as server.



#17 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 12103 posts
  • Local time: 11:05 AM

Posted 14 May 2018 - 08:58 PM

Post a log, let's see if it tells us anything :)

#18 shpitz461 OFFLINE  

shpitz461

    Advanced Member

  • Members
  • 173 posts
  • Local time: 02:05 PM
  • LocationAcworth, GA

Posted 14 May 2018 - 09:00 PM

Will do, youngest is watching right now so I'll test later. Following your instructions right now.



#19 shpitz461 OFFLINE  

shpitz461

    Advanced Member

  • Members
  • 173 posts
  • Local time: 02:05 PM
  • LocationAcworth, GA

Posted 14 May 2018 - 09:42 PM

Ok, log is generating right now, playing Kung Fu Panda 3D using internal player in 2D.



#20 shpitz461 OFFLINE  

shpitz461

    Advanced Member

  • Members
  • 173 posts
  • Local time: 02:05 PM
  • LocationAcworth, GA

Posted 14 May 2018 - 10:10 PM

Frozen just now, at 26:27.

 

Attached is the log.

Attached Files

  • Attached File  mpv.7z   697.57KB   1 downloads






Also tagged with one or more of these keywords: 3D, MVC, Freeze, mk3d

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users