Jump to content
stesie

Chromecast - does not show Photos in full screen

Recommended Posts

stesie

Is there a way to configure Emby so that Photos are casted full screen?

 

Background:

I am using Chromecast to watch my Photo collection and I find it very annoying that Emby does not cast the Photo in full screen format. I previously used Plex and that works as expected in that regards. Emby display videos in full screen and it is not reproducible why lot of screen space is wasted when displaying images.

 

Stefan

Share this post


Link to post
Share on other sites
Luke

hi @@stesie, i tested this and they are displaying in full screen for me. can you tell me exactly how you are doing this? thanks.

Share this post


Link to post
Share on other sites
stesie

Hi @@Luke, (for other reasons) I have purchased a Chromecast Ultra today and I recognize the issue does not appear with that. When I change back to my old Chromecast (1st gen.) the issue appear again. So it seems to be Chromecast version related.

 

Another issue I face with both Chromecasts: When casting an image, Emby app automatically display one image after the next within this folder. So far so good. But if I then use the app to navigate to a video, the image gallery does not stop. I can hear the audio from the video, but what is displayed on the screen are the images – not the video.

The app provide buttons to play/stop/pause videos on the bottom. But not so when running an image gallery. At least I can’t see any buttons to stop the image gallery playing. The only way I found so far is to manually disconnect from the Chromecast, connect to it again and then start the video playback (without casting an image in advance).  

 

Stefan

Share this post


Link to post
Share on other sites
Luke

Thanks for the report, I will test that out.

Share this post


Link to post
Share on other sites
stesie

Hi @Luke, how is testing going and when might be a fix availabe?

Share this post


Link to post
Share on other sites
Luke

@@stesie, I've pushed an update to our chromecast receiver to resolve this. please try it out, thanks !

Share this post


Link to post
Share on other sites
stesie

Thank you @@Luke , Photos are full screen now.

A related issue I face, is, if I want to watch a folder via Chromecast that contains several photos and several (short) videos clips. When casting the 1st photo, then the 2nd, 3rd etc are shown automatically. If I touch - say - the 5th picture manually that interrupts the automatism and the 5th picture is shown as expected. To that point all good no issue. BUT: if I select a video clip instead of a photo, than it mess up: I can hear the audio from the video, but I can't see it! Chromeceast keep showing one picture after the next.

The only way to show the video is to disconnect the app from the Chromecast, connect to it again and start the video without displaying a photo before. That's odd - isnt it?

Edited by stesie

Share this post


Link to post
Share on other sites
Luke

Ok thanks, I'll look at that.

Share this post


Link to post
Share on other sites
stesie

Hi @@Luke,

 

the Github ticket is stated closed, although I have posted on Sept 6, that the solution is not working properly.

 

Please can you look at it?

Share this post


Link to post
Share on other sites
Luke

Are they still not full screen?

Share this post


Link to post
Share on other sites
stesie

Hi @Luke, Photo casting is in full screen since, but it still seem to kill the capability to cast a video:

 

When connecting to Chromecast, then watching a photo, then try to play a video, the video does not start to play. The spinning wheel is spinning forever.

 

When connecting to Chromecast, then try to play a video (without watching photos before), the video play immediately. It also let me play more videos if I want - BUT as soon I select a photo and then try to play a video again, then the spinning wheel is again spinning forever.

 

The only way to show the video is then to disconnect the app from the Chromecast, connect to it again and start the video without displaying a photo before. That's odd - isnt it?

Edited by stesie

Share this post


Link to post
Share on other sites
Luke

Have you tried this again recently?

Share this post


Link to post
Share on other sites
stesie

Sure @@Luke. I tried it before I posted the reminder on Jan 4.

Share this post


Link to post
Share on other sites
Luke

Is this on a gen 1 Chromecast?

Share this post


Link to post
Share on other sites
stesie

Havent tried gen 1 since quite some time. I recently faced the issue on the Model with 4K Video support.

Edited by stesie

Share this post


Link to post
Share on other sites
stesie

Hi @Luke. Can you reproduce it? Do you think it is possible to fix this isssue?

Share this post


Link to post
Share on other sites
Luke

Hi, yes i will be looking at this, thanks.

Share this post


Link to post
Share on other sites
stesie

Hi @@Luke, can you indicate when a fix might be availabe?

 

>When connecting to Chromecast, then watching a photo, then try to play a video, the video does not start to play. The spinning wheel is spinning forever.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...