Jump to content


Photo

Chromecast - does not show Photos in full screen


  • Please log in to reply
18 replies to this topic

#1 stesie OFFLINE  

stesie

    Member

  • Members
  • 12 posts
  • Local time: 08:05 AM

Posted 12 April 2018 - 03:30 PM

Is there a way to configure Emby so that Photos are casted full screen?

 

Background:

I am using Chromecast to watch my Photo collection and I find it very annoying that Emby does not cast the Photo in full screen format. I previously used Plex and that works as expected in that regards. Emby display videos in full screen and it is not reproducible why lot of screen space is wasted when displaying images.

 

Stefan



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 127151 posts
  • Local time: 03:05 AM

Posted 14 April 2018 - 05:58 PM

hi @stesie, i tested this and they are displaying in full screen for me. can you tell me exactly how you are doing this? thanks.



#3 stesie OFFLINE  

stesie

    Member

  • Members
  • 12 posts
  • Local time: 08:05 AM

Posted 15 April 2018 - 07:35 AM

Hi @Luke, (for other reasons) I have purchased a Chromecast Ultra today and I recognize the issue does not appear with that. When I change back to my old Chromecast (1st gen.) the issue appear again. So it seems to be Chromecast version related.

 

Another issue I face with both Chromecasts: When casting an image, Emby app automatically display one image after the next within this folder. So far so good. But if I then use the app to navigate to a video, the image gallery does not stop. I can hear the audio from the video, but what is displayed on the screen are the images – not the video.

The app provide buttons to play/stop/pause videos on the bottom. But not so when running an image gallery. At least I can’t see any buttons to stop the image gallery playing. The only way I found so far is to manually disconnect from the Chromecast, connect to it again and then start the video playback (without casting an image in advance).  

 

Stefan



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 127151 posts
  • Local time: 03:05 AM

Posted 15 April 2018 - 12:57 PM

Thanks for the report, I will test that out.

#5 stesie OFFLINE  

stesie

    Member

  • Members
  • 12 posts
  • Local time: 08:05 AM

Posted 09 May 2018 - 09:53 AM

Hi Luke, how is testing going and when might be a fix availabe?



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 127151 posts
  • Local time: 03:05 AM

Posted 23 June 2018 - 11:43 PM

@stesie, I've pushed an update to our chromecast receiver to resolve this. please try it out, thanks !



#7 stesie OFFLINE  

stesie

    Member

  • Members
  • 12 posts
  • Local time: 08:05 AM

Posted 24 June 2018 - 06:19 AM

Thank you @Luke , Photos are full screen now.

A related issue I face, is, if I want to watch a folder via Chromecast that contains several photos and several (short) videos clips. When casting the 1st photo, then the 2nd, 3rd etc are shown automatically. If I touch - say - the 5th picture manually that interrupts the automatism and the 5th picture is shown as expected. To that point all good no issue. BUT: if I select a video clip instead of a photo, than it mess up: I can hear the audio from the video, but I can't see it! Chromeceast keep showing one picture after the next.

The only way to show the video is to disconnect the app from the Chromecast, connect to it again and start the video without displaying a photo before. That's odd - isnt it?


Edited by stesie, 24 June 2018 - 07:39 AM.


#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 127151 posts
  • Local time: 03:05 AM

Posted 24 June 2018 - 09:13 AM

Ok thanks, I'll look at that.

#9 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 127151 posts
  • Local time: 03:05 AM

Posted 14 August 2018 - 04:41 PM

Iv'e created a ticket for this issue so that you can monitor it here:

 

https://github.com/M...mby/issues/3405

 

Thanks !



#10 stesie OFFLINE  

stesie

    Member

  • Members
  • 12 posts
  • Local time: 08:05 AM

Posted 04 January 2019 - 04:28 PM

Hi @Luke,

 

the Github ticket is stated closed, although I have posted on Sept 6, that the solution is not working properly.

 

Please can you look at it?



#11 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 127151 posts
  • Local time: 03:05 AM

Posted 04 January 2019 - 06:04 PM

Are they still not full screen?



#12 stesie OFFLINE  

stesie

    Member

  • Members
  • 12 posts
  • Local time: 08:05 AM

Posted 05 January 2019 - 04:09 AM

Hi @Luke, Photo casting is in full screen since, but it still seem to kill the capability to cast a video:

 

When connecting to Chromecast, then watching a photo, then try to play a video, the video does not start to play. The spinning wheel is spinning forever.

 

When connecting to Chromecast, then try to play a video (without watching photos before), the video play immediately. It also let me play more videos if I want - BUT as soon I select a photo and then try to play a video again, then the spinning wheel is again spinning forever.

 

The only way to show the video is then to disconnect the app from the Chromecast, connect to it again and start the video without displaying a photo before. That's odd - isnt it?


Edited by stesie, 08 January 2019 - 12:37 PM.


#13 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 127151 posts
  • Local time: 03:05 AM

Posted 11 January 2019 - 01:55 AM

Have you tried this again recently?



#14 stesie OFFLINE  

stesie

    Member

  • Members
  • 12 posts
  • Local time: 08:05 AM

Posted 11 January 2019 - 06:26 AM

Sure @Luke. I tried it before I posted the reminder on Jan 4.



#15 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 127151 posts
  • Local time: 03:05 AM

Posted 11 January 2019 - 02:08 PM

Is this on a gen 1 Chromecast?

#16 stesie OFFLINE  

stesie

    Member

  • Members
  • 12 posts
  • Local time: 08:05 AM

Posted 11 January 2019 - 02:12 PM

Havent tried gen 1 since quite some time. I recently faced the issue on the Model with 4K Video support.


Edited by stesie, 11 January 2019 - 02:12 PM.


#17 stesie OFFLINE  

stesie

    Member

  • Members
  • 12 posts
  • Local time: 08:05 AM

Posted 23 January 2019 - 03:43 PM

Hi @Luke. Can you reproduce it? Do you think it is possible to fix this isssue?



#18 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 127151 posts
  • Local time: 03:05 AM

Posted 23 January 2019 - 04:15 PM

Hi, yes i will be looking at this, thanks.



#19 stesie OFFLINE  

stesie

    Member

  • Members
  • 12 posts
  • Local time: 08:05 AM

Posted 20 March 2019 - 02:15 PM

Hi @Luke, can you indicate when a fix might be availabe?

 

>When connecting to Chromecast, then watching a photo, then try to play a video, the video does not start to play. The spinning wheel is spinning forever.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users