Jump to content


Photo

Hide volume change icon


  • Please log in to reply
5 replies to this topic

#1 nnylray OFFLINE  

nnylray

    Advanced Member

  • Members
  • 67 posts
  • Local time: 02:01 PM

Posted 18 March 2018 - 04:44 AM

Is there a way to hide the volume change icon in Emby Theater?  I am having a major issue where the range of volumes is way too wide.  For example, I can't hear basic dialogue, so I have to increase the volume, but then an explosion happens, but at the volume of a real explosion.  I am aware of dynamic range compression, but it never seems to increase the volume of quiet voices enough for me.  The best option I have found is a program called Sound Locker, where I can limit the max volume.  However, whenever there is a sound that exceeds this volume threshold, it seems to trigger a volume change, which then results in the volume changing icon appearing in Emby Theater.  I would prefer it not to show up every time there is a loud noise.  (Also, I never need the volume icon because I control the volume on my receiver).



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124164 posts
  • Local time: 05:01 PM

Posted 18 March 2018 - 01:54 PM

HI, we don't currently have a setting for this, although in TV mode it will hide when the mouse idles, simply because you don't need those controls with a remote control.



#3 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 10955 posts
  • Local time: 02:01 PM

Posted 18 March 2018 - 02:10 PM

Your receiver will likely have an option to level the volume, too.



#4 nnylray OFFLINE  

nnylray

    Advanced Member

  • Members
  • 67 posts
  • Local time: 02:01 PM

Posted 18 March 2018 - 02:17 PM

I tried letting the mouse idle, but the icon still comes up because of something the program is doing to control the volume.

 

Also, I have tried all of the dynamic range control / midnight / loudness control settings on my receiver, but none of them ever seem to have any effect.  It is a Pioneer VSX-530.



#5 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 10955 posts
  • Local time: 02:01 PM

Posted 18 March 2018 - 02:43 PM

I think DRC is only applicable to AC3. 

 

https://mpv.io/manua...-ad-lavc-ac3drc

 

5aaeb2b029947_Snapshot_502.jpg

 

So if you want to test it, there is a way for mpv to make everything AC3, on the fly. And that may enable you to use DRC to better effect.



#6 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 10955 posts
  • Local time: 02:01 PM

Posted 18 March 2018 - 05:04 PM

Well, I can't positively determine that I can get DRC working, at all. I have tried many configs in both Theater and the standalone. I can't find it anywhere in the logs and I perceive no difference, when listening. Based on the manual, it might mean that my files don't contain the required information to enable it.

 

I did discover a few things, though. Enabling exclusive mode when not bitstreaming, causes mpv to not support several audio formats.

 

But a big thing I discovered, was disabling bitstreaming in Theater and letting mpv decode to PCM, lowers the volume considerably (DRC not in use). Playing the same file in the standalone, the audio volume is unchanged. I cannot discern what is causing that.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users