Jump to content

Can't stream anything to Chromecast


Der_Judge
 Share

Recommended Posts

I have have the same problem using Chrome browser and trying to stream something on the chromecast. So it is not only on Android. Any recommendations how to troubleshoot this?

 

@@blinkiz and also, what type of SSL cert do you have?

Link to comment
Share on other sites

blinkiz

@@blinkiz and also, what type of SSL cert do you have?

It is a Let's Encrypt certificate generated by Traefik proxy with correct CN for my URL. Emby server does not have this certificate. In setting I simply have "Handled by reverse proxy".

 

Please remember I do have working streaming at home to my chromecast. But streaming to chromecast at work and at a friends house does not work. I have tired both with Android emby app, iPad Emby app and computer (chrome, webgui) with the same result.

Link to comment
Share on other sites

blinkiz

Hmm. okay. How do you come to this conclusion?

My Emby docker based server has no open ports against Internet. Incoming traffic are all using traefik reverse proxy on port 443 which forwards to http://172.23.0.10:8096. Port 80 is answered with a  HTTP/1.1 302 redirect to port 443 by traefik reverse proxy.

 

Please keep in mind that streaming at home to my chromecast works but not at workplace or at a friends house where I have tested.

Link to comment
Share on other sites

Because I'm not sure the Chromecast receiver trusts the certificate, which would explain why you can stream from home but not remote.

Link to comment
Share on other sites

blinkiz

Because I'm not sure the Chromecast receiver trusts the certificate, which would explain why you can stream from home but not remote.

Oh. I do not have Emby server at home. It is located in the cloud far from home. All locations (chromecast sites/subnets in this case) are connecting the same way to my Emby docker server.

Link to comment
Share on other sites

Does the emby server dashboard display the correct local and remote addresses?

Link to comment
Share on other sites

  • 2 weeks later...
blinkiz

There exist many posts on this forum regarding problems with Emby and chromecast.

I have found out what my problem is. If IPv6 does not exist where I connect from, Emby streaming to chromecast works. If IPv6 is disabled in my DNS for docker server where Emby server is, it also works.

 

So

Chromecast is in IPv6 enabled network <-> IPv6 public address on docker server <-> Traefik reverse proxy port 443 <-> http://172.23.0.10:8096 Emby server

Does not work.

 

Any clue why this is a problem?

Edited by blinkiz
Link to comment
Share on other sites

  • 5 months later...

Hi,

I have problem too, my emby server work normally 2 chromecast ultra in my local area, my grandmam have a chromecast in remote network 3 few week ago i cant play anything this remote chromecast3.

The phone is connected Emby app. android or ios is the same problem, i push the play button but nothting happened.

I attach my server version. Can you help, how can i solve this problem?

Thank you for your help.

5db89aef38908_Kepernyofoto20191029210208

Link to comment
Share on other sites

Hi,

I have problem too, my emby server work normally 2 chromecast ultra in my local area, my grandmam have a chromecast in remote network 3 few week ago i cant play anything this remote chromecast3.

The phone is connected Emby app. android or ios is the same problem, i push the play button but nothting happened.

I attach my server version. Can you help, how can i solve this problem?

Thank you for your help.

5db89aef38908_Kepernyofoto20191029210208

 

@@zsgodor are you able to play from inside your local network? do you have a chromecast?

Link to comment
Share on other sites

On the local network you use your 192.168.xx server address, right? 

 

I'm wondering if the Chromecast receiver just can't resolve your domain name. Try removing it from the advanced section of emby server setup so that the remote address is just the ip address.

Link to comment
Share on other sites

On the local network you use your 192.168.xx server address, right? 

 

I'm wondering if the Chromecast receiver just can't resolve your domain name. Try removing it from the advanced section of emby server setup so that the remote address is just the ip address.

Hi Luke,

 

 

 

 

Yes my local address is right, i remove my domain (emby.laphinta.hu) the network settings, i try later chromecast work or no, and i reply.

5dba94ca500e9_Kepernyofoto2019103190005.

Link to comment
Share on other sites

Hi Luke,

Problem solved, when i login  my emby IP address, the playing work normally, but i dont understand why can't resolve this chromecast my domain name.

This error is a chromecast error ,or Emby?

You can ping emby.laphinta.hu?

 

zsolti$ ping emby.laphinta.hu
64 bytes from 217.197.177.76: icmp_seq=0 ttl=64 time=4.570 ms
64 bytes from 217.197.177.76: icmp_seq=1 ttl=64 time=2.643 ms
64 bytes from 217.197.177.76: icmp_seq=2 ttl=64 time=5.045 ms
64 bytes from 217.197.177.76: icmp_seq=3 ttl=64 time=1.511 ms

 

Thank You for your support.

Zsolt

Link to comment
Share on other sites

Thanks for the feedback.

 

The Chromecast receiver dns can't resolve your domain name. I can't really tell you why, only that that's what's going on.

Link to comment
Share on other sites

  • 1 year later...
8 minutes ago, Moaelyuser said:

Sorry this conversation is a bit complex. So what is the solution?

Hi, we'll help you in your topic that you've created. Thanks.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...