Jump to content

Two issues at once - library type changed and Collections stopped working


The Greens
 Share

Recommended Posts

The Greens

Okay, so out of nowhere I had two problems occur at once...

  • Collections stopped working.  Movies and TV are now displaying singular.  I tried turning Collections off and back on, but it didn't help.
  • My Adult library is set as "Home Videos and Photos".  I did have two folders in it that were displaying correctly as movies (did not inherit).  Now one of them (the actual Movies folder) has changed (it behaves as if it is storing videos) and I can't get it to change back.

I did not receive any error messages and I have not tried any corrective actions yet for fear of making it worse.  Since these two things happened at the same time, I am really concerned that an automatic update broke my system (which was working great).  How do I fix this and should I turn updates off? 

 

Thanks. 

 

server-63654940800.txt

server-63655027196.txt

server-63655027200.txt

server-63655084107.txt

server-63655084144.txt

server-63655113599.txt

server-63655199996.txt

server-63655200000.txt

Link to comment
Share on other sites

 

 

  • Collections stopped working.  Movies and TV are now displaying singular.  I tried turning Collections off and back on, but it didn't help.

Hi there, I'm having a hard time visualizing this. can you possibly show a screenshot to demonstrate the issue? Thanks.

Link to comment
Share on other sites

The Greens

Hmmm.  I've attached a screenshot of the "after", but it's not going to help much without the "before" picture, so let me add this explanation...

 

My movie library was built as "unset".  That allows me to use a folder structure to categorize by genre.  Works great. 

 

The Pixar folder includes two "Cars", two "Monster Inc." and three "Toy Story" movies.   Originally, I had one cover image for each movie (fseven images).  I then created a "Cars Collection", a "Monster's Inc. Collection" and a "Toy Story Collection".  After assigning the movies to a collection, you end up with one cover image for each collection and a cover image for each movie not in a collection.  It reduces the number of covers displayed from 14 to 10.  When you click on a collection, you are taken to a screen that shows information about that collection and a cover image for each movie in it.  From there, you can play whichever movie you want.  Looks and works great - I did it in both my Movies and TV libraries.

 

Now, all of a sudden, none of the collections are displaying in Movies or TV.  I am back to seeing individual cover images for each item in the folder.  I checked the Metadata Manager.  All of the collections are still there, and the movies or TV shows are assigned correctly....  its just not showing it that way anymore.   It's behaving as if I had unchecked the "Group movies into collections" entry in the Library/Display option screen.

post-188127-0-81206300-1519799993_thumb.jpg

Link to comment
Share on other sites

The Greens

Correct.  As far as I know, you can't create Collections any other way.  Plus, if you name it correctly, the system goes out and pulls unique covers and metadata for the collection, which is really nice. 

 

Keep in mind, it was working just fine for weeks and then, poof!  It dies at the same time the other problem appears.

Link to comment
Share on other sites

Ok this change was by design when browsing in the context of plain folders. How are you getting to your movies library in the first place?

Link to comment
Share on other sites

The Greens

So, you are telling me that you guys broke it on purpose?  Don't you think that would have been a good bit of information to share with us before doing that?

 

In answer to your question, I have multiple libraries.  My "regular" movies library is setup as "unset" type so I can sort my movies into folders.  My "adult" library is a mix of actual movies and video clips.  It was setup as "Home Videos and Pictures", which allowed me to use a folder structure and until your "change by design", the movies in displayed correctly.  Here is the odd thing... I actually have two sub-folders in that library with movie content.  One now displays as videos, but the other still displays as movies.  How's that?

Link to comment
Share on other sites

Unset content type is designed to show folder contents so I think the change makes sense.

 

I think what we need to do is deprecate the server option and move it into the UI directly.

Link to comment
Share on other sites

The Greens

Well, if I understand it correctly, "unset" could be any type of content - movie, TV or video, and then show it appropriately.  Is that correct?  Again, it was working fine that way but after the change, decided that my movie folder was now a video folder.  Is there any way to switch it back or tell the system that folder is actually movies?  As for the rest of your comment I have absolutely no idea what that means.  How do I "depreciate the server option"?

Link to comment
Share on other sites

It means I think we need to change from a global server option to more of a context-sensitive option that you can do right from the movies list. That will allow us to make users happy on both sides of this argument.

Link to comment
Share on other sites

The Greens

So at the moment, no fix for this.  Do you have any idea why one of the sub-folders is still showing them as movies?  is it possibly because I locked the metadata?  

 

On a separate note, have you figured out why Collections is no longer working?

Link to comment
Share on other sites

 

 

Collections is no longer working

 

Can you explain this, because I thought that's what i just answered?

Link to comment
Share on other sites

The Greens

Oh wow.  We are on really different pages.  I was talking about the fact that the folder that used to (correctly) show content as movies is now showing it as videos.  Looking back at this thread, are you saying that I can only use the collections feature on libraries defined as "Movies" or "TV", or are you saying that you turned off the Collections feature for all content types? 

Link to comment
Share on other sites

Ok, one thing at a time.

 

 

I was talking about the fact that the folder that used to (correctly) show content as movies is now showing it as videos.

How exactly are you determining this?

Link to comment
Share on other sites

The Greens

Ok, one thing at a time.

Quote

 

 

I was talking about the fact that the folder that used to (correctly) show content as movies is now showing it as videos.

How exactly are you determining this?

 

It's easy.  In the past, it displayed the movies just like it does a movie library....  each movie had a image of the DVD cover (which are portrait images).  Click that would take you to the detail screen that showed Info on the movie, Cast & Crew and "more like this".   Now it shows them as videos, with a landscape thumbnail.  When you click on them, you get Info, Cast & Crew and Scenes (not "More Like This").

Link to comment
Share on other sites

The Greens

So, Ia m going to rebuild the Adult "Movie" folder.  I tested it and I can get it to display correctly - I will just then lock everything in it.  I would still like an answer on the Collections issue - are you saying that we can now only use Collections on libraries actually defined as Movie or TV?  If so, why?  Why would you remove functionality?  It appeared to be working fine before.

Link to comment
Share on other sites

You can add any items to collections from any library you want, but as far as substituting them dynamically with the collection, yes the behavior has changed and my reasons as well as future plans are in previous responses.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...