Jump to content


Photo

Google Home [Official Thread]


  • Please log in to reply
370 replies to this topic

#361 moviefan OFFLINE  

moviefan

    Advanced Member

  • Alpha Testers
  • 907 posts
  • Local time: 08:41 PM

Posted 02 January 2020 - 01:24 PM

This doesnt exist on iPhone as far as I can tell.

 

I have clicked everywhere I can possible think and can't find any reference to Emby Home anywhere.

 

There's gotta be a way to clear it out and start from scratch.

 

Does anyone else that uses Emby with Google Home also have an iPhone or are you all android users?



#362 darkassassin07 ONLINE  

darkassassin07

    Advanced Member

  • Members
  • 816 posts
  • Local time: 08:41 PM

Posted 02 January 2020 - 03:53 PM

https://support.goog...tform=iOS&hl=en


Looks like 'explore' is just a compass-like icon on ios.


"Note: You must download the Google Assistant app to access apps for the Assistant." (so you'll need both the home and assistant apps)

Edited by darkassassin07, 02 January 2020 - 03:55 PM.


#363 moviefan OFFLINE  

moviefan

    Advanced Member

  • Alpha Testers
  • 907 posts
  • Local time: 08:41 PM

Posted 02 January 2020 - 07:00 PM

Yah, again, that documentation appears outdated.

 

Here is the home screen for Google Home:

 

5e0e75c22192d_IMG_8758.png

 

 

My account picture is shown where there is a black rectangle.  When I click on it this screen is shown:

 

5e0e75df1c65b_IMG_8757.png

 

Any ideas on what to do?



#364 chef OFFLINE  

chef

    Advanced Member

  • Developers
  • 4429 posts
  • Local time: 11:41 PM
  • LocationPeterborough, Canada

Posted 02 January 2020 - 07:14 PM

Yah, again, that documentation appears outdated.

Here is the home screen for Google Home:

5e0e75c22192d_IMG_8758.png


My account picture is shown where there is a black rectangle. When I click on it this screen is shown:

5e0e75df1c65b_IMG_8757.png

Any ideas on what to do?


Hi guys, I've spent the last couple days familiarizing my self with the source from Google home.

Most of the development I have done is for Alexa however after getting to know Google's dialogflow and the recent changes made to the way they set up Google home, we're going to take the next steps in getting this working again.

It should be mentioned as a side note, and something very exciting, Amazon, Google, and Apple will be (for the first time ever) pooling resources to create a standard in AI application programming across all their devices.

This is very exciting news and it is happening this year! In the meantime, we are still collaborating behind the scenes to get the fixes in place for Google home, and Amazon Alexa, and also we'll be rolling out more languages to make these skills accessable to more people.
  • darkassassin07 likes this

#365 darkassassin07 ONLINE  

darkassassin07

    Advanced Member

  • Members
  • 816 posts
  • Local time: 08:41 PM

Posted 02 January 2020 - 08:57 PM

@moviefan
You will need to install the google assistant app as well, and configure it from there. The assistant settings are not in the google home app.

https://apps.apple.c...nt/id1220976145
  • moviefan likes this

#366 moviefan OFFLINE  

moviefan

    Advanced Member

  • Alpha Testers
  • 907 posts
  • Local time: 08:41 PM

Posted 03 January 2020 - 03:13 AM

Okay I was finally able to figure this out.

 

You do have to use the Assistant App (I had this already but didnt make sense before)

 

Within the assistant app the explore icon (compass looking thing) is on the home screen on the bottom left.

 

After clicking this, it shows a bunch of nonsense.  Scroll down to the bottom and click "Your Actions."  This is where Emby Home can be found.  I was able to successfully unlink and link again.

 

However, I am still continuing to have the issue of connecting with the same error message.

 

Actually, there are two servers listed when I put in my credentials.  Both of them have the same name.  I did have a server crash so I assume it's related.  But one of them errors out about connectivity and the other one says it is unable to access me account and asks me to complete the account linking process again.

 

So, first question is - where are these linked servers stored?  How can I purge the old one?

 

And the second is, what is the problem now?  Seems like it should work but just isnt.



#367 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 148545 posts
  • Local time: 11:41 PM

Posted 03 January 2020 - 03:15 AM

Okay I was finally able to figure this out.

 

You do have to use the Assistant App (I had this already but didnt make sense before)

 

Within the assistant app the explore icon (compass looking thing) is on the home screen on the bottom left.

 

After clicking this, it shows a bunch of nonsense.  Scroll down to the bottom and click "Your Actions."  This is where Emby Home can be found.  I was able to successfully unlink and link again.

 

However, I am still continuing to have the issue of connecting with the same error message.

 

Actually, there are two servers listed when I put in my credentials.  Both of them have the same name.  I did have a server crash so I assume it's related.  But one of them errors out about connectivity and the other one says it is unable to access me account and asks me to complete the account linking process again.

 

So, first question is - where are these linked servers stored?  How can I purge the old one?

 

And the second is, what is the problem now?  Seems like it should work but just isnt.

 

Just sign into just about any Emby app using your Emby Connect credentials and you'll be able to delete the server from the server selection screen.


  • moviefan likes this

#368 moviefan OFFLINE  

moviefan

    Advanced Member

  • Alpha Testers
  • 907 posts
  • Local time: 08:41 PM

Posted 03 January 2020 - 04:02 AM

Okay that was helpful.  I was able to clear out all the associations for Emby connect, relinked, and now it is giving me the one error message about my Emby server being unreachable.

 

My server is available via an FQDN with a valid SSL certificate and worked fine with this service before.

 

What else can I troubleshoot here?  

 

I am able to authenticate remotely to the web server using Emby Connect credentials fine.  Just seems this Google Home integration that doesnt think it's reachable.



#369 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 148545 posts
  • Local time: 11:41 PM

Posted 03 January 2020 - 03:19 PM

Okay that was helpful.  I was able to clear out all the associations for Emby connect, relinked, and now it is giving me the one error message about my Emby server being unreachable.

 

My server is available via an FQDN with a valid SSL certificate and worked fine with this service before.

 

What else can I troubleshoot here?  

 

I am able to authenticate remotely to the web server using Emby Connect credentials fine.  Just seems this Google Home integration that doesnt think it's reachable.

 

What kind of cert? It could be that google home is rejecting the certificate. Does Emby Server show the SSL remote address on the server dashboard?



#370 moviefan OFFLINE  

moviefan

    Advanced Member

  • Alpha Testers
  • 907 posts
  • Local time: 08:41 PM

Posted 03 January 2020 - 10:32 PM

Thanks Luke you pointed me in the right direction.

 

I am not sure if this setting wasn't properly reconfigured after my recent server crash via the backup plugin, or if this is simply a new setting I never paid attention to and havent used Google Home since it was introduced, but this was the setting that was breaking Google:

 

5e0ff903785cd_ScreenShot20200103at63104P

 

 

That was set to disabled for me.  I switched to required for all remote connections and it fixed Google home.

 

Strange because it has been working with valid encryption with it disabled with all other features for either the last couple months or much longer.



#371 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 148545 posts
  • Local time: 11:41 PM

Posted 03 January 2020 - 11:27 PM

It's possible they might be requiring SSL for all communications now. 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users