Jump to content


Photo

4K UHD playback on an HD system?

4k uhd hd theater windows 10

  • Please log in to reply
22 replies to this topic

#1 ShoutingMan OFFLINE  

ShoutingMan

    Advanced Member

  • Members
  • 678 posts
  • Local time: 01:05 AM

Posted 04 February 2018 - 05:09 PM

I now have my a UHD video (from the one UHD 4K disc I own) and also the HD version. Impressively, Emby Theater on Windows 10 plays the UHD video pretty well. Audio and Video in my brief check played without stuttering or losing sync. That's cool and unexpected for me.

 

But I noticed on a scene with large white region (the Hockey rink in Deadpool, about 1:02:00 (hh:mm:ss) in) there was large macro-blocking visible. It's not there in the HD version, so it's from the on-the-fly conversion of 4K down to HD.

 

What, if anything, can I tweak in Emby Theater or Server to get better playback of 4K material on my 2K system? It would be a bonus if I could start collecting 4K media and only have to keep the 4K file saved, trusting Emby to play it perfectly on my HD system. That might be not practical, but it's worth a check. :)

 

My Emby Server (and playback PC) is a 6th Gen Core i5-6500 with Intel HD Graphics 530 (integrated graphics). 

 

Thanks for any insights into how UHD is played back at HD from Emby and tips to improve that performance!



#2 jhoff80 OFFLINE  

jhoff80

    Advanced Member

  • Members
  • 352 posts
  • Local time: 01:05 AM

Posted 04 February 2018 - 05:37 PM

From my understanding and trials at this with demo files, the big problem is going to be tone mapping the HDR video from the UHD Blu-ray for SDR screens.  You'll end up with a lot of blown-out highlights without that tone mapping process.  madVR is the best way to handle that conversion last I looked, but that won't be compatible with all devices / players.


  • ShoutingMan likes this

#3 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13395 posts
  • Local time: 10:05 PM

Posted 04 February 2018 - 06:19 PM

I you're using the desktop app, the server won't have any involvement. Can you post a screenshot of your stats, while playing that video?



#4 ShoutingMan OFFLINE  

ShoutingMan

    Advanced Member

  • Members
  • 678 posts
  • Local time: 01:05 AM

Posted 04 February 2018 - 10:09 PM

From my understanding and trials at this with demo files, the big problem is going to be tone mapping the HDR video from the UHD Blu-ray for SDR screens.  You'll end up with a lot of blown-out highlights without that tone mapping process.  madVR is the best way to handle that conversion last I looked, but that won't be compatible with all devices / players.


That’s a good point. I’ve seen a few other comments about this aspect of playback. I’ll just keep both for now until I can upgrade to a 4K display. I have all of one UHD movie so far, so I’m not yet pressed for storage.

#5 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13395 posts
  • Local time: 10:05 PM

Posted 04 February 2018 - 10:43 PM

MPV handles HDR with ease. 

 

https://emby.media/c...r-evc/?p=521624

 

But maybe the conversion to 1080, affects it.


Edited by Doofus, 04 February 2018 - 11:57 PM.


#6 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13395 posts
  • Local time: 10:05 PM

Posted 04 February 2018 - 11:03 PM

If you want to eliminate the HDR, add this line to your mpv.conf

vf=format=colormatrix=bt.709:primaries=bt.709

Edited by Doofus, 04 February 2018 - 11:58 PM.

  • ShoutingMan likes this

#7 ShoutingMan OFFLINE  

ShoutingMan

    Advanced Member

  • Members
  • 678 posts
  • Local time: 01:05 AM

Posted 04 February 2018 - 11:58 PM

Here's a screengrab with Stats for Nerds playing the UHD MKV. Scaling is set to Auto.

 

I did a quick check after this with Scaling set to "Mitchell", which the MPV docs say is good for downscaling. The wide field of the hockey ring still had the macro blocking.

 

Next chance I have for Emby experimenting, I'll take a look at the HDR stripping. That looks like a promising lead. :)

Attached Files



#8 ShoutingMan OFFLINE  

ShoutingMan

    Advanced Member

  • Members
  • 678 posts
  • Local time: 01:05 AM

Posted 05 February 2018 - 12:05 AM

I did a quick trial, putting the HDR stripping line in my conf file. No effect on the macroblocking. So it's not HDR specific artifacts.



#9 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13395 posts
  • Local time: 10:05 PM

Posted 05 February 2018 - 12:08 AM

Try changing your HWA to auto copyback.



#10 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13395 posts
  • Local time: 10:05 PM

Posted 05 February 2018 - 12:09 AM

And your refresh rate to 60Hz



#11 ShoutingMan OFFLINE  

ShoutingMan

    Advanced Member

  • Members
  • 678 posts
  • Local time: 01:05 AM

Posted 05 February 2018 - 12:56 AM

And your refresh rate to 60Hz

I don’t think playing UHD at the wrong frame rate will improve its downscaling or colorspace conversion. :)

I’ll check the copy back. I think I just leave most everything to Auto except the frame rate refresh.

Edited by ShoutingMan, 05 February 2018 - 12:57 AM.


#12 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13395 posts
  • Local time: 10:05 PM

Posted 05 February 2018 - 01:20 AM

MPV seems to really like 60Hz. Don't rule it out before you test it. I run everything at 60Hz and it's smoother than refresh rate switching. 

 

Using D3D11 with convert 10bit to 8bit. Using copyback, will eliminate that.


  • markyp likes this

#13 ShoutingMan OFFLINE  

ShoutingMan

    Advanced Member

  • Members
  • 678 posts
  • Local time: 01:05 AM

Posted 05 February 2018 - 08:17 AM

MPV has constant judder MPV playing off nominal refresh rate, on my PC. That’s why I’ve been so outspoken about getting refresh rate switching working correctly.

#14 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13395 posts
  • Local time: 10:05 PM

Posted 05 February 2018 - 11:14 AM

I know you've had that issue, but the last update made some real improvements.

#15 ShoutingMan OFFLINE  

ShoutingMan

    Advanced Member

  • Members
  • 678 posts
  • Local time: 01:05 AM

Posted 06 February 2018 - 12:36 AM

I’ll take a look. But I’m a believer in proper frame rates without interpolation. :)

#16 ShoutingMan OFFLINE  

ShoutingMan

    Advanced Member

  • Members
  • 678 posts
  • Local time: 01:05 AM

Posted 06 February 2018 - 12:40 AM

Hmmm, this is interesting:

--video-unscaled=<no|yes|downscale-big>
Disable scaling of the video. If the window is larger than the video, black bars are added. Otherwise, the video is cropped, unless the option is set to downscale-big, in which case the video is fit to window. The video still can be influenced by the other --video-... options. This option disables the effect of --panscan.

Note that the scaler algorithm may still be used, even if the video isn't scaled. For example, this can influence chroma conversion. The video will also still be scaled in one dimension if the source uses non-square pixels (e.g. anamorphic widescreen DVDs).

This option is disabled if the --no-keepaspect option is used.


Edited by ShoutingMan, 06 February 2018 - 12:41 AM.


#17 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13395 posts
  • Local time: 10:05 PM

Posted 06 February 2018 - 01:09 AM

I do agree that it shouldn't have anything to do with your issue, though. It appears to be something with the renderer. From what mpv is saying, auto copyback looks to be the safest.

 

5a7937be4d7b2_Snapshot_435.jpg

 

5a7937d99a589_Snapshot_434.jpg


Edited by Doofus, 07 February 2018 - 01:28 AM.


#18 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13395 posts
  • Local time: 10:05 PM

Posted 06 February 2018 - 01:17 AM

Here's something

 

--correct-downscaling

 

https://mpv.io/manua...ect-downscaling



#19 ShoutingMan OFFLINE  

ShoutingMan

    Advanced Member

  • Members
  • 678 posts
  • Local time: 01:05 AM

Posted 06 February 2018 - 09:11 PM

Thanks, will check what hardware processing option I have set and the MPV downscaling option(s).



#20 ShoutingMan OFFLINE  

ShoutingMan

    Advanced Member

  • Members
  • 678 posts
  • Local time: 01:05 AM

Posted 12 February 2018 - 06:13 PM

Try changing your HWA to auto copyback.

 

Auto:

Chroma artifacts on the hockeyrink scene

Playback is smooth

 

Auto (Copyback):

Chroma artifacts not apparent

Playback is choppy in places

 

 

I had this in the conf file for both cases:

vf=format=colormatrix=bt.709:primaries=bt.709

So it seems I don't have the CPU or GPU for realtime UHD downscaling to HD.







Also tagged with one or more of these keywords: 4k, uhd, hd, theater, windows 10

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users